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Chapter 1  Getting Started

About this chapter

This chapter introduces the major features of Raven using some of the 
sound files supplied with the program as examples. Many details of how 
these features work are deferred until later chapters. We recommend that 
you read this chapter at the computer and try the examples as they’re dis‐
cussed. We assume you know how to browse for files on your computer, 
and have installed Raven as discussed in the Raven README file.

In this chapter you’ll learn how to:
•understand the basic layout of the Raven window
•open an existing sound file using Raven
•understand the sound window
•play all or part of a sound file
•copy part of a sound file
•save all or part of a sound file
•save your workspace
•record new signals

The Raven window

Launch Raven by double‐clicking on its icon. (Depending on how you 
installed Raven, there may be an icon for it on your desktop, in your Start 
menu (Windows), in your dock (Mac OS), or you may have to open the 
Raven folder to find it.) After launching the Raven software, you will be 
greeted by the Raven window (Figure 1.1) with its four main components.

Menu bar Raven’s menu bar appears just below the title bar of the Raven window on 
Windows computers and at the top of the screen on Mac OS computers.

Control toolbar  The control toolbar contains controls for common Raven operations. When 
you position the mouse pointer over a control in the toolbar, a “tooltip” 
appears giving the name of the tool.

Side panel On the left side of the Raven window is the side panel. The side panel con‐
tains tools that let you control various aspects of how signals are displayed 
and played back. 

Raven desktop To the right, the main area of the screen is the Raven desktop. This area is 
your workspace and will contain open sounds and other files.
Raven Pro 1.3 User’s Manual 1
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Figure 1.1 The Raven window

Figure 1.1. The Raven window, showing the four main components 
(menu bar, control toolbar, side panel, and the desktop.)

For more information on the Raven window layout and functionality, 
please visit Chapter 2, “The Raven Window”.

Opening a sound file 

To open a sound file, choose File > Open Sound Files... , or type <Ctrl-O> 
(Windows) or <Command-O> (Mac OS). You will then see Raven’s Open 
Sound Files dialog box (Figure 1.2)
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Figure 1.2 Open Sound Files dialog

Figure 1.2. Open Sound Files dialog box on a Windows computer (top) 
and a Mac OS computer (bottom).

The Open Sound Files dialog box displays a scrolling list of the files and 
directories in the current directory. The name of the current directory is 
given at the top of the dialog box. If the current directory is not “Exam‐
ples”, find the Examples directory now in the Raven program directory. 
(To move up in the file system hierarchy, click on the name of the current 
directory and select another directory from the pull‐down menu that 
appears. To move down the hierarchy, double‐click on the name of a direc‐
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tory in the scrolling list of files and directories within the current direc‐
tory.)

Select the file named “ChestnutSidedWarbler.aif” in the Examples direc‐
tory. Click the Open button, or double‐click on the filename. The Config‐
ure New Sound Window dialog box appears (Figure 1.3) 

Figure 1.3.  Configure New Sound Window dialog

Figure 1.3. The Configure New Sound Window dialog box

Window preset and
paging

The Configure New Sound Window dialog box allows you to choose a 
window preset that controls the layout of a sound window (for more 
information on sound window presets, see “Sound window presets” in 
Chapter 11 (page 255)), and to control how much of the sound is loaded 
into Raven’s working memory at one time (see “About Raven memory 

WINDOWS On Windows computers, the Audio File Format panel 
on the right side of the Open Sound Files dialog box 
displays information about the currently selected file.

MAC OS On Mac OS, the file information is displayed on the left-
hand side of the dialog box.
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allocation” in Chapter 11 (page 262) for more information on how Raven 
uses memory.)

Speed correction The Speed tab of the dialog box gives you options to correct the recorded 
speed of a stored sound.  For more information on this, see “Correcting 
speed when opening file” in Chapter 7 (page 167).

For now, click OK at the bottom of the dialog box to accept the default set‐
tings.  A sound window appears on the Raven desktop (Figure 1.4)

Figure 1.4 Sound window

Figure 1.4. A sound window shown on the Raven desktop.

The title bar of the sound window shows a sequential number (starting at 
1) that Raven assigns to each sound you open, and the name of the file.

When Raven is running, you can open any WAVE or AIFF 
sound file by dragging its icon from an Explorer (Windows) or 
Finder (Mac OS) window or from the desktop and “dropping” 
the icon anywhere in the Raven desktop.
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Opening sounds in
different file formats

Raven also  enables you to open sound files in .mp3 (with the exception of 
variable bitrate mp3 files), .mp4, .aifc, and QuickTime movie soundtrack 
(.mov) formats.  In order to access files in these formats, you must have 
QuickTime (QT) for Java installed on your computer.  Raven does not 
include the ability to save sound files in these additional formats.

Opening files from
Canary

Raven Pro can open sound files saved in the Canary file format. Under 
Mac OS X, Raven Pro can open these files directly. In order to open Canary 
files in Raven Fro on a computer running Windows, you must first convert 
the files to MacBinary format on a Mac OS computer, then copy the files to 
the Windows machine. You can convert Canary files to MacBinary by 
using a free conversion program available at:

http://www.birds.cornell.edu/brp/software/canary-converters

To open a recently used sound file, choose the file’s name 
from the list of recent files at the bottom of the File menu.  By 
default, Raven displays the four most recent files.  To open a 
file from a folder that you recently used within Raven, choose 
File > Open Recent Folder > folderName.

WINDOWS You can check whether QT for Java is installed by look-
ing at the Download QuickTime Installer item on the 
Help menu.  If QT for Java is already present, the menu 
item will be disabled.  If the menu item is enabled, click 
on it and follow the instructions that appear in your web 
browser to install QT for Java.

MAC OS QT for Java is already installed on Mac OS computers.  
Mac OS users can also open CD audio tracks with 
Raven.  Audio CD tracks will be displayed in the   /Vol-
umes folder as AIFC files that can be accessed from 
Raven’s Open Files dialog.

 Converting the files to MacBinary format is necessary 
because Mac files have a two‐part structure that is not prop‐
erly preserved if the file is simply copied from a Mac to a 
Windows machine. The MacBinary format stores both parts 
of a Mac file in a single file that can be transferred to a Win‐
dows computer with no loss of information.
6 Raven Pro 1.3 User’s Manual



Chapter 1:  Getting Started
Note that while Raven Pro can open sound files saved by Canary in the 
Canary file format and in the AIFF file format, Raven Pro cannot open files 
saved by Canary in the MATLAB, SoundEdit, Text, or Binary formats.

Understanding the Sound Window

By default, when you first open a sound file, Raven shows you a sound 
window that contains two views of the sound (see Figure 1.5) The waveform 
(upper) view displays an oscillogram, or graph of the sound showing 
amplitude versus time. The spectrogram (lower) view represents time on 
the horizontal axis, frequency on the vertical axis, and relative power at 
each time and frequency as a color (by default grayscale) value. Spectro‐
gram views are discussed further in “Spectrogram views” in Chapter 5 
(page 115).

Figure 1.5 Sound window

Figure 1.5. A sound window showing a waveform view (top) and a 
spectrogram view (bottom).

In addition to waveforms and spectrograms, Raven can also display spec‐
trogram slice views of a signal, and selection spectrum views, which show 
the average spectrum of a selected portion of a signal. Spectrogram slice 
views and selection spectrum views are discussed in “View Types” in 
Chapter 3 (page 50). Chapter 3, “Sound Windows: Visibility, Views, Link‐
age, & Navigation” also explains how to configure Raven to display com‐
binations of views other than the default waveform and spectrogram 
when a signal is first opened.

Playing a sound

The sound playback controls can be found in the right‐hand end of the 
control toolbar (Figure 1.6) Make sure the ChestnutSidedWarbler.aif 
sound window is open, as directed in “Opening a sound file” on page 2.  
To play the sound, click the Play button, or press <Ctrl-Shift-P> (Windows) 
or <Command-Shift-P> (Mac OS).
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Figure 1.6.  Playback controls 

Figure 1.6.  The playback controls in the control toolbar.

As the sound plays, a vertical green line, the playback cursor, moves across 
the waveform from left to right to show you what part of the signal you 
are hearing. To stop playing at any time, click the Stop button. When the 
selection finishes playing, or when you click Stop, the playback cursor dis‐
appears.

Making a selection To choose a portion of the signal, click and drag your mouse from one 
point in the sound to another a point, in either the waveform or spectro‐
gram view.  Raven will mark your selection with a colored rectangle.  For 
more about making selections, see Chapter 6, “Selections: Measurements, 
Annotations, & Editing”.

Playing a selected
part of a signal

Once you’ve made a selection, you can choose to play only that portion of 
the sound by clicking the Play button. To play the entire sound again, clear 
the selection using View > Active Selection > Clear, or go through the con‐
text menu..

Scrolling playback
and position

markers

The vertical and horizontal magenta lines in each view are the position 
markers. Each view in a sound window has two position markers which 
identify unique locations along the horizontal and vertical axes. The verti‐
cal line on the left‐hand side of each view is the time axis marker (which 
marks one specific time value.) Position markers are important for several 
types of Raven operations, and are discussed further in “Position mark‐
ers” in Chapter 3 (page 44)

Using the mouse, grab the time axis position marker (the vertical magenta 
line) in either the waveform or spectrogram view and move it slightly 
away from the left edge of the window (Figure 1.7). Next, click the Scroll-
ing Play button to play the signal. In scrolling playback, the signal view 
scrolls from right to left beneath the position marker, like tape moving 

For most views, Raven will play the visible portion of the 
sound unless there is an active selection marked.  For spec-
trogram slice and selection spectrum view, if there are no 
selections, Raven will play the entire sound. This holds true 
for reverse playback as well.
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Chapter 1:  Getting Started
past the playback head of a tape recorder. The position marker identifies 
the point in time that you are hearing.

Figure 1.7 sound window, pos marker moved.

Figure 1.7.  The BeardedSeal sound window, with the time axis posi-
tion marker moved away from the left edge of the window. The win-
dow’s scroll thumb is also labeled.

Playback rate You can speed up or slow down the playback rate of the signal. By default 
the playback rate is set at 1.0, or the same as the recording rate. Slowing 
down the rate makes the sound lower in pitch and slower; speeding it up 
makes it higher in pitch and faster. Try it now: type a number greater than 
1 in the rate box to speed up or a decimal number between 0 and 1 to slow 
down, press <Enter>, and then play the sound again.

During scrolling playback, you can drag the scroll thumb to 
move the signal so that a particular point of interest is at the 
time position marker.  The sound stops playing while you drag 
the scroll thumb and resumes immediately at the new time 
position when you release the scroll thumb.
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Copying Part of a Sound 

You can copy data in the active selection using commands on the Edit 
menu or standard keyboard equivalents. When you copy a selection, a 
copy of the selected data is put in the clipboard. The Paste command 
inserts the contents of the clipboard at the time of the active selection in 
the active sound window. If the active selection is a range (rather than a 
point), the clipboard contents replace the data in the selection. If there is 
no active selection, the Paste command is unavailable. Data on the clip‐
board can be pasted into the same sound window or into a different one. 

Copying a selection
to a new sound

window

Create a new empty sound window by choosing File > New > Sound Win-
dow or by typing <Ctrl-N> (Windows) or <Command-N> (Mac OS). Next, 
make a selection in the ChestnutSidedWarbler.aif sound.  Go to Edit > 
Copy to copy the data in the selection to the clipboard.  Next, click on the 
new sound window to make it active and select Edit > Paste. You should 
now see the selection you made in the ChestnutSidedWarbler.aif sound 
appear in the new sound window (see Figure 1.8).

Figure 1.8 Copy a Selection

Figure 1.8. A selection from ChestnutSidedWarbler.aif copied into a 
new sound window.
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Copy a selection to
an existing sound

With both sound windows open, make a new selection in the ChestnutSid‐
edWarbler.aif signal. Copy this selection by choosing Edit > Copy, click in 
the middle of the second sound window to create an active selection, and 
paste the new selection there by choosing Edit > Paste (Figure 1.9)

Figure 1.9 Copying a Selection into a Sound

Figure 1.9. A second selection from ChestnutSidedWarbler.aif copied 
and pasted into the middle of the sound in the bottom window.

 Saving All or Part of a Sound

You can save the active signal in a sound file, either in WAVE format (file‐
name extension .wav) or in AIFF (Audio Interchange File Format, file‐
name extension .aif) format. WAVE files can be opened by most other 
programs that work with audio data. AIFF files can be opened by most 
Macintosh programs that work with audio data, and some programs on 
other platforms.

To choose a file format (WAVE or AIFF), and a sample size for the file to be 
saved, use the Files of Type drop‐down menu in the Save As... dialog box 
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(Figure 1.10). Choice of sample size is discussed in Appendix A, “Digital 
Representation of Sound”.

Saving a signal To save a sound, choose File > Save “Sound N” or File > Save “Sound N” 
As... . Choosing Save “Sound N” simply saves the sound under the same 
filename in the same location as the last time the sound was saved. If the 
sound has never been saved, Raven asks you to specify a location and 
name for the file. Choosing Save  “Sound N” As... allows you to specify a 
new location and/or name for the file to be saved (Figure 1.10)

Figure 1.10 Save As... Dialog Box

Figure 1.10. This is the Save As... dialog box.  After choosing a sound 
file or a sound selection to save, you can select a location for the file 
and specify a file name.

Saving a selection After making a selection, within the ChestnutSidedWarbler.aif signal for 
example, choose File > Save Active Selection As... and you will see the 
Save As... dialog box (Figure 1.10) After entering a name for your selection 
and clicking Save, the active selection is saved into a new file by itself 
which can be opened at any time.

Files saved in WAVE or AIFF formats contain only the actual 
audio data. Information that is specifically for use with Raven 
(such as selection tables and layout parameters) is not saved 
in these files.
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Saving Your Workspace

When you save a workspace, all aspects of Raven’s state are saved. By sav‐
ing a workspace first, you can quit Raven and resume your work later 
exactly where you left off, even if you have many sound windows open.

Saving a
workspace

When you save a workspace, all information about Raven’s state is saved, 
including all open signals and the size and placement of their windows. 
To save the workspace, choose File > Save Workspace As... . Raven work‐
space files can be saved anywhere, and must have a filename extension of 
.wsp.

Opening a
workspace

To open a workspace file, choose File > Open Workspace... . If you have 
any sound windows open, Raven will warn you that they will be lost 
when the workspace file opens, and ask if you want to proceed. If there are 
signals open with unsaved changes, Raven gives you the opportunity to 
save them before opening the workspace file. Once the saved workspace 
opens, Raven is completely restored to its state at the time the workspace 
was saved.

You can also open a Raven workspace by dragging the work-
space file’s icon from the computer’s desktop, a Windows 
Explorer window, or from a Mac Finder window, and dropping 
the icon on the Raven desktop.

Earlier versions of Raven could not open workspace files if 
any of the sound files they included had been moved.  Now, if 
Raven cannot find a sound file needed for a workspace that is 
opening, the program will present a dialog box (Figure 1.11) 
listing the missing file(s) and will allow you to find the file by 
browsing through the system.

If you copy or move a workspace file to a different computer, 
you must also copy or move the sound files and selection 
table files (and their parent folders) that are referenced by the 
workspace in order for Raven to open the workspace prop-
erly.
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Figure 1.11 Workspace Resolver Dialog

Figure 1.11. Raven’s Workspace Resolver Dialog (top).  This appears if 
you attempt to open a workspace file with missing or moved sound files.  
If you wish to find the missing file, choosing Browse... displays the 
Select Dialog (bottom) which allows you to browse for and select the 
sound file.
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Printing

To print the active sound window, choose File > Print “Sound N”..., or 
press <Ctrl-P> (Windows) or <Command-P> (Mac OS), then click OK in 
the print dialog that appears. 

By default, Raven prints in portrait orientation. To change to landscape 
orientation, choose File > Printer Page Setup, and choose Landscape ori‐
entation in the Page Setup dialog. The currently selected print orientation 
is indicated by the orientation of the page icon next to Printer Page Setup 
in the File menu.

Exporting images to
files

To save an image of all or part of the Raven window as a graphics file, 
choose File > Export Image Of. A submenu appears showing the graphics 
objects that Raven can copy: the entire Raven window, the active sound 
window, all views within the active sound window, or each individual 
view within the active window. Choose whichever object you want to 
export from the submenu. In the Export Image dialog box that appears, 
choose a graphics file format. Any of the four graphics objects can be 
saved in  PNG, TIFF, JPEG, or BMP format. Views can also be saved in 
Encapsulated Post Script (EPS) format, but image scaling does not work 
for this format.

Copying images to
the clipboard

To copy an image of all or part of the Raven window so that you can paste 
it into a document in another program, choose Edit > Copy Image Of. A 
submenu appears showing the four graphics objects that Raven can copy: 
the entire Raven window, the active sound window, all views within the 
active sound window, or the active view of the active window. Choose 
whichever object you want to copy from the submenu. The copied image 
can be pasted into documents in any program that works with graphic 
images.

When Raven prints, it sends an image of the active window 
directly to the printer without rescaling or resizing. You may 
need to experiment with the horizontal and vertical size of the 
window to achieve the desired printed result. For more flexi-
bility with printing Raven images, try exporting them to files or 
copying them to the clipboard (see below).

If you click on the printer Properties button in the Print dialog, 
a dialog appears that contains another set of controls for 
choosing page orientation. These controls may not correctly 
display or allow you to change the actual page orientation. To 
change the page orientation, always use File > Printer Page 
Setup.
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Recording a sound (acquiring input)

Raven obtains its audio input from an audio source (e.g., a tape recorder, 
CD player, or microphone) connected to a particular port on an audio 
input device installed on your computer (e.g., microphone or line input 
port of an internal sound card or USB sound input device).

Raven can acquire a signal directly to a file, to a sequence of files, or to 
memory only (without saving to disk). While Raven is acquiring input you 
can see multiple views— waveforms, spectrograms, spectrogram slices— 
scroll by in real time.

This section covers acquiring a signal to memory. Recording to a file or file 
sequence is discussed in Chapter 4, “Signal Acquisition (Recording)” and 
also covers decimating the input signal (acquiring it at a lower effective 
sample rate).

Selecting an audio
input device

You use controls supplied by the operating system to choose and config‐
ure the audio input device that Raven will use. Appendix A, “Digital Rep‐
resentation of Sound” discusses how to choose a particular audio input 
device on each operating system. Before proceeding further, you should 
refer to the appendix to ensure that your system is properly configured.

Connect an audio source (e.g., tape recorder, CD player, or microphone) to 
the appropriate port of the audio input device you selected.

Create new
recorder

To ready Raven for acquiring a signal, click on the Record button on the 
control toolbar (Figure 1.12) You can also press <Ctrl-R> (Windows) or 
<Command-R> (Mac OS), or choose File > New > Recorder... Doing so will 
display the Configure New Recorder dialog box (Figure 1.13)

Figure 1.12 Record button

Figure 1.12. The Record button, located in the control toolbar of the 
Raven desktop.
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Figure 1.13. New Recorder dialog.

Figure 1.13.  Raven's Configure New Recorder dialog box.

Use fields in the Configure New Recorder box to acquire the signal to 
memory or to one or more files, to choose which input device and device 
configuration to use, and to specify how to display the sound while it’s 
being acquired. For now, to give you a feel for Raven’s capabilities, we’ll 
go over how to record sounds to memory (without saving them to disk) 
and what you can do with the signal as it’s coming in. Chapter 4, “Signal 
Acquisition (Recording)” explains in detail what each of the fields in this 
dialog box do. For now, just leave all the fields as they are and click OK or 
press <Enter>.

The Recorder
Window

When you click OK or press <Enter> in the Configure New Recorder dia‐
log box, a new recorder window appears on the Raven desktop (Figure 
1.14). A recorder window looks and behaves like any other Raven sound 
window except that it has additional controls displayed in the status bar at 
the bottom of the window.
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Figure 1.14. Recorder window (to memory).

Figure 1.14. A new Recorder window, configured for recording one 
channel to memory.

Starting and
stopping the real-

time signal display

Click the triangular green Record-to-Memory button (Figure 1.14) to start a 
real‐time scrolling waveform display in the recorder window. When you 
start providing an audio signal (by starting playback of a tape or CD, or by 
speaking into a microphone), you should see a waveform appear at the 
right edge of the waveform window and scroll across to the left. The 
Record-to-Memory button is replaced by a square Stop Recording button, 
and the status field next to the button displays the message “Recording to 
memory”. 

When the waveform reaches the left edge, the oldest data are discarded to 
make room for the newest data. Time counts up from the right side and 
scrolls across the view. Clicking the Stop Recording button stops record‐
ing. If you click the button to start recording again, Raven clears the 
Recorder window before beginning to display the new signal.

By default, when recording to memory only, Raven records into a 30‐sec‐
ond sound buffer. You can specify a longer sound buffer when configuring 
the recorder (see “Buffer Size” in Chapter 4 (page 74)).

While recording is
stopped…

When you stop a recording, the most recent part of the signal remains dis‐
played on the screen. You can do anything with this signal fragment that 
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you can do with a signal in any other sound window: save it, make selec‐
tions from it, copy from it, print it— whatever you like. Remember that if 
you have been recording for a while you will only have the latest part of 
the signal to work with (only what can be displayed), and not the entire 
signal from the point at which you began recording. 

More about
recording

Chapter 4, “Signal Acquisition (Recording)” covers the recording process 
in more depth. Read that chapter to find out:
•how to select and configure your input device
•how to record to a file or a sequence of files
•how to incorporate date‐ and time‐stamps into names of acquired files
•how to acquire signals at lower sample rates than those available from an 
audio input device (signal decimation)

•other operations to perform while recording
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About this chapter

In this chapter you’ll learn about the three main parts of the Raven Win‐
dow and how to adjust the appearance of the application. Topics include:
•the Menu bar.
•the Toolbars.
•the Side panel and mouse measurement field.
•changing the appearance of the Raven Window.

The Menu bar

The menu bar appears below the title bar on the top left of the Raven win‐
dow on Windows computers and at the top of the screen on Mac OS com‐
puters (Figure 2.1.)

Figure 2.1 The Menu bar

Figure 2.1. The Menu bar on a Windows computer.

Each entry on the menu bar contains specific commands and controls to 
help you utilize all Raven’s tools. The following is a brief discussion of the 
menu bar entries that is intended to familiarize you with each menu item 
and its contents.
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The File menu Figure 2.2 The File menu

Figure 2.2. The contents of the File menu.

‘New’ section in File menu
The first two entries are in the ‘New’ section of the File menu, which were 
discussed in Chapter 1, “Getting Started”. You can choose to create a new 
sound window,  new recorder window or a new selection table.  These 
these menu options also have keyboard shortcuts which are listed to the 
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far right of each menu item (<Ctrl-N> for New Sound Window in Windows, 
for example.)

‘Open’ section in File menu
The next section contains the ‘Open’ options, some of which were dis‐
cussed in Chapter 1, “Getting Started”. You can choose to open an existing 
sound file, open from a CD, open sound from a folder that you recently 
used, open a selection table (which will be discussed in “The Selection 
Table” in Chapter 6 (page 135)) or open a previously saved workspace.  
Again, some of these ‘Open’ options have keyboard shortcuts listed to the 
far right if you prefer using those.

‘Close’ section in File menu
The ‘Close’ section contains commands used to close files and other items 
that you were working with. You can choose to close an individual sound 
file, close a selection table (more on these in (“Selection Tables” in Chapter 
6 (page 135))) or to simply close all the files open on the Raven desktop.

‘Save’ section in File menu
There are many options for saving your work, several of which were men‐
tioned in Chapter 1, “Getting Started”. In the Save section, you can save 
sound files, selection tables, and workspaces that have already been saved 
somewhere.  To save items for the first time, or to save a file under a new 
name, choose Save as... “Saving as...” is available for sound files, selection 
tables, active selections, all selections, selected channels, and workspaces.

‘Print’ section in File menu
In the ‘Print’ section, you can choose to print a sound file, print sections of 
the file, or make changes to the page setup which will adjust the printed 
output. Remember that the printer Properties button in the Print dialog 
may not correctly display or change the page orientation; page settings 
should only be adjusted through the File > Page Setup... menu item.

‘Export’ section in File menu
This section has options for exporting images (discussed in “Exporting 
images to files” in Chapter 1 (page 15)) as well as exporting samples from 
sound file views (more on this in “Export output and text file content” in 
Chapter 6 (page 152)).

‘Exit’ in File menu
When you are finished using the Raven, you can exit the application by 
choosing File > Exit from the menu bar or by clicking the system close icon 
in the window title bar.

‘Recent Files’ section in File menu
This section of the File menu contains the four files most recently used by 
Raven.  Selecting one of the files listed here will automatically open the 
sound in a new window on the Raven desktop.  This feature is designed to 
give you easy access to files you might want to use.
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The Edit menu Figure 2.3 The Edit menu

Figure 2.3. The contents of the Edit menu.

Undo/Redo items in Edit menu
After performing an edit operation, you may wish to undo your change.  
To revert back to the previous state, choose Undo.  In some cases, you may 
wish to reapply a change that was just revoked.  To remake a change that 
was undone, choose Redo. Note that the action you will be undoing/redo‐
ing will also be listed in the menu (for example, Undo Filter or Redo 
Paste).

‘Editing’ section in Edit menu
The main section of the Edit menu contains commands to Cut or Copy a 
selection to the clipboard, Paste a selection from the clipboard, or Delete a 
selection. These editing options all deal with sound samples, and more 
information about these processes can be found in “Editing a sound” in 
Chapter 6 (page 132).

Filter/Amplify items in Edit menu
Also in the Edit menu, you can choose to Filter and/or Amplify parts of 
signals.  More details on these processes can be found in “Filtering and 
amplifying sounds” in Chapter 6 (page 133).

Copy Image Of
Similar to the Export Image Of... function in the File menu, you can choose 
to copy image information to the clipboard from within the Edit menu. 
Selecting Copy Image Of allows you to copy an image of the entire Raven 
window, a particular sound window, or certain views within a sound win‐
dow to the clipboard for use in other applications.

Select All
Choosing this menu item selects all information displayed in the Raven 
sound window. In cases where you need to make changes or edit all the 
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information displayed, this bypasses the time and effort required to indi‐
vidually select everything. Also, if the sound window is zoomed to a sub‐
set of the entire sound, only the visible subset of the current view will be 
selected.

The View menu Figure 2.4 View menu

Figure 2.4. The contents of the View menu.

Basic commands
From this menu, you can select which toolbars are visible and you can lock 
their positions. You can create a new view or work with window presets 
(see more on these topics in Chapter 3, “Sound Windows: Visibility, Views, 
Linkage, & Navigation” and Chapter 11, “Customizing Raven: Prefer‐
ences, Presets & Memory”). You can choose to apply the view settings of a 
sound window to all other open windows and you can also adjust config‐
uration settings of a recorder.

‘View’ section in View menu
This section contains commands that allow you to adjust views by hiding 
them, deleting them or moving them up and down within sound window.  
More information regarding views is discussed in Chapter 3, “Sound Win‐
dows: Visibility, Views, Linkage, & Navigation”.

Unlinking
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You can choose to unlink views within a sound window by selecting this 
submenu. Details on how this works and when you might want to do this 
can be found in “Linking and unlinking views” in Chapter 3 (page 53).

Configure view
Views can be adjusted in several ways. The color scheme can be changed, 
and the display axes of the view can be adjusted. For more information on 
how to adjust views, see Chapter 3, “Sound Windows: Visibility, Views, 
Linkage, & Navigation”.  This section may also have more menu items 
available depending on the active view (spectrogram views, for example, 
will have entries allowing you to adjust spectrogram parameters and 
smoothing.)

Detectors
You can select and run interactice detectors by choosing this item.

Measurements/Labels
You can choose to make measurements of displayed information in the 
selection table and to label individual selections in the views.  More infor‐
mation on this can be found in Chapter 6, “Selections: Measurements, 
Annotations, & Editing”.

Selections
After making selections, there are many things you can do with them, 
including copying, clearing, and pasting them. Some of these commands 
can be found in the Active Selection submenu. Basic selection copying was 
discussed in “Copying Part of a Sound” in Chapter 1 (page 10) and you 
can find more details on selections and various ways to work with them in 
Chapter 6, “Selections: Measurements, Annotations, & Editing”.

The Window menu Figure 2.5 Window menu

Figure 2.5. Contents of the Window menu.
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Management
This section of the Window menu contains advanced commands to control 
aspects of Raven’s performance. You can find more information about 
these options in Chapter 11, “Customizing Raven: Preferences, Presets & 
Memory”.

Window organization
Tile and Cascade Windows are two ways to organize sound windows on 
the Raven desktop. Details about these commands can be found in “Tile/
Cascade windows” in Chapter 3 (page 68).

Appearance
The appearance of the Raven application and desktop area can be 
adjusted. For more instructions on personalizing Raven’s appearance, see 
“Selectable look and feel, desktop background color, tooltip color” in 
Chapter 11 (page 256).

Window Selection
If you have multiple sound windows open on the Raven desktop, they will 
be listed in the Window menu. Choosing one of them from the bottom of 
the Window menu will activate that window and bring it to the front.  This 
makes it easier to find exactly the sound window you need.

The Tools menu Figure 2.6 Tools menu

Figure 2.6. Contents of the Tools menu.

The items in the Tools menu are advanced ways to work with data in 
sound files. For information on using the correlation tool, please refer to 
Chapter 9, “Correlation”. For help with making detections, see Chapter 10, 
“Detection”. And to perform batch operations like channel exporting, see 
“Batch channel export” in Chapter 8 (page 175).
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The Help menu Figure 2.7 Help menu

Figure 2.7. Contents of the Help menu.

Documentation
This section of the Help menu contains links to documentation for the 
Raven software. You can access the entire Raven User’s Manual by select‐
ing the first option or you can chose to view the “What’s New” document.  
You can visit the Raven web site, view frequently asked questions, or read 
the Raven license agreement.  You can also access the Raven Help Forum 
which is a great tool for users.

Feedback
By selecting the Email Feedback option, you can submit comments, bug 
reports, support requests, and other feedback to the Raven software team 
via email. For more information on contacting the Raven software team 
and how to use the Email Feedback form, please see “Contacting the 
Raven development and support team” in Chapter 11 (page 267).

Updates
Periodically, the Raven software team releases updates and changes to the 
Raven application. You can check for and read about these updates in this 
section of the Help menu. You can also download the QuickTime installer 
(more on this process can be found in “Opening sounds in different file 
formats” in Chapter 1 (page 6).)

About
Selecting About Raven... allows you to view information regarding copy‐
right information, thanks, and credits for the application.
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The Toolbars

There are five main toolbars in Raven. You can control whether a toolbar is 
displayed or hidden by selecting View > Toolbars > <Toolbar Name>.  If 
the toolbar has a checked box next to its name, it is already visible.  If the 
box is empty, the toolbar is hidden.  In the same menu (View > Toolbars) 
you can also choose to lock or unlock the toolbars.  If the icon is a locked 
padlock, the toolbars are locked and you will be unable to move or other‐
wise adjust their positions.  Unlocking the toolbars (denoted by an 
unlocked padlock) allows you to move the toolbars around if you so 
desire.

The file toolbar The file toolbar is located underneath the menu bar, across the top of the 
Raven window (see Figure 2.8). It contains buttons allowing you to create 
new items, open existing items, save items, and print (in addition to 
adjusting the page setup for printing purposes). Since this section is 
intended only to introduce the contents of the toolbar, specific information 
about the commands and their functionality can be found throughout this 
manual.

Figure 2.8 file toolbar

Figure 2.8. The file toolbar.

New Recorder, New Sound Window, New Selection Table
The first three buttons in the file toolbar create new items (recorders, 
sound windows, or selection tables).  You can also create these items by 
accessing the File menu (“‘New’ section in File menu” on page 22).

Open Sound Files, Open CD, Open Selection Table, Open Workspace
The next set of four buttons allow you to open various items (sounds from 
files or CD, selection tables, or saved workspaces). You can also open these 
items from the File menu (“‘Open’ section in File menu” on page 23).

Save Sound, Save Sound File As..., Save Selection Table, Save Selection
Table, Save Active Selection As..., Save All Selections As..., Save Selected
Channels As..., Save Workspace
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There are 7 buttons with various Save functionality in the toolbar. You can  
save certain items through the File menu as well (“‘Save’ section in File 
menu” on page 23).

Print Sound, Page Setup
If you’d like to print a sound, or adjust the page settings before printing, 
the last two buttons provide an easy way to do so. Of course, you can 
always go through the File menu to access these options as well (“‘Print’ 
section in File menu” on page 23).

The edit toolbar The edit toolbar is typically located underneath the file toolbar (although, 
if you unlock the toolbars and move them around, the location could be 
different). This toolbar contains buttons related to editing, filtering, and 
amplifying sounds and selections. More information on these topics can 
be found in Chapter 6, “Selections: Measurements, Annotations, & Edit‐
ing”.

Figure 2.9 the edit toolbar

Figure 2.9. The edit toolbar.

Undo, Redo, Cut, Copy, Paste, Delete
These buttons contain basic editing commands that can also be applied by 
selecting the Edit menu (“Undo/Redo items in Edit menu” on page 24 and 
“‘Editing’ section in Edit menu” on page 24).

Select All, Filter Around Active Selection, Filter Out Active Selection, Filter
Active Selection With..., Filter Around All, Filter Out All, Filter All With...,
Amplify...
To quickly perform filtering or amplification, you can use these buttons.  
Alternately, you can perform the same tasks by accessing the Edit > Filter 
menu or Edit > Amplify item (“Filter/Amplify items in Edit menu” on 
page 24) if you prefer.

The view toolbar This toolbar contains buttons that will create new views as well as adjust 
the way sound windows and views will appear. For more information on 
these topics, see Chapter 3, “Sound Windows: Visibility, Views, Linkage, & 
Navigation”.
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Figure 2.10 the view toolbar

Figure 2.10. The view toolbar.

New Waveform View, New Spectrogram View, New Spectrogram Slice
View, New Selection Spectrum View, New Beamogram View
The first five items on the control toolbar are the New Views buttons and 
they are only accessible when a sound window is open. These buttons cre‐
ate new waveform, spectrogram, spectrogram slice, and selection spec‐
trum views, respectively. Also, when multi‐channel signals are open, there 
is a beamforming view available as well. You can also create new views by 
accessing the View > New submenu (“‘View’ section in View menu” on 
page 25). For more information on what these views are and how to use 
them, see “View Types” in Chapter 3 (page 50).

Clear Selection, Clear All Selections, Zoom to Selection, Zoom to All, Zoom
In X, Zoom Out X, Zoom In Y, Zoom Out Y, Tile Windows, Cascade Win-
dows
If you want to quickly clear a single selection, or clear all selections in a 
sound window, you can use the first two buttons on the left. You can also 
access these commands at the bottom of the View menu, or by using the 
selection context menu. If you’d like to adjust the appearance of a particu‐
lar view, you can use the zoom buttons in the toolbar. The same function‐
ality can be acheived by using the zoom buttons on the sound window 
itself (“Changing view scales by zooming” in Chapter 3 (page 47)). If you 
want to change how the sound windows are displayed on the desktop, 
you can choose to tile or cascade them using the two buttons on the far 
right. These commands can also be found listed in the Window menu 
(“Tile/Cascade windows” in Chapter 3 (page 68)).

The play toolbar The play toolbar contains the playback controls.  The use of these controls 
was discussed in “Playing a sound” in Chapter 1 (page 7).
Raven Pro 1.3 User’s Manual 31



Chapter 2:  The Raven Window
Figure 2.11 The Play toolbar

Figure 2.11. The play toolbar.

Play, Scrolling Play, Looping Play, Reverse Play, Stop
These buttons control the playback of a sound. For more information on 
using these controls, see “Playing a sound” in Chapter 1 (page 7).

Playback Rate
This controls the speed at which a sound is played. You can speed up or 
slow down the playback rate of the signal. By default the playback rate is 
set at 1.0, or the same as the recording rate. Slowing down the rate makes 
the sound lower in pitch and slower; speeding it up makes it higher in 
pitch and faster.

The spectrogram
toolbar

The spectrogram toolbar gives you access to making quick adjustments to 
the appearance of spectrogram displays. For more detailed information on 
spectrograms, see Chapter 5, “Spectrographic Analysis”.

Figure 2.12 the spectrogram toolbar

Figure 2.12. The spectrogram toolbar.

Color Map: Changing and Reversing
To change the color map of your spectrogram, simply use the Change 
Color Map drop‐box. Choices include Grayscale (standard), Cool, Hot, 
Standard Gamma II, Copper, and Bone. You can also choose to reverse the 
color map. For more on spectrogram color maps, see “Color schemes of 
sound windows” in Chapter 3 (page 60).
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Brightness: Adjusting and Setting
To adjust the brightness of the spectrogram window, you can use the 
adjustable slider (sliding the bar to the right increases brightness while 
sliding it to the left decreases the brightness) or you can set the brightness 
to an exact level by entering a number (1 to 100) into the Set Brightness 
text box. For more information on this, please see “Spectrogram brightness 
and contrast” in Chapter 3 (page 60).

Contrast: Adjusting and Setting
To adjust the contrast of the spectrogram, you can use the adjustable slider 
(sliding the bar to the right increases the contrast while sliding it to the left 
decreases the contrast) of you can set the contrast to an exact level by 
entering a number (1 to 100) into the Set Contrast text box. For more infor‐
mation on this, please see “Spectrogram brightness and contrast” in Chap‐
ter 3 (page 60).

Spectrogram Window Size: Adjusting and Setting
The window size parameter controls the length of each data record that is 
analyzed to create each of the individual spectra that together constitute 
the spectrogram. The default unit for this measurement is number of sam‐
ples. For more information on window size, please see “Window size” in 
Chapter 5 (page 103) and “Window Size slider control” in Chapter 5 (page 
104).

The Side Panel

The left side of the Raven window holds the side panel, which contains six 
tabs: Layout, Linkage, Selection, Playback, Detection, and Information. By 
default, the side panel  opens to the Layout tab; see Figure 2.13.
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Figure 2.13 The Side Panel

Figure 2.13. A general view of the side panel, with basic layout features 
outlined in red.

Docking controls Clicking on these arrows controls the visibility of the side panel. If you 
choose the arrow pointing toward the left (at the top for Windows users, 
or at the bottom for Mac OS) the side panel will be docked or hidden, and 
you will be unable to view its contents. If you select the arrow pointing 
toward the right, the side panel will become undocked and will become vis‐
ible again. If the sound window is maximized when you hide the side 
panel, it automatically expands to occupy the entire Raven desktop when 
it is undocked. Similar docking control arrows appear throughout the 
application in cases where panels can be docked to provide more viewing 
room for other information.
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Vertical separator
bar

The gray shaded bar to the right of the side panel can be moved to the left 
and right to control the width of the side panel itself. To resize the side 
panel, simply click your mouse over the control bar and, while holding the 
mouse button, drag the mouse to the right or left.

Show all/hide all The side panel contains different sections of information.  Each section in 
the panel contains a list of items.  When a checkbox next to an item is 
checked, that item will be shown in the active sound window on the 
Raven desktop.  For example, if you open ChestnutSidedWarbler.aif, the 
items listed under the View section in the side panel should be ‘Waveform 
1’ and ‘Spectrogram 1’, with both checkboxes checked. This means that 
both the waveform and spectrogram views are shown in the ChestnutSid‐
edWarbler.aif sound window.  For a brief review of what the sound win‐
dow looks like, please refer to “Understanding the Sound Window” in 
Chapter 1 (page 7)

Sometimes, you may want to hide all the items listed in a side panel sec‐
tion. To do this, select the hide all button (the three white, ‘empty’ boxes). 
This will uncheck the checkboxes and will hide these items from being 
seen in the sound window. To show all the items listed in a side panel sec‐
tion, select the show all button (the three black boxes) and this will make 
the items visible in the sound window. See Figure 2.14. for more informa‐
tion on hiding and showing all components.
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Figure 2.14..  Layout tab

Figure 2.14.  The Layout tab for a sound window that contains two 
views. The Component Visibility pane has been hidden by dragging the 
separator bar above it down.

Side panel tabs At the bottom of the side panel are five tabs which dictate what informa‐
tion is displayed in the side panel. Clicking on one of the tabs will change 
the contents of the side panel to show information pertinent to the tab’s 
heading. Details regarding these tabs and how they can be used will be 
discussed at later points throughout this manual.

Information panel The sixth tab holds the Information Panel, which displays information 
about the sound window that is currently open.  It will tell you the sound’s 
file type, number of channels, sample rate, encoding, and length.  The 
sample rate is adjusted to compensate for any speed changes; so a sound 
recorded at half‐speed at 44 kHz will be listed as having a sample rate of 
88 kHz.

When a window contains more than one sound (for example, a correlation 
window), the Information Panel displays information about the first 
sound in the list.
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Mouse
measurement field

At the bottom of the Raven window is an area called the mouse measure‐
ment field which displays information from whatever sound view your 
mouse pointer is currently positioned over. See Figure 2.15.

Figure 2.15 Mouse measurement field

Figure 2.15. The Raven window with the mouse measurement field 
labeled in red.

Depending on what type of view your mouse pointer is positioned over, 
differnet information will be displayed here.

•As you move the mouse pointer over a waveform view, the time of the 
pointer’s location and the amplitude of the waveform at that time are 
shown in the mouse measurement field.

•When moving the mouse pointer over a spectrogram view, the time and 
frequency of the pointer’s location, and the relative power at that time 
and frequency are shown in the mouse measurement field.

•As you move the mouse pointer across a spectrogram slice view, the 
mouse measurement field at the bottom of the Raven window displays 
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the frequency at the mouse pointer location, and the relative intensity at 
that frequency, for the time slice shown.

Often, the time scale is so compressed that the number of sample points 
represented exceeds the number of pixels in the window. In this case, each 
pixel stands for multiple sample points, and the measurement display 
shows the minimum and maximum values of the samples represented at 
the time of the mouse position (as in Figure 2.15).

Changing the Appearance of the Raven Window

Selectable look and
feel

The color and texture of the Raven window (the “look and feel”) can be 
selected so that it mimics the appearance of several standard application 
types.  You can also choose to retain Raven’s unique style and appearance.  
Choose Window > Look and Feel and select Metal, Motif, or Windows.  
Metal is Raven 1.3’s standard appearance.  

Selectable desktop
background color

Choose Window > Background Color... to open the Background Color Edi‐
tor panel and set the color of the main Raven screen area (the desktop) 
through Swatches, HSB, or RGB color definitions.  More about customiz‐
ing Raven can be found in Chapter 11, “Customizing Raven: Preferences, 
Presets & Memory”.

Selectable tooltip
color

Choose Window > Tooltip Color... to open the Tooltip Color Editor panel 
and set the color of Raven’s tooltips, the helpful signs that pop up when 
you hover your mouse cursor over a button or box.  Note that tooltip color 
can only be changed when the Metal Look and Feel is in use.
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Chapter 3 Sound Windows:  
Visibility, Views, Linkage, & Navigation

About this chapter

This chapter will explain how to work with and get around Raven in more 
detail.  Before reading this chapter, you should have a solid understanding 
of the major components and basic layout that make up the Raven win‐
dow.  If you need to review this information, please see Chapter 1, “Get‐
ting Started” and Chapter 2, “The Raven Window”. Topics discussed in 
this chapter are:

•using contextual menus
•learning the basic layout of a sound window
•understanding the five main view types
•llinking and unlinking of views
•controlling how views are displayed
•changing the appearance of a Sound window
•changing the appearance of the Raven window

Using Contextual Menus

As you learn more about navigating around the Raven window, you 
might realize that it would be convenient to have a list of contextually‐ori‐
ented commands readily available.  Well, luckily for our users, there IS 
such a list. A context menu is a menu of useful commands that apply to 
wherever your mouse pointer is positioned at that time.  To activate a con‐
text menu, simply right‐click using your mouse and the menu will appear.
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Figure 3.1 Context menu example

Figure 3.1. An example of a context menu when the mouse pointer is 
over a waveform view. The menu gives you many command options 
relevant to the mouse location and is accessible by a simple right-click 
of the mouse.

Basic Layout of a Sound Window

This section contains information regarding the general makeup of sound 
windows.  To review how to open a sound window, refer to “Opening a 
sound file” in Chapter 1 (page 2).
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Figure 3.2 Sound Window

Figure 3.2. A basic sound window containing two views (a waveform 
view, top, and a spectrogram view, bottom) with the view axes (both 
vertical and horizontal) marked in red. Each axis is marked with a unit 
and number values.

The active view Most commands, buttons and scroll bars that affect views apply only to 
the active view. Only one view in a sound window can be active at any 
given time. The active view is identified by a colored vertical view selection 
button at its left edge. The name of the active view is also highlighted on 
the side panel’s Layout tab. In Figure 3.2, the waveform is the active view. 
To activate a view, click on its view selection button or in its axis areas. You 
can also activate a view by clicking on its name to select it in the side 
panel’s Layout tab.

Moving, resizing,
and closing a sound

window

The sound window’s title bar has controls for resizing and closing the win‐
dow, and is the means by which you move a sound window. See Figure 
3.3.

Although you can activate a view by clicking in the data 
region (i.e., above and to the right of the axes), doing so will 
create a selection. Basic information about selections can be 
found in “Making a selection” in Chapter 1 (page 8), while 
more advanced selection information is discussed in Chapter 
6, “Selections: Measurements, Annotations, & Editing”
Raven Pro 1.3 User’s Manual 41



Chapter 3:  Visibility, Views, & Navigation
Figure 3.3 Moving and Resizing a Sound Window

Figure 3.3. The title bar, with controls to resize and close a sound win-
dow. The title bar is also the anchor for moving the sound window.

To move the window around, simply click and drag on the title bar. 

To minimize the window (to reduce the whole window to a short title bar 
at the bottom of the Raven window) click on the Minimize icon in the title 
bar. Clicking on a minimized window’s title bar expands it again. 

Clicking on the maximize icon makes the window fill the entire Raven 
desktop. When the window is maximized, you’ll notice the Maximize but‐
ton changes into a Restore button. Clicking this Restore icon restores the 
sound window to its previous size and position. 

Clicking on the Close icon closes the window; if you close it, you’ll have to 
reopen the sound file again by choosing  File > Open Sound Files..., by 
typing <Ctrl-O> (Windows) or <Command-O> (Mac OS), or by using the 
Recent Files section of the File menu. 

You can also resize the window by clicking and dragging on an edge or 
any corner of the window. On Mac OS, you must drag from the bottom 
right corner to resize the window.

Scrollbars The horizontal and vertical scrollbars in a Raven sound window always 
refer to the active view. The length of the horizontal scrollbar in a wave‐
form or spectrogram view corresponds to the total duration of the sound 
that is in Raven’s working memory.1 The length of a scrollbar’s scroll 
thumb (Figure 3.4) relative to the length of the entire scrollbar, indicates 
what proportion of the corresponding axis is visible in the view pane.

1. If you opened the entire sound at once (the default), the duration of the sound 
in memory is the duration of the entire sound file or file sequence. If you 
opened the sound in a paged window, the duration in memory is the length of 
one page. See “Configuring a new paged sound window” in Chapter 7 (page 
158) for more on paged sound windows.
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Figure 3.4 Scrollbars

Figure 3.4. A sound window with its scrollbars and scroll thumbs 
labeled in red.

As touched on in “Scrolling playback and position markers” in Chapter 1 
(page 8) the location of the scroll thumb within the scrollbar indicates the 
view’s position relative to the data. When the horizontal scroll thumb of a 
waveform or spectrogram is at the left edge of the scrollbar, the start of the 
data is aligned with the position marker (Figure 3.4).

Axis units in views The units used on the axes are indicated in the lower left corner of each 
view. In the waveform, the units are seconds (S) for the horizontal time 
axis, and kilounits (kU) for the vertical amplitude axis. In the spectrogram, 

Raven displays a gray background for areas in each view 
pane that are beyond the limits of the data, for example 
before the beginning or after the end of a signal in the time 
dimension.
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the units are  seconds (S) for the horizontal time axis, and kilohertz (kHz) 
for the vertical frequency axis.

Position markers Each view that Raven displays has a horizontal and a vertical position asso‐
ciated with it, shown by a magenta line, known as a position marker. You 
have already seen how the time position marker in a waveform view indi‐
cates the current time during scrolling play (“Scrolling playback and posi‐
tion markers” on page 8).

Notice that when you move the time position of either the waveform or 
spectrogram, the time position marker in the other view moves with it. 
This is because views that share a dimension (e.g., the time dimension for 
waveform and spectrogram views) are by default linked by their position 
in that dimension. More detailed information regarding linkage of views 
is discussed in “Linking and unlinking views” on page 53. 

Centering a position You can move the horizontal or vertical position marker of a view relative 
to the window by grabbing it with the mouse and dragging it. To move a 
particular point in the data shown in a view to the horizontal or vertical 
center of the view pane, place the position marker on the point of interest, 
then click the corresponding Center Position button (Figure 3.5.). The 
position marker and the underlying data will jump to the center of the 
view pane. Blue labels along the axes show the exact numeric values of the 
current horizontal and vertical positions. 

The “units” displayed on the vertical axis of a waveform view 
are the actual sample values in the signal, which are propor‐
tional to the sound pressure at the microphone when the 
sound was recorded. 

When we speak of the “horizontal position marker” we mean 
the line that marks the horizontal position, which is a vertical 
line.

WINDOWS
On computers running the Windows operating system, 
you can make a view’s horizontal position marker jump 
directly to a point by control-clicking at that point. 
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Figure 3.5.. Center position buttons

Figure 3.5.  The horizontal and vertical Center Position buttons. 

Positions control
view appearance

and behavior

The horizontal and vertical position of a view control aspects of a view’s 
appearance and behavior in four ways:

1.  First, a view’s horizontal and vertical position, in combination with the 
view’s horizontal and vertical scales, determine what portion of the 
view’s data is visible in the window. 

2. Second, a view’s position is the point around which zoom operations are 
centered. 

3. Third, the position of a view in a particular dimension (e.g., time or fre‐
quency) may be used to link that view to any other view that shares 
that dimension (“Linking and unlinking views” on page 53). 

4. And fourth, during scrolling playback the time position moves through 
the data (though the position location stays fixed— see below) and can 
be used to control where playback starts (see “Scrolling playback and 
position markers” on page 8).

Position vs. position
location

The position of a signal identifies a point in the data along a particular axis, 
such as time or frequency. In contrast, the position location is the point in a 
particular view’s panel where the position marker is displayed, i.e., from left 
to right or top to bottom. For example, when you drag a time position 
marker, you change both the position location (relative to the window) 
and the position (relative to the data), since the data do not move with the 
marker.1 When you click the Center Position button for an axis, the posi‐
tion marker jumps to the corresponding (horizontal or vertical) center of 
the view panel, and the data move with it— i.e., the position location 
changes, but the position (relative to the data) does not. 

1. The one exception is when you try to drag the position marker beyond the lim‐
its of the signal. In that case, the end point of the signal will move with the 
marker, and you will be changing the position location but not the position 
(which is set to one of its limits already).
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Figure 3.6..  Centered pos markers w/gray bkgrd

Figure 3.6.   Waveform and spectrogram views with centered position 
markers, positioned at the start of the signal (left edge of horizontal 
scrollbar) and the lowest frequency (bottom end of vertical scrollbar) of 
the spectrogram. The vertical scrollbar refers to the spectrogram view, 
because the spectrogram is the active view.

Scale of a view Each view that Raven displays has a horizontal and vertical scale associ‐
ated with it. The scale determines the relationship between the dimen‐
sional units shown along that axis (e.g., seconds or kilohertz) of the view 
and display units (e.g., pixels, centimeters, or inches) on your computer 
screen. The scale at which the entire extent of an axis just fits in the view 
pane is called the default scale for that axis. When you first open a sound 
file, the time scale of the waveform view is set to the default. When you 
first create a spectrogram (information on creating views will be discussed 
later in the chapter) the frequency scale is set by default so that the entire 
frequency range of the signal fits vertically in the spectrogram pane.

Setting the scale of
view axes

The scale and position of the horizontal and vertical axes of any view can 
be changed using the zoom controls and scrollbars, as described in the 
next section. However, more precise control of scale and position is avail‐
able in the Configure View Axes dialog box (Figure 3.7). To display the 
Configure View Axes dialog box, choose Configure View Axes... from the 
contextual menu for any view or from the View menu for the active view. 
You can enter precise values for the position and scale of the view’s hori‐
zontal and vertical axes. Scale is specified in units per line of the view (see 
“Multiple‐line views within sound windows” on page 64).
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Figure 3.7 Changing time scale

Figure 3.7. The original file (top left) is shown with the default time 
scale. Below that (bottom left) is the sound with its time scale changed 
to 10 Seconds/Line. The Configure View Axes box is shown (right) with 
the edited time scale displayed. You can see the original view shows 
more than 20 seconds of the signal, while the bottom view (with the 
altered time scale) shows only 10 seconds of the signal across the line.

Changing view
scales by zooming

At the scale of magnification shown in Figure 3.6., you can’t see individual 
cycles of oscillation of the waveform view (top); what you see is the enve‐
lope of the entire signal. In order to see more detail of a signal, you must 
adjust the zoom level of the view. In the lower right‐hand corner of a Raven 
sound window are the zoom controls for the active view (Figure 3.8.). But‐
tons marked with ‘+’ and ‘‐’ at the right and bottom ends of the horizontal 
and vertical scrollbars respectively increase and decrease magnification 
(zoom in and out) around the current position along that axis. 
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Figure 3.8.. Zoom buttons

Figure 3.8. The zoom controls, which apply to the active view. The 
Zoom to Selection button is gray if no selection exists in the signal.

Zoom details Each time you click a Zoom In or Zoom Out button, the corresponding axis 
of the active view is re‐scaled by a factor of   (= 1.41). Thus, clicking the 
Zoom In or Zoom Out button twice in succession changes the scale by a 
factor of 2. To zoom in horizontally on a view, first make sure that view is 
active, then move the horizontal position marker to the point where you 
want to center the zoom. Click the ‘+’ button at the end of the horizontal 
scrollbar, and observe how the display changes. Clicking the ‘‐’ button 
reverses the change. 

Each time that you zoom in or out horizontally or vertically, the corre‐
sponding scroll thumb shortens or lengthens to indicate what proportion 
of the signal is visible. (Remember that the scroll thumb is half the length 
of the scrollbar when that axis’s scale is set to its default value.) 

Zooming in
horizontally

If you click the horizontal ‘+’ (zoom in) button repeatedly the scale will 
eventually be stretched to the point where Raven displays the individual 
samples in the waveform as dots (Figure 3.9). 

2
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Figure 3.9 Zoom to Sample Points

Figure 3.9. A sound window with its waveform view (top) horizontally 
zoomed in enough to display individual sample points.

As mentioned before, the spectrogram and waveform views are linked by 
their time scale (and time positions.)  So, you’ll notice that both the wave‐
form and spectrogram views zoomed in, even though only one of them is 
the active view.

Zooming vertically To zoom vertically in the spectrogram, activate that view, and drag the 
vertical position marker to the point where you want to center the zoom. 
Click the ‘+’ or ‘‐’ button at the bottom of the vertical axis to increase or 
decrease magnification around the vertical position marker.

Notice that changing the vertical position or scale of the spectrogram has 
no effect on the waveform. The vertical dimensions of the views are differ‐
ent (amplitude in the waveform, frequency in the spectrogram), so the ver‐
tical scales of the views cannot be linked.

Zoom to all To reset the horizontal or vertical scale of a view to display the entire axis, 
click on the corresponding Zoom To All button, marked with a horizontal 
or vertical I‐beam icon (Figure 3.8., page 48).

Zoom to selection The Zoom To Selection button rescales the active view so that the active 
selection fills the view frame. If there is no active selection, the Zoom To 
Selection button is not available. In the spectrogram view, select a rectan‐
gular  area to enlarge by clicking and dragging the mouse pointer. Then 
click on the Zoom To Selection button in the lower right corner of the 
sound window (Figure 3.8., page 48).
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View Types

The four main view
types

Waveform view
When you open a sound in Raven, the top view in a sound window is a 
waveform view by default. This view displays an oscillogram which is a 
graph of the sound showing amplitude versus time.

Spectrogram view
The second view shown by default in a sound window, below the wave‐
form view, is a spectrogram view.  It shows time on the horizontal axis, 
frequency on the vertical axis, and relative power at each point as a color 
(grayscale by default.)

Spectrogram Slice view
A spectrogram slice view is a plot of relative intensity versus frequency at 
a particular point in time within a signal. A spectrogram slice represents a 
vertical cross section through a spectrogram at a single time, but is rotated 
90° so that the frequency axis is horizontal. In fact, a spectrogram is built 
of a series of spectrogram slices stacked side by side (with their frequency 
axes running vertically). 

Where a spectrogram view shows a series of slices at successive points in 
time, and represents power at each frequency by a color value, a spectro‐
gram slice view shows only one slice and represents power at each fre‐
quency on a line graph. The relationship between spectrogram and 
spectrogram slice views is explained in more depth in Chapter 5, “Spectro‐
graphic Analysis”.

Selection Spectrum view
These show the average spectrum of a sound over the time interval 
defined by a user‐made active selection.  More information about selec‐
tions and how they affect this view type can be found in “Selection spec‐
trum views” in Chapter 5 (page 125).

Making a new view New views are created by using the appropriate buttons located on the 
control toolbar (Figure 3.10).

Figure 3.10 New view buttons on the control toolbar

Figure 3.10. The new view buttons on the control toolbar.
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Open a sound file like ChestnutSidedWarbler.aif. The sound window 
shows a spectrogram and waveform view by default.  To create a new 
view, like a spectrogram slice view, simply click on the New Spectrogram 
Slice button () in the control toolbar.  Alternately, you can choose View > 
New > Spectrogram Slice View..., or type <Ctrl-L> (Windows) or <Com-
mand-L> (Mac OS). The Configure New Spectrogram Slice View dialog 
box should appear (Figure 3.11).

Figure 3.11 Configure New Spectrogram Slice View dialog box

Figure 3.11. The Configure New Spectrogram Slice View dialog box.

This dialog box lets you specify various parameters that affect the appear‐
ance of the spectrogram. For now, don’t worry about what these parame‐
ters mean; they are explained in detail in “Configuring spectrographic 
views” in Chapter 5 (page 100). Click OK to accept the default settings and 
compute the spectrogram slice view.

The sound window is re‐drawn with an additional view pane, containing 
the new spectrogram slice view. If the time position marker of the wave‐
form or spectrogram view is at the very beginning of the data (where 
Raven puts it by default when opening a new signal) the spectrogram slice 
view does not display any data (Figure 3.12). 
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Figure 3.12 New Spectrogram Slice View

Figure 3.12. This sound window contains the usual waveform and 
spectrogram views, but it also contains a blank spectrogram slice view 
as well.  The spectrogram slice view displays no data when the time 
position marker of the spectrogram and waveform view is located at the 
start of the data (all the way to the left).

Showing data in a
new view

To see valid data, drag the time position marker to the right in either the 
waveform or spectrogram view (Figure 3.13). (For a complete explanation 
of why no data are visible in the spectrogram slice view when the position 
marker is at the start of the signal, see Chapter 5, “Spectrographic Analy‐
sis”.)
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Figure 3.13 Spectrogram Slice view with data

Figure 3.13. The same sound window as shown in Figure 3.12 but with 
the time position marker (the vertical magenta line) moved to a position 
in the waveform and spectrogram data.  The spectrogram slice view 
now displays the data from the time designated by the time position 
marker.

Selected view
dictates toolbar

content

Remember that the active view in a sound window is marked by the high‐
lighted view selection button to the left of the view (for example, the spec‐
trogram view is active in Figure 3.13). The activated contents of the control 
toolbar are dictated by which view is active in the current sound window.  
For example, if a spectrogram view is active, the brightness and contrast 
sliders in the spectrogram toolbar become active (Figure 2.12 on page 32). 
If any of the other views are active, the brightness and contrast sliders are 
grayed out because they have no relevance in those cases.

Linking and unlinking views

Two views that share a dimension— such as time or frequency— can have 
their positions and scales either linked or unlinked by that dimension. When 
the positions of two views are linked, moving the position of either one 
(by moving the corresponding scroll thumb, or by moving the position 
marker within the window) causes the positions of both views to move 
together. When the scales of two views are linked, changing the scale of 
either one (using the zoom buttons) causes both views to be re‐scaled. In 
the examples you’ve seen so far, waveform and spectrogram views have 
been linked by time position and in time scale.

When you open or record a signal and create multiple views, each view is 
initially linked in position and scale to every other view that shares its 
dimensions. For example, waveforms and spectrograms are initially all 
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linked to each other in time position and time scale, and spectrogram and 
spectrogram slice views are linked in frequency position and frequency 
scale. Spectrograms and waveforms cannot be linked in frequency because 
waveforms have no frequency dimension.

Unlinked views In some situations, it can be useful to work with views that are unlinked 
from each other in particular ways. For example, Figure 3.14. shows two 
spectrogram views of a signal that is 53 seconds long. The views are linked 
in time position but unlinked in time scale. Unlinking the time scales 
makes it possible to view simultaneously an eight‐second portion segment 
of the signal (upper view), and a close‐up of a two‐second segment con‐
tained within it (lower view). Since the two views remain linked in time 
position, the position markers provide a reference point to show where 
the close‐up view is located within the entire signal. As either view is 
scrolled horizontally through the signal, the linked position markers iden‐
tify the same point in time in both views. 

Figure 3.14..  Two linked spgs, diff time scales

Figure 3.14.  Two spectrogram views of the file “BlackCappedVireo.aif” 
that are linked in time position, but unlinked in time scale. The upper 
spectrogram shows 7.8 seconds of the signal; the lower spectrogram is 
a close-up of 2.0 seconds. The highlighted rectangle identifies the 
same selection in both views. The time position markers in both spec-
trograms identify the same time, because the time positions are linked.
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Unlinking views
through the

contextual menu

To create two spectrograms that are unlinked in time scale as discussed in 
the above example (Figure 3.14.):
1. Open a signal.
2. Make a second spectrogram by clicking the New Spectrogram button 

(Figure 3.10, page 50), or typing <Ctrl-G> (Windows) or <Command-G> 
(Mac OS).

Place the mouse pointer on the second spectrogram, activate the contex‐
tual menu, and choose Unlink View > Time Scale.

Now try using the zoom buttons to change the time scale of the first spec‐
trogram. Notice that the time scales of the waveform and the first spectro‐
gram change together, but the time scale of the second spectrogram does 
not change. If you activate the second spectrogram, and zoom in time, its 
time scale changes, while the time scales of the waveform and the first 
spectrogram remain unchanged. If you scroll any of the three views, their 
position markers will move in synchrony, because all three are still linked 
by time position.

Restoring or
creating new

linkages through
the linkage tab

To restore linkages between views that have been unlinked, or to create 
linkages between views that have never been linked, activate the Linkage 
tab in the Raven side panel. (If the side panel is not visible, click on the 
right‐pointing triangle at the top (Windows) or bottom (Mac OS) of the 
separator bar at the left edge of the Raven window.)

At the top of the Linkage tab, there is a drop‐down menu showing all of 
the linkable properties of the current views. Click on this menu, and 
choose Time Scale. If you created two spectrograms and unlinked them as 
described above, the tab will display three folder icons representing link‐
age groups, with names like “Group 1”, “Signal 1 Default”, and “New” 
(Figure 3.15). (The second group may be called “Signal 2 default”, “Signal 
3 default”, etc., depending on how many signals you’ve opened in the cur‐
rent Raven session. If more than one signal is open, you will see a default 
linkage group for each signal.)
Raven Pro 1.3 User’s Manual 55



Chapter 3:  Visibility, Views, & Navigation
Figure 3.15 .  Linkage tab.

Figure 3.15.  The Linkage tab, showing the linkage groups for the Time 
Scale property corresponding to Figure 3.14..

A linkage group is a set of views that are linked to each other by a particu‐
lar property (in this case, Time Scale). Views that are in different linkage 
groups are unlinked from each other in that property. 

Open the first two folders by double‐clicking on them (or single‐clicking 
the icon to the left of each folder icon). In the present case, the linkage 
group called “Sound 1 Default” contains the views called “Sound 1 Wave‐
form 1” and “Sound 1 Spectrogram 1”; Group 1 contains “Sound 1 Spec‐
trogram 2”. The active view is highlighted, and you can activate a different 
view by clicking on its name. 

To link two views that are presently unlinked, drag the icon for one of the 
views to the linkage group that contains the other. In the case shown in 
Figure 3.15, you can unlink the waveform from Spectrogram 1 and link it 
to Spectrogram 2 by dragging its icon from the Default folder to the Group 
1 folder. 

When you move a view from one linkage group to another, the view is 
immediately redrawn if necessary so that its image has the correct scale, 
position, or other linkable property. If a linkage group contains only a sin‐
gle view, and you drag that view to a different linkage group, the original 
(now empty) group disappears.

Creating a new
linkage group

To create a new linkage group select one of the views listed by clicking on 
it, and drag it onto the folder labeled “New”. A new linkage group will 
appear in the list, containing the view that you moved.

Creating new linked
views

To create a new spectrogram, spectrogram slice, or selection spectrum 
view that is linked by spectrogram parameters to an existing spectro‐
graphic view, choose New > Similar Spectrogram View, New > Similar 
Spectrogram Slice View, or New > Similar Selection Spectrum View from 
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the contextual menu for any spectrographic view, or from the View menu 
for the active spectrographic view.

Other linkable
properties

In addition to its position and scale for each of its dimensions, every view 
has three other properties by which it can be linked to other views:
•Color Scheme:  Color schemes include color specifications for most of 
the graphical elements shown in a view (e.g., axes, backgrounds, selec‐
tion boundaries), as discussed later in this chapter . Adjusting brightness 
and contrast settings for a spectrogram adjusts the settings for all spec‐
trograms linked to it by Color Scheme. By default all views of a signal are 
linked to each other by Color Scheme.

•Channel Visibilities:  In multi‐channel signals (see Chapter 8, “Multi‐
channel Sounds”), hiding or showing particular channels of a view will 
also hide or show those channels in other views that are linked by Chan‐
nel Visibility.

•Number of Lines:  Changing the number of lines displayed for a view  
(see “Multiple‐line views within sound windows” on page 64) automati‐
cally changes the number of lines displayed for any other views that are 
linked by Number of Lines. By default, all views in a signal that display a 
time axis are linked to each other by Number of Lines.

Additionally, spectrogram, spectrogram slice, and selection spectrum 
views can be linked by spectrogram parameters. If two views are linked 
by spectrogram parameters, then changing the parameters for either view 
automatically changes both views. 

Linkage between
spectrogram and

spectrogram slice
views

When you request a spectrogram slice view, Raven actually calculates an 
entire spectrogram of the signal, but only displays one slice at a time. A 
spectrogram slice view thus has a “hidden” time axis. Which slice of the 
underlying spectrogram is displayed is determined by the view’s time 
position. By default, the time position of a spectrogram slice view is linked 
to the time positions of waveform and spectrogram views. As you move 
the time position marker of a spectrogram view, any spectrogram slice 
view that is linked to it is continually updated to show the cross‐section of 
the spectrogram at the time position marker.

Views that share a linkable property can be linked even if they 
are in different signal widows. This can be useful for example 
in setting views of different signals to the same scale.

Even though a spectrogram slice view has a time position, it 
does not have a time scale, since the time axis of the underly-
ing spectrogram is not displayed.
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By default, new spectrogram and spectrogram slice views are also linked 
to each other by frequency position and frequency scale. When you move 
the frequency position of a spectrogram, the frequency position of any 
linked spectrogram slice views move as well, and vice versa. Similarly, 
when you zoom the frequency scale of any spectrogram slice view, the fre‐
quency scale of any linked spectrogram zooms as well. It is important to 
remember that the frequency scales of spectrogram and spectrogram slice 
views are rotated 90° from each other.

 Controlling how views are displayed

Using tools and commands in the side panel’s Layout tab and in the View 
menu, you can rearrange the order of views and hide or show the non‐
data components of views such as the axes and position markers.

Another way to hide a view is to activate that view and choose Hide View 
from the View menu, or from that view’s contextual menu.

Deleting a view To delete a view, activate the view and choose Delete View from its contex‐
tual menu or from the View menu. When you delete a view (as opposed to 
hiding it), the memory occupied by that view is released for reuse. Re‐dis‐
playing a hidden view occurs instantly, whereas re‐displaying a view that 
was deleted requires that it be recalculated, which may take a significant 
amount of time.

Changing the order
in which views are

displayed

To rearrange the order in which views are displayed in the sound window, 
you can drag and drop view names in the Layout tab.

You can also move a view up or down within the sound window by choos‐
ing Move View Up or Move View Down from the View menu or the view’s 
contextual menu.

Hiding and showing
window

components

The bottom pane of the side panel’s Layout tab contains a list of window 
components that can either be displayed or hidden. You can display or hide 
each component of the active window by checking or unchecking its 
checkbox. Figure 3.16. shows a sound window containing two views, with 
all components hidden.

When you activate a contextual menu in a view pane, view-
specific commands in the menu apply to whichever view the 
mouse pointer is on when the menu is activated, irrespective 
of whether or not that view is active.
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Figure 3.16..  All components hidden.

Figure 3.16.  A sound window with all components hidden.

By default, all window components are displayed except for line titles, 
which identify the view type and number of each view (Figure 3.17.). If the 
sound has multiple channels (see Chapter 8, “Multi‐channel Sounds”) or a 
view has multiple lines, channel and line numbers are displayed in line 
titles as well.

Figure 3.17. .  View titles.

Figure 3.17.  A sound window showing a waveform and a spectrogram 
view, with line titles displayed.
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Changing the Appearance of a Sound Window

Spectrogram
brightness and

contrast

When a spectrogram view is active, the brightness and contrast controls 
on Raven’s spectrogram toolbar become active too (Figure 2.12 on page 
32).

If your spectrogram looks too dark or light, or if it’s hard to pick the signal 
out of the background, move the brightness and contrast sliders to achieve 
the desired appearance of the spectrogram. The brightness control adjusts 
the overall darkness of the spectrogram: for a grayscale spectrogram (the 
default), sliding the control to the right lightens the display.

The contrast control adjusts the number of different color (by default, 
grayscale) values that are shown in the spectrogram. In a grayscale spec‐
trogram, moving the contrast slider all the way to the right makes the dis‐
play black and white: all values below some threshold are assigned to 
white and the rest become black. In this case, the threshold between black 
and white is determined by the brightness control. With the contrast con‐
trol all the way to the left Raven displays up to 200 shades of gray.

The box next to each control tells you what percent contrast or brightness 
you’ve set. If you prefer, you can type a percentage number into a box 
instead of moving the slider.

Color schemes of
sound windows

Each view in a sound window has a particular color scheme. A color 
scheme consists of a spectrogram colormap and particular colors for items 
such as active and inactive selection borders and fills, dots and lines in 
waveforms.

A spectrogram colormap defines the relationship between power values in 
the spectrogram and colors used to display them. Raven provides six pre‐
defined colormaps: Grayscale, Hot, Cool, and Standard Gamma II1, Bone, 
and Copper (Figure 3.18.). To change the colormap of a spectrogram, 
choose Color Scheme > Colormap-name from the spectrogram’s context 
menu, or from the View menu when the spectrogram is active.

1. The Standard Gamma II color map is included in Raven courtesy of Research 
Systems, Inc., a Kodak Company.

Views in a sound window are by default linked to each other 
by color scheme. If you change the colormap or any other 
item in a view’s color scheme, the affected colors will also 
change in any other views that are linked to it by color 
scheme.
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Figure 3.18..  Colormap examples

Figure 3.18.  Four spectrogram views of the signal “CassinsKing-
bird.wav”, using four different, predefined colormaps. a) Hot. b) Stan-
dard Gamma II. c) Bone. d) Copper.

You can reverse the spectrogram colormap by choosing Color Scheme > 
Reverse Color Map from the spectrogram’s context menu, or from the 
View menu when the spectrogram is active..

Editing color
schemes

In addition to selecting spectrogram colormaps, you can also edit a view’s 
color scheme by choosing Color Scheme > Edit... from the view’s context 
menu, or from the View menu when the view is active. More information 
on customizing color schemes can be found in “Editing color schemes” in 
Chapter 11 (page 243).

Sound Window
Presets

You can save information about the layout of a sound window in a window 
preset, which you can later apply to another sound window (or to the same 

In general, if the background of a spectrogram is white, then 
light colors represent low power.  If the background is black, 
the dark colors of a colormap represent the low power.
Raven Pro 1.3 User’s Manual 61



Chapter 3:  Visibility, Views, & Navigation
window). A window preset includes information about the size of a win‐
dow, what views are displayed, whether or not the selection table is show‐
ing, and other properties (Table 3.1).
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To save a window preset, first configure the properties listed in Table 3.1 
the way you want to save them, then choose View > Window Preset > 
Save As... . When the Save Sound Window Preset dialog box appears, 
enter a name for the preset, and click OK. 

To apply a window preset that’s already been saved to the active sound 
window, choose View > Window Preset > Preset-name. When you apply a 
saved preset, the active window is redrawn with the properties specified 
in the preset, and any additional views are calculated as needed.

You can specify a window preset to apply when you first open a sound file 
in the Configure New Sound Window dialog box (Figure 1.3, page 4). You 
can change the name of the default window preset by editing the Raven 

Table 3.1.  Window properties saved in window presets.

window size

view types, parameters, color schemes, 
    positions, scales, sizes

spectrogram parameters

spectrogram brightness and contrast

selection table visibility and size

measurement list

selection label configuration

selection label visibility

axis visibility

line title visibility

position marker visibility

view selection button visibility

scrollbar visibility

Window presets must be saved in the folder Presets/
Sound Window/ within the Raven program folder. You can 
also create additional folders within the Sound Window 
folder by clicking on the New Folder icon within the Save 
Sound Window dialog. These folders will appear as sub-
menus in the Window Preset menu, with each submenu list-
ing the presets in the corresponding folder.
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preferences file, as described in “About Raven preferences” in Chapter 11 
(page 252). 

If you make changes to the properties of a window to which you’ve 
applied a preset, you can save the changes to the current preset by choos‐
ing View > Window Preset > Save “Preset-name”.

Multiple-line views
within sound

windows

Raven can display views that have a time axis (i.e., waveforms and spec‐
trograms) across multiple lines (Figure 3.19.). The values shown on the 
time axis of a multiline view start at the left end of the top line, go to the 
right end of that line and continue on from left to right on subsequent 
lines, like lines of text on a page.

Figure 3.19..  Multi‐line spg.

Figure 3.19.  A spectrogram view with three lines. Note the continuity 
of the time axis from one line to the next.

Window presets take precedence over other presets that 
affect the appearance of the contents of a window. Thus, if 
you apply a window preset, spectrogram parameters, the 
measurement list, and the color scheme are all set as defined 
in the specified window preset, even if they were previously 
set to different values by choosing spectrogram, measure-
ment, or color scheme presets. 
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On the side panel, the Layout tab’s Lines box shows you how many lines 
there are for the selected view. To change the number of lines, select a 
waveform or spectrogram view, change the number in the box, and press 
<Enter>. By default, all waveform and spectrogram views in a sound 
window are linked to each other in the number of lines displayed. You can 
unlink the number of lines property as described in “Linking and unlink‐
ing views” on page 53.

Grouping views
with multiple lines

In sound windows with two or more views and two or more lines per 
view, you can change the way the lines and views are grouped in the win‐
dow. By default Raven displays all the lines for one view, followed by the 
lines for the next; this is called grouping by view (Figure 3.20.). The alterna‐
tive is to see all the first lines for all views, followed by all the second lines 
for all views, and so on; this is called grouping by time (Figure 3.21.).

The scale of the time axis doesn’t change when you change 
the number of lines displayed. To rescale the axis so that the 
view fills the available lines, click on the horizontal Zoom-to-
All button at the right end of the horizontal scrollbar.
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Figure 3.20..  VL grouping.

Figure 3.20.  A sound window containing two views, each with two 
lines, grouped by view. All lines of the waveform view are in the top 
group, all lines of the spectrogram view are in the next group. 
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Figure 3.21..  LV grouping.

Figure 3.21.  The same two views shown in Figure 3.20., but grouped 
by time. The first lines of both views are in the top group; the second 
lines of both views are in the next group. 

To change the grouping, choose View or Time from the pull‐down menu 
labeled “Group By”, in the side panel’s Layout tab.

Working with more
than one sound

Raven lets you work with more than one sound at a time. When more than 
one sound window is open, the tools in Raven’s toolbar (e.g., New View 
buttons, brightness, contrast, and playback controls) and in the side 
panel’s Layout and Playback tabs always refer to the active window (the one 
window in which the title bar is colored). The side panel’s Linkage tab 
shows views for all sounds that are open, since Raven lets you link views 
of different sound windows to each other. You can activate a sound win‐
dow by clicking anywhere in it with the mouse. You can also activate a 

The horizontal separator bar that Raven displays between 
top-level groupings (i.e., between views in View grouping or 
between lines in Time grouping) is wider than the bar used 
between second-level groups.
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window by choosing its name from the Window menu, or by clicking on 
the name of one of its views in the side panel’s Linkage tab.

Tile/Cascade
windows

When you have multiple sound windows open, Raven can arrange them 
neatly for you on the desktop.  If you choose Window >Tile Windows, 
Raven resizes and repositions all of the windows so that they are all the 
same size and fill the desktop (as nearly as possible) without overlapping 
each other (Figure 3.22.) If you choose Window > Cascade Windows, 
Raven resizes and repositions all of the windows so that they are all the 
same size and as large as possible, overlapping so that their title bars are 
all visible (Figure 3.23.)
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Figure 3.22. Tile Windows

Figure 3.22. Examples of tiled sound windows (a) 2 to 3 sounds will be 
tiled in one column (b) 4 to 8 sounds will be tiled in two columns and (c) 
9 to 12 sounds will be tiled in three columns. 
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Figure 3.23. Cascade Windows

Figure 3.23. An example of cascaded sound windows. Here, the win-
dows are stacked on each other with all title bars visible.

Apply current
window layout to all

windows

To apply all of the active window’s layout to all currently open windows, 
choose View >Apply To All.  Window layout includes all of the information 
that would be stored in a sound window preset, including window size, 
view visibility and scale, spectrogram parameters, and spectrogram 
brightness and contrast.  A complete list of window properties affected by 
the Apply To All command is given in Table 3.1..

Raven does not check whether the sampling rate of the data 
on the clipboard is the same as that of the destination sound. 
If the sample rates do not match, the resulting sound will 
probably not be what you intended. It is up to you to ensure 
that the sampling rates match.
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About this chapter

This chapter describes how to acquire (digitize) signals with Raven, and 
assumes that you are familiar with basic Raven concepts and operations as 
described in earlier chapters.

In order to make good recordings with Raven, you should be acquainted 
with the basic concepts of digital sound representation discussed in 
Appendix A, “Digital Representation of Sound”. Failure to understand 
concepts such as sampling rate and sample size can lead to digitized sig‐
nals that are poor in quality or distorted in various ways.

In this chapter you’ll learn how to:
•choose whether to record to memory, to a file, or to a file sequence
•create and configure a recorder window
•create and work with real‐time signal views in a recorder window 

Overview of signal acquisition

Raven acquires (records) audio signals via recorders. A recorder is repre‐
sented on the Raven desktop by a recorder window that can display one or 
more views of a signal in real time as the signal is being acquired. A 
recorder window is like any other Raven sound window, except that it has 
additional controls for starting and stopping recording. 

Recording modes Raven provides three different recording modes, which differ in where the 
signal is stored as it’s recorded.
•Record to memory:  When recording to memory, audio data are not 
automatically saved to disk files, but reside only in a portion of Raven’s 
temporary memory allocated as a recording buffer. You can specify the 
size of the buffer (in seconds) when you configure a recorder. During 
recording, audio data are stored in the buffer until the buffer is full, and 
then the oldest data are continually discarded to make room for new 
data being acquired. For example, if the buffer size is 30 seconds (the 
default), the buffer will always contain the most recent 30 seconds of 
data during recording; data recorded more than 30 seconds ago are lost. 
While a signal is in the recording buffer, you can manually save it to a 
disk file, or save selections from it. Recording to memory is useful for 
exploratory browsing through recordings when you don’t need to save 
the data to files, or when the signals you’re interested in saving are 
sparsely distributed among sections that you don’t want to save. 
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•Record to file:  When recording to a single file, Raven saves audio data 
directly to a disk file for a specified amount of time, then stops. You can 
also manually stop recording to disk before the specified time has fin‐
ished.

•Record to file sequence:  When recording to a file sequence, Raven saves 
audio data continuously to a series of files, each of which is a specified 
size. Successive files in a sequence are named according to a template 
that you specify, which can incorporate a sequence number or a times‐
tamp. Raven also saves a list file, which can be used to open the file 
sequence as a single continuous signal.

Creating a recorder You create a recorder by specifying a set of configuration parameters in 
the Configure New Recorder dialog box (Figure 4.1), which is invoked by 
clicking on the Record button on the Raven toolbar (identified by the 
microphone icon, left) or by choosing File > New Recorder... .

Figure 4.1.  New Recorder dialog.

Figure 4.1.  The Input tab of the Configure New Recorder dialog box. 

You use the Record To drop‐down list in this dialog to choose whether to 
record to Memory, a File, or a File Sequence. Depending on which record‐
ing destination you choose, different tabs appear in the dialog box. The 
following sections discuss the configuration options on each tab.

Recording Input

The Input tab (Figure 4.1) allows you to choose and configure an audio 
input device. The Input tab is displayed for all three recording modes. 

Device Click on the Device drop‐down list to see a list of all available audio input 
devices. By default, the operating system’s default audio input device is 
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selected. The name that is shown for this device will be the name of the 
default audio input device (typically a built‐in sound card) for your com‐
puter. The audio input device obtains its input from a recording source that 
you choose using controls supplied by your computer’s operating system. 
Appendix C, “Configuring Audio Input” explains how to configure your 
operating system’s controls to choose a recording source (e.g., the com‐
puter’s built‐in CD player, a microphone, or line input jack) for audio 
input.

Each audio input device is characterized by a set of available sampling 
rates at which signals can be recorded, the number of channels that can be 
recorded, and a set of sample formats. Each of these parameters is dis‐
cussed below. Some devices may also have additional parameters that can 
be configured. .

Sample Rate The Sample Rate drop‐down list displays all of the sampling rates avail‐
able for the selected input device. Typically, the sampling rates available 
are determined by the underlying sound input hardware. The Sample 
Rate parameter specifies the rate at which an analog electrical signal rep‐
resenting a sound is sampled to create the digital signal. Be sure to choose 
a sampling rate that is at least twice as high as the highest frequency in the 
recording you want to acquire, in order to avoid signal distortion due to 
aliasing. See Appendix A, “Digital Representation of Sound” for a discus‐
sion of aliasing and the trade‐offs involved in choice of sampling rate. 

Channels The default audio input device on most computers provides for one‐ 
(mono) or two‐channel (stereo) acquisition. For signals that are acquired in 
stereo, the Left and Right channels are identified within Raven as Channel 
1 and 2, respectively. To acquire only one channel, uncheck either the Left 
or Right checkbox. The remaining channel will be acquired as Channel 1.

If you selected a device that supports input of more than two channels, 
each channel is represented by a numbered checkbox. If you disable input 
of some channels, data from the channels that are recorded will be repre‐
sented in the resulting acquired signal in channel‐number order, and 
renumbered sequentially beginning at Channel 1. For eample, if you are 
recording from a 16‐channel input device, and you select only input chan‐
nels 1, 5, 7, and 12, then data from these channels will be represented in 
channels 1, 2, 3, and 4 respectively of the acquired signal. 

Sample Format The Sample Format drop‐down list shows all of the sample formats avail‐
able for the selected virtual recording device. The default input device on 
most computers supports two formats, 8‐bit and 16‐bit signed PCM (Pulse 

Raven now includes support for multi-channel recording 
using both NI-DAQ and ASIO audio input devices.  For more 
information about using this feature, please see Appendix C, 
“Configuring Audio Input”.
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Code Modulation). Some sound cards will support 24‐bit signed PCM. A 
larger sample size (more bits) results in a better quality digitized signal 
(higher signal‐to‐noise ratio), but may also increase the storage require‐
ments for signals saved to disk files. See Appendix A, “Digital Representa‐
tion of Sound” for a discussion of the trade‐offs involved in choice of 
sample size.

Raven always represents signals internally with 32 bits per sample. If you 
choose an input sample size other than 32 bits, the input values are re‐
scaled to 32‐bit samples (for more on rescaling of sample values, see the 
footnote under “Sample Size” on page 77).

Recording Display

The Display tab (Figure 4.2) allows you to configure the recorder window, 
and is displayed for all three recording modes. 

Figure 4.2 .  Recorder Display tab.

Figure 4.2.  The Display tab of the Configure New Recorder dialog box.

Buffer Size The buffer size determines how much of the signal is retained in memory 
and can be visible in the recorder window during signal acquisition. You 
can specify buffer size either in seconds or minutes. You can use the drop‐
down list to choose time units of seconds or minutes. The default buffer 
size is 30 seconds.
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During recording, audio data remain in memory for the duration of the 
buffer, and are then discarded to make room for new incoming data. If 
you’re recording to memory, data that are discarded from the buffer are 
lost permanently, unless you re‐acquire them. When recording to a file or a 
file sequence, data that are gone from the buffer can be retrieved by open‐
ing the file(s) that were saved during the acquisition.

Update Rate The update rate determines how many times per second views in the 
recorder window are redrawn during signal acquisition. The default rate 
is 10 Hz. There is a trade‐off between the perceived smoothness of the 
scrolling real‐time display and Raven’s responsiveness to user interaction. 
If the update rate is too low, scrolling views move in visibly discrete steps, 
resulting in a jittery display. If the update rate is too high, Raven will be 
slow to respond to user actions such as mouse clicks or keyboard com‐
mands. In practice, the best rate will depend on the size of the recorder 
window, the number and type of views it contains, and the speed of the 
computer. The default update rate of 10 Hz provides a good balance 
between display smoothness and performance on most computers. You 
may need to experiment to determine what update rate provides the best 
performance on your computer. See “Reconfiguring an existing recorder” 
on page 88 to learn how to change the update rate once a recorder is run‐
ning.

Latency The Latency value on the Display tab specifies the difference, for a running 
recorder, between the current time and the active view’s time axis position 
(by default, the right‐hand edge of the window). Specifying a display 
latency greater than zero introduces a delay in the display of data in real‐
time views.

Display latency vs. processing latency
When a recorder is running, you may observe a flickering gray band at the 
right‐hand edge of some real‐time views. This band is more evident in 
recorder windows that are displayed at large sizes or that contain many 
views, when the time axis is zoomed in, and on slower computers. This 
band represents the view’s processing latency, which is the difference 
between the current time (by default the right‐hand edge of the window) 
and the last time for which Raven has displayed data in the view. The pro‐
cessing latency is always greater than zero because it takes some time for 
Raven to build the visual image of the data to be displayed in the view. 
Real‐time views scroll at a fixed rate, irrespective of the rate at which 
Raven builds images for display. When a view scrolls and no new image 
data are available for display, Raven draws a gray band to fill in the time 
interval for which the image is not yet available. As soon as the image is 
computed, it replaces the gray band. Processing latency is typically longer 
for spectrogram or spectrogram slice views than for waveforms, because 
spectrograms require more calculation than waveforms. The processing 
latency (hence the width of the gray band) varies from moment to moment 
for each view as Raven rapidly switches among the various tasks involved 
in updating the views in the recorder window. When the processing 
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latency is small relative to the time scale shown in a view, the flickering 
gray band disappears. When it is larger, the band becomes more promi‐
nent.

By specifying a display latency greater than zero, you give Raven some 
additional time to compute a view and build the corresponding image 
before it needs to be displayed. A small display latency (e.g., 0.1 or 0.2 sec‐
onds) often eliminates the flickering band with only a barely‐perceptible 
delay in the display of real‐time data. Non‐zero display latencies also 
result in smoother updates to real‐time spectrogram slice views.

Window preset The Window Preset drop‐down list on the Display tab shows the name of 
the window preset that will be applied to the recorder window when it is 
first created. Window presets define what views are visible in a window, 
as well as window size, selection mode, and other properties. You can 
choose from all of the window presets that are currently defined by click‐
ing on the drop‐down menu icon to the right of the Window Preset field. 
Window presets are discussed further in “Sound Window Presets” in 
Chapter 3 (page 61). 

File Format

The File Format tab appears only if you choose Record to File or Record to 
File Sequence.
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Figure 4.3. File Format tab.

Figure 4.3.  The File Format tab  of the Configure New Recorder dialog 
box.

File Format Raven can acquire audio data directly to files saved either in AIFF (Audio 
Interchange File Format, filename extension .aif) or in WAVE format 
(filename extension .wav). WAVE files can be opened by most other pro‐
grams that work with audio data. AIFF files can be opened by most Mac‐
intosh programs that work with audio data, and some programs on other 
platforms. Raven can open either type of file.

Sample Size The Sample Size parameter specifies the “bit depth” of the samples saved 
in the file(s) created during signal acquisition. Raven always represents 
signals internally with 32 bits per sample. If you choose an output sample 
size other than 32 bits, the data values are rescaled to the specified sample 
size.1 See Appendix A, “Digital Representation of Sound” for a discussion 
of the trade‐offs involved in choice of sample size.
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File Size The size of the file(s) to be saved can be specified either in time units (sec‐
onds or minutes), storage units (kilobytes or megabytes), or sample 
frames. A sample frame consists of one sample for each channel in the 
acquired signal. For example, if you specify a file size of 100,000 sample 
frames for a signal acquired at a sampling rate of 22,050 Hz, each acquired 
file would be 4.535 seconds long (4.535 = 100,000 sample frames / 22,050 
sample frames per second). If only a single channel is acquired, the file 
would contain 100,000 samples; a stereo signal would contain twice that 
many. If the files are saved with a sample size of 16 bits (2 bytes), a single‐
channel file would contain 200,000 bytes of data; a stereo file would con‐
tain 400,000 bytes.1 

File naming

If you choose Record to File or Record to File Sequence, the File Name or 
File Names tab appears (note the plural tab label when recording to file 
sequences). The fields on these two tabs allow you to specify where to save 
acquired files and how to name them. The only difference between the File 
Name and File Names tabs is that the latter allows you to specify a name 
for a list file, which is required when recording to file sequences. See 
“Recording to a file sequence” on page 82 for more about list files. This 
section explains how to specify file names for both single‐file and file 
sequence recording. 

1. In general, individual samples in a signal of sample size n can have 2n possible 
values, from ‐2n‐1 to 2n‐1‐1. Thus, Raven’s 32‐bit internal representation has 
4,294,967,296 (=232) possible sample values, from ‐2,147,483,648 to 
+2,147,483,648. If you save a file with a sample size other than 32 bits, individ‐
ual sample values are rescaled so that their values relative to the new range of 
possible values (given the new sample size) are the same as their 32‐bit values 
relative to the range of possible 32‐bit values. For example, a 32‐bit sample value of 
1,073,741,824 (half of the full‐scale value of 2,147,483,648), if saved in a 24‐bit 
signal, would be rescaled to a sample value of 4,194,304 (half of the full‐scale 
value of 8,388,607 (=223)).

1. The actual total size of AIFF or WAVE files is slightly larger than the number of 
bytes of audio data they contain because files in either format include a header 
that contains information such as the sampling rate and the number of bytes of 
data in the file.
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Figure 4.4. Single file name tab.

Figure 4.4.  The File Name tab of the Configure New Recorder dialog 
box.

Directory You can specify where to save acquired files either by typing a pathname 
(e.g., c:\SoundData\wrenProject\05May2002\) or by browsing 
through your computer’s file system. Click the Browse... button to obtain 
a browser dialog that lets you choose a directory (folder) in which to save 
acquired files. 

Sound File(s) You specify the name of the file(s) in the Sound File(s) field. For single‐file 
acquisition, the file name can be a simple text string that you type directly 
into the Sound File field, or it can be a file name template that incorporates 
date and time information that Raven fills in at the time acquisition starts, 
as discussed below. 

For file sequences, you must specify a file name template that Raven uses 
to build a unique name for each file in the sequence. A file name template 
contains some combination of date, time, and sequence number tags 
(Table 4.1). When each file in a sequence is created, Raven substitutes the 
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corresponding value for each tag in the template to generate the file 
names.

The date and time values substituted for tags in the template depend on 
the Start Time setting, as discussed under “Start Time” on page 81.

The number of characters that occur within a date, time, or sequence tag 
determine the number of characters that are written to represent that unit 
in the file name. For example, if the template is “set1‐<nn>”, the resulting 
filenames will end with two‐digit sequence numbers; while “set1‐<nnn>” 
would result in filenames ending three‐digit sequence numbers.

Table 4.1.  Date, time, and sequence tags used in acquired file names. 
Minimum and maximum values for date and time tags are shown in 
brackets.

Tag Definition

<yy> year; 2 digits minimum

<ll> month [1 12]; 2 digits minimum

<dd> day [1 12]; 2 digits minimum

<hh> hour [0 23]; decimals permitted;
2 digits minimum

<mm> minute [0 59]; decimals permitted;
2 digits minimum

<ss> second [0 59]; decimals permitted;
2 digits minimum

<n> integer sequence number, starting at 1
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For hour, minute, second, and date tags, you can specify decimal values. 
See Table 4.2 for examples.

When you enter a filename containing date or time tags, the string labelled 
“Example:” below the Audio File(s) field shows what the filename would 
be once the relevant date and time values are substituted for the tags.

Start Time You can either specify that Raven use the date and time given by the com‐
puter’s internal clock (“Now”), or you can specify some other date and 
time (like when the recording was actually made, if you are acquiring 
from tape). Times are specified using a 24‐hour representation; 1 PM 
would thus be represented as 13.

File name collisions When recording to a file or file sequence, if a file to be created has the 
same name as a file that already exists in a given directory, Raven by 
default creates a new subdirectory and puts the new file there, in order to 
avoid overwriting the old file. The new subdirectory is named “Record‐
ings‐date.time” where date and time identify the time when the directory 
was created, using the format <yyyy><ll><dd>.<hh><mm><ss> (see 
Table 4.1 for more details). When this happens, Raven displays a message 
showing the name of the file and the directory into which it was placed.

Table 4.2.  Examples of file names generated by various file name 
templates, assuming a start time of 10:30:00, and a file size of 20 seconds.

Template Resulting file names

BCV-<hh><mm><ss>.aif BCV-103000.aif
BCV-103020.aif
BCV-103040.aif
BCV-103100.aif, ... 

BCV-<hh><mm.mm>.aif BCV-1030.00.aif
BCV-1030.33.aif
BCV-1030.67.aif
BCV-1031.00.aif, ...

BCV-<hh.hhhh>.aif BCV-10.5000.aif
BCV-10.5056.aif
BCV-10.5111.aif
BCV-10.5167.aif, ...

BCV-<n>.aif BCV-1.aif
BCV-2.aif
BCV-3.aif
BCV-4.aif, ...

BCV-<nnn>.aif BCV-001.aif
BCV-002.aif
BCV-003.aif, ...
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Alternatively, you can configure Raven to overwrite existing files when 
file names collide by editing an entry in the Raven preference file, as 
described in “The Preset Manager” in Chapter 11 (page 250).  

Recording to a file sequence

If you choose Record to File Sequence, the File Names tab appears (Fig‐
ure 4.5). The File Names tab contains the same fields as shown on the File 
Name tab used for single‐file recording (see “File naming” on page 78), 
with the addition of a List File field.

Figure 4.5. File sequence names tab.

Figure 4.5.  The File Names tab of the Configure New Recorder dialog 
box.

When you record to a file sequence, Raven saves the incoming audio data 
to a continuous series of files as described in “File Format” on page 76 and 
“File naming” on page 78. In addition, Raven saves a list file, which is a 
plain text file containing a list of all of the audio files recorded in the file 
sequence. Once an audio file sequence and its associated list file have been 
created, you can open the sequence as a single signal by opening the list 
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file. Opening a file sequence via a list file is discussed in “Opening file 
sequences” in Chapter 7 (page 161).

Note that if you configure the name of your list file with relative times in 
the name of its sub‐folder, Raven will generate a new list file whenever the 
relative times you used are changed.  For example, look at the following 
list file name templates:

raven.<yyyy><ll><dd>.<hh><mm><ss>.txt ‐ this will result in a single list 
file for all of your recordings, with the list file’s name determined by when 
the first recording starts.

raven.<yyyy><ll><dd>/<hh><mm><ss>.txt ‐ this will result in a new list file 
being created in a separate folder for each new day that passes.  If you 
choose this option, you may wish to configure the names of your record‐
ings so that they will be separated into the same folders as their list files, to 
allow you to analyze them in a more straightforward manner.

Using recorder presets

You can use recorder presets to save and retrieve sets of parameters for the 
entire recorder dialog, and for each tab within the dialog. To save a 
recorder preset for the entire dialog (including parameters on all tabs), 
first configure all of the parameters on all of the tabs in the dialog the way 
you want to save them, then choose Preset > Audio Recorder > Save As... 
from the dialog’s menu bar. When the Save Audio Recorder Preset dialog 
appears, enter a name for the preset, and click OK. 

After making changes to an existing recorder, you can save those changes 
as a recorder preset in the Configure Recorder dialog (View > Configure 
Recorder...).  If you have made changes to your window layout and you’d 
like to preserve them as part of your recorder preset, you must first save 
your changes as a new window preset (View > Window Preset > Save 

If file name collisions (see “File name collisions” on page 81) 
occur while acquiring to a file sequence, the list file and some 
of the acquired audio files can end up in different directories.  
Raven will warn you that this has occurred, and then auto-
matically write the correct relative pathnames into the list file.  
You can open the list without making any changes to it. 
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As...), and then select that window preset on the Display tab of the Config‐
ure Recorder dialog before you save the recorder preset. 

To save a preset for a single tab, configure the parameters on that tab, then 
choose Preset > tab-name > Save As... from the dialog’s menu bar. For 
example, to save a preset for the Input tab (while showing the Input tab) 
choose Preset > Audio Recorder Input > Save As... . When the Save dialog 
appears, enter a name for the preset, and click OK.

To retrieve a preset for the entire recorder dialog, choose Preset > Audio 
Recorder > preset-name. To retrieve a preset for the current tab, choose 
Preset > tab-name > preset-name. When you retrieve a preset, all of the  
parameters in the Configure Recorder dialog or in the current tab are 
immediately set to the saved values. If you then change some parameters 
and want to revert to the saved values, choose the name of the preset from 
the Preset menu again. If you want to save changes you’ve made under 
the name of the last preset you loaded, choose Preset > Audio Recorder > 
Save “preset-name” or Preset > tab-name > Save “preset-name”.

The recorder window:  real-time views during recording

When you click OK in the Configure New Recorder dialog, a new recorder 
window appears on the Raven desktop (Figure 4.6), with the window lay‐
out that you specified on the Display tab. If you chose recording to mem‐
ory in the  Configure New Recorder dialog, only the triangular green 
Record-to-Memory button appears at the bottom of the window. If you 
chose recording to a file or file sequence, the Record-to-Memory and 
round red Record-to-Disk buttons both appear at the bottom of the win‐
dow. 

Except for the two record buttons at the bottom of the window, a recorder 
window looks and behaves exactly like any other Raven sound window. It 
can contain multiple views that can be linked to each other in various 
ways. By default, a new recorder window contains a single waveform 
view. You can make selections in a recorder window and see correspond‐
ing measurements in the selection table.

Audio recorder presets must be saved in the folder Pre-
sets/Audio Recorder/ within the Raven program folder. 
You can also create additional folders within the Audio 
Recorder folder by clicking on the New Folder icon within 
the Save Sound Window dialog. These folders will appear as 
submenus in the Preset > Audio Recorder menu, with each 
submenu listing the presets in the corresponding folder.
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Figure 4.6. New recorder window

Figure 4.6.  A new recorder window, configured for recording to file(s), 
with a 30 second recording buffer.

Creating real-time
signal views

You can create a new view in a recorder window any time, whether the 
recorder is running or stopped. If a recorder window already contains 
multiple views, particularly if they are displayed at a large size, Raven’s 
responsiveness to keyboard and mouse activity may slow down notice‐
ably on slower computers while the recorder is running. In such cases, it 
may be preferable to create new spectrogram or spectrogram slice views 
while the recorder is stopped.

Recording to
memory

To begin recording to memory, click the Record to Memory button at the 
bottom of the window. Data begin appearing at the right edge of the win‐
dow (where the position marker is located by default in a recorder win‐
dow) and scroll across from right to left in all of the waveform and 
spectrogram views that are displayed. If data do not start appearing in the 
recorder window, refer to “Problems with recording” on page 96. To stop 
recording, click the square green Stop Recording button that replaces the 
Record to Memory button.

Each time you start recording, any data already in the record-
ing buffer are erased.
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Recording to files Raven always records to memory when recording to a file or file sequence, 
so that the recorder window can display real‐time views during acquisi‐
tion. To begin recording to a file or file sequence, click the Record to File 
button. The Record to File button is then replaced by the square red Stop-
Recording to File button. If the recorder is not already recording to mem‐
ory, recording to memory and to a file or file sequence begins immediately, 
and all views in the window begin displaying data. If the recorder is 
already recording to memory when you click the Record to File button, 
recording to memory continues, and recording to the specified file or file 
sequence begins. 

While recording to a file, Raven displays the name of the file and a 
progress bar at the bottom of the recorder window to indicate how much 
of the file has been recorded. If you’re recording to a single file, file record‐
ing stops when the file has reached the size specified in the Configure 
Recorder dialog (see “File Size” on page 78). If the recorder was recording 
to memory before file recording started, it continues recording to memory 
after file recording stops. When a file in a sequence has reached the speci‐
fied size, recording to disk continues uninterrupted with the next file, and 
continues until you click the Stop Recording to File button.

Adjusting recording
level

In order to avoid distortion in recorded signals, it is important to adjust 
the recording level appropriately. You adjust the recording level using 
controls provided by your operating system, as discussed in Appendix C, 
“Configuring Audio Input”.

Ideally, the level should be adjusted so that the minimum and maximum 
excursions of the waveform view are close to the vertical limits of the 
waveform scale, without actually reaching those limits. If the recording 
level is set too low, some features of the signal may not be visible in signal 
views. If the recording level is set too high, the acquired waveform will be 
clipped. Clipping occurs when the magnitude of the original analog wave‐
form exceeds the maximum magnitude that can be represented with the 
given sample size and recording level. The result is that waveforms get 
truncated or “clipped” in the digital signal (Figure 4.7). When viewed in 
the frequency domain (i.e., in spectrogram or spectrogram slice views), 
clipped signals include spurious harmonics not present in the original 
analog signal (see spectrograms in Figure 4.7). 

If you are recording from a tape player and would like to hear 
some of the recorded sound just after it has been recorded, 
you can use the Raven scrolling play button to do this.  If you 
use the play button, you will hear the current buffer from its 
beginning, not the sound as it is being recorded.  Also, if you 
are using a microphone to record, you should not attempt to 
play the sounds as they are being recorded because the out-
put sounds from the speakers will feed back into the micro-
phone.
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Figure 4.7. Clipped and unclipped signals

Figure 4.7.  (a) Unclipped and (b) clipped waveform and spectrogram 
views of a 500 Hz sinusoidal signal. The clipped version was acquired 
with the recording level set too high. The unclipped version accurately 
represents the original signal. Note how the tops and bottoms of the 
waveform are truncated in the clipped version, resulting in the appear-
ance of spurious harmonic energy at 1000, 1500, and 2500 Hz in the 
clipped spectrogram. 

Navigating and
selecting data in a

running recorder

Zooming and scrolling
When you first create a recorder window, the time axis is (by default) 
zoomed so that the length of the recording buffer just fits in the window. 
The time position location is at the right‐hand edge of the window. As 
with any other sound window, you can zoom and scroll any view in any 
dimension, whether the recorder is running or stopped. If you drag the 
scroll thumb away from the right‐hand end of the scrollbar while the 
recorder is running, the view stops scrolling and the data remain station‐
ary in the window, although acquisition continues without interruption. 
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When you release the scroll thumb at any point other than at either end of 
the scrollbar, the thumb begins to “crawl” to the left. This movement 
occurs because, as the view remains fixed at a particular time, its position 
within the buffer changes as new data are acquired and the oldest data are 
discarded. When the scroll thumb approaches the left edge of the window 
(representing the point at which the oldest data are discarded), data begin 
to disappear from the left‐hand end of the view, and are replaced from left 
to right by a gray background. 

Selections and editing in a recorder window
When a recorder window contains audio data, you can create selections, 
whether the recorder is running or stopped. You can copy and save selec‐
tions, but Cut, Delete, and Paste operations are prohibited in recorder 
windows. 

Reconfiguring an
existing recorder

Reconfiguring while acquisition is stopped
When a recorder is stopped, you can reconfigure all of its parameters. 
Choose Configure Recorder... from the recorder window’s context menu 
to open the Configure Recorder dialog box. You can change any of the  
parameters in this dialog, and click OK. 

Reconfiguring while recording
While a recorder is running, you can change its update rate and display 
latency (see “Update Rate” on page 75, and “Latency” on page 75). Other 
parameters cannot be changed without first stopping the recorder. Choose 
Configure Recorder... from the recorder window’s context menu to open 
the Display tab of the Configure Recorder dialog. In the dialog, there is an 
asterisk on those tabs that can be modified while the recorder is running.

Multiple recorder
windows

Raven allows you to create multiple recorders, with different parameters. 
If you need to switch back and forth repeatedly between different sets of 
parameters— e.g., different sample rates or different destinations for 
acquired files— you can keep multiple recorders open on the Raven desk‐
top, and switch among them as needed. However, only one recorder at a 
time can be running.

Advanced options: acquiring from recordings at altered input speeds

Raven can correct for alterations in the speed at which a recorded sound is 
played during acquisition. 

When you reconfigure a recorder, any data that are already in 
the recording buffer are lost, and any detectors in the 
recorder are deleted. 
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It is sometimes necessary or useful to acquire sounds from a recording 
that is being played back either slower or faster than the original recording 
speed. For example, ultrasonic signals of bats and dolphins cannot be 
properly digitized using most computer sound cards, because these cards 
can only digitize sounds up to 22 kHz (half the maximum sampling rate 
on most sound cards) without aliasing.1 One solution is to shift the fre‐
quencies in the recorded input sound down below 22 kHz during acquisi‐
tion by playing the sound back at a reduced speed.

When working with signals that are too low in frequency to be audible, it 
may be convenient to play the tape back at a high speed during acquisi‐
tion, so that you can hear the signals as they are acquired.

If you click on the Advanced button at the bottom of the Configure 
Recorder dialog, an additional tab labelled Speed becomes available (Fig‐
ure 4.8). The Speed tab lets you specify whether the sound to be acquired 
is at normal speed, or slowed down or sped up by a specified factor rela‐
tive to normal speed. To hide the Speed tab, click the Simple button that 
appears in place of the Advanced button.

For example, to shift signals from 150 kHz down so that they could be 
acquired by a sound card with a maximum bandwidth of 22 kHz, you 
could play the recording at 1/8 normal speed during acquisition (150 kHz/
8 = 18.75 kHz). In this case, you would specify in the Speed tab that the 
recording was slowed down by a factor of 8.

1. Aliasing is a type of distortion that occurs when sounds that are being digi‐
tized contain energy at frequencies that are more than half the sampling rate. 
Aliasing is explained more fully in “Aliasing and the Nyquist frequency” in 
Appendix A (page 272).

Input speed adjustment is useful only when acquiring from a 
recording that can be played back at altered speed. If you 
need to record ultrasonic signals directly into Raven from a 
live source, you need to have a sound card that provides a 
sampling rate at least twice the highest frequencies in the sig-
nal. For further information about sampling rates, see “Sam-
pling rate” in Appendix A (page 272).
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If you provide the appropriate input speed correction factor in the Speed 
tab, then Raven will display time and frequency axes of views, and mea‐
surements so that they refer to the original sound at normal speed.

Figure 4.8.  Speed tab

Figure 4.8.  The Speed tab of the Configure New Recorder dialog box. 
This tab is visible only after you click the Advanced button (which is 
then replaced by the Simple button).

Advanced options: sample rate conversion during recording

Raven can decimate a signal as it is being acquired. Decimation is a way of 
reducing the sampling rate of a signal by retaining every Nth sample, and 
discarding all others. Raven automatically applies a low‐pass filter to a 
signal before decimating it, in order to prevent aliasing in the decimated 
signal.1

Sounds that are acquired at an altered speed using the 
appropriate speed correction factor behave in Raven as if 
they had been acquired at normal speed. Thus, to hear 
sounds that were originally above or below the human hear-
ing range, you will need to specify an appropriately low or 
high speed for playback, as described in “Playback rate” in 
Chapter 1 (page 9).
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Why decimation is
useful

For low‐frequency sounds, the lowest sampling rate available with a par‐
ticular device may be many times higher than needed to represent the sig‐
nal accurately. This can lead to digitized signals that are much larger than 
necessary, which require more storage and longer processing times. Deci‐
mation during signal acquisition is a way of reducing the sampling rate to 
a rate that is more appropriate for the signal. Appendix A, “Digital Repre‐
sentation of Sound” discusses choice of sampling rate further.

For example, most of the sounds made by blue whales or elephants are at 
frequencies below 100 Hz. For many types of analysis of these signals, 
sampling rates of 200 to 500 Hz are desirable. However, the lowest sam‐
pling rate provided by many recording devices is 8000 Hz. By choosing a 
decimation factor of 16 or 32, the signal can be acquired with a sampling 
rate of 500 or 250 Hz, respectively.

Decimation Factor If you click on the Advanced button at the bottom of the Configure 
Recorder dialog, an additional tab labelled Rate Conversion is displayed 
(Figure 4.9). You can hide the Rate Conversion tab by clicking the Simple 
button, which replaces the Advanced button. 

1. Aliasing is a type of distortion that occurs when sounds that are being digi‐
tized contain energy at frequencies that are more than half the sampling rate. 
Aliasing is explained more fully in “Aliasing and the Nyquist frequency” in 
Appendix A (page 272).
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Figure 4.9. Decimation tab.

Figure 4.9.  The Rate Conversion tab of the Configure New Recorder 
dialog box. This tab is visible only after you click the Advanced button 
(which is then replaced by the Simple button).

The Rate Conversion tab displays the Input Sample Rate, which is the rate 
selected on the Input tab (see “Sample Rate” on page 73), a drop‐down 
menu from which you can choose a decimation factor, and the resulting 
Output Sample Rate. The Output Sample Rate is the sampling rate of the 
signal that will be acquired. A decimation factor of N means that every 
Nth sample is retained, resulting in a sampling rate of 1/N times the input 
rate. Thus, a decimation factor of 1 implies no decimation. The decimation 
factor available are 2, 4, 8, 16, and 32. 

Advanced options: scheduled recording

If you click on the Advanced button at the bottom of the Configure 
Recorder dialog, an additional tab labelled Schedule becomes available 
(Figure 4.10). The Schedule tab contains parameters that you can set to 
control when Raven begins acquiring data. To hide the Schedule tab, click 
the Simple button that appears in place of the Advanced button.
92 Raven Pro 1.3 User’s Manual



Chapter 4:  Signal Acquisition (Recording)
Figure 4.10. Recording schedule tab.

Figure 4.10.  The Schedule tab of the Configure New Recorder dialog 
box. This tab is visible only after you click the Advanced button (which 
is then replaced by the Simple button).

Retroactive
Recording Offset

The Retroactive Recording Offset field allows you to specify the time off‐
set used in retroactive recording to files. When a recorder is already 
recording to memory, retroactive recording enables you to start recording 
to a file or file sequence beginning at a time in the recording buffer before 
the moment that you clicked the Record-to-Disk button. Retroactive 
recording is discussed further in “Advanced options: retroactive recording 
to files” on page 93.

Advanced options: retroactive recording to files

When configuring a recorder, you can use the Retroactive Recording Off-
set field to specify that acquisition to disk files should begin at a point in 
time prior to the moment when you click the Record to File button, provided 
that the recorder was already recording to memory (see “Retroactive 
Recording Offset” on page 93). This feature is useful when acquiring data 
from field or lab recordings that contain signals of interest interspersed 
among long segments without such signals. For example, if you’re acquir‐
ing data from a tape recording, you might configure a file sequence 
recorder with a 5 second retroactive recording offset. You would then 
monitor the tape by starting the recorder in record‐to‐memory mode and 
watching real‐time views as the tape is played back. When you see or hear 
a signal of interest, you would click the Record to File button. Raven 
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would immediately begin acquiring data, starting with the last 5 seconds in 
the recording buffer (i.e., the last five seconds shown in real‐time views in 
the recorder window). As long as you start the disk recording within 5 sec‐
onds of the start of your signal of interest, that signal would be saved to 
disk.

Advanced options: exporting clip files while recording

The Clip Exporter now allows sound clips to be saved before the audio 
data in the real‐time recorder leaves the audio buffer. This facilitates mak‐
ing manual selections in a recording while it is recording. When a selec‐
tion is committed, the audio data in the selection is saved to a file. See 
Figure 4.11 for images of the related Clip Exporter tabs in the recorder dia‐
log.

The Clip Exporter is an alternative to the Schedule tab (see “Advanced 
options: scheduled recording” on page 92) with the Record To File option.  
The Schedule tab allows a recording to be made each time the red record 
button is pressed. However, the system needs to be configured to do retro‐
active recording in order to record sounds that are already in the buffer, 
and the record button needs to be pressed before the end of the retroactive 
time limit.  In contrast, the Clip Exporter allows a selection to be made at 
any time within the 30‐second buffer (Figure 4.12)

Also, the Clip Exporter is similar to Save Active Selection As; however, it 
allows all of the names that will be assigned to the files to be preconfig‐
ured, since there isn’t time to fill in this information before the sound 
leaves the buffer.

The Clip Exporter can also be used in conjunction with a 
Raven detector (see “Saving detected selections” in Chapter 
10 (page 228)) so that when an event signal is detected, a 
selection is created, and the selection is automatically saved 
to a file.
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Figure 4.11 Clip tabs

Figure 4.11. a) The Clip Format tab and b) the Clip Names tab within 
the recorder window.
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Figure 4.12 Clip Exporter

Figure 4.12. A recorder window with the “Export selections to clip files” 
option selected.

Problems with recording

Device unavailable If, when you click on the Start Recording button in a recorder window, 
Raven displays a message indicating that the audio device is unavailable, 
check to make sure that there is not another recorder running within 
Raven. Only one recorder at a time can be running. Another possible rea‐
son for this condition is that the audio input device has been allocated by 
another application. If there is another audio application running, you 
may need to quit from it in order to record in Raven. Some audio CD 
player programs allocate the audio device for their exclusive use. Such 
applications cannot be used to play CDs for input into Raven. If you have 
this problem, try using a different program for playing CDs.

Unsupported audio
format

While using some audio CD player programs, attempts to record with 
Raven may result in an error message stating that “the specified audio for‐
mat is not supported.” In most cases, this message is itself erroneous (i.e., 
the audio format is supported), and the problem can be rectified by using 
a different audio CD player program.
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About this chapter

This chapter is a reference for working with spectrogram, spectrogram 
slice, and selection spectrum views in Raven. The chapter assumes that 
you have read Chapter 1, “Getting Started”, and that you are acquainted 
with basic concepts involved in short‐time Fourier transform (STFT) anal‐
ysis of time‐varying signals. Terms such as data record (equivalent to 
“frame” or “aperture”), filter bandwidth, window overlap, and window 
function are explained here only briefly. If you are not already familiar 
with these concepts, we recommend that you read Appendix B, “A Biolo‐
gist’s Introduction to Spectrum Analysis”, which provides the conceptual 
background needed to make full use of Raven’s spectrogram analysis 
capabilities.

About spectrographic views

Raven provides three types of views that show the relative intensity of dif‐
ferent frequency components of a sound (i.e., sound spectrum information; 
see Figure 5.1).   
•Spectrogram views show how the spectrum of a sound varies over time 
in a three‐dimensional plot, in which time is represented on the horizon‐
tal axis, frequency on the vertical axis, and the relative power at a given 
point in time and frequency as a color (by default, grayscale) value.

•Spectrogram slice views display a single spectrum from the series of 
spectra that constitute a spectrogram (see below), plotted as a two‐
dimensional line graph with frequency on the horizontal axis, and rela‐
tive power (in decibels) on the vertical axis. 

•Selection spectrum views show the average spectrum of a sound over 
the time interval defined by the active selection.
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Figure 5.1. Three spectral views

Figure 5.1. Raven’s three spectrographic views. The spectrogram slice 
shows a single spectrum from the spectrogram, at the time indicated by 
the time position marker (8.329 seconds). The selection spectrum 
shows the average spectrum over the time interval defined by the high-
lighted selection in the spectrogram.

How the
spectrographic

views are related

To calculate any one of the three spectrographic view types, Raven divides 
a sound (or a selected portion of a sound) into a series of successive short 
time segments, or records, and calculates a single spectrum for each record, 
using an algorithm called the discrete Fourier transform (DFT). For spectro‐
gram and spectrogram slice views, this process is performed for the entire 
sound. For selection spectrum views, only the part of the sound within the 
time interval of the active selection is processed.

In a spectrogram, Raven displays the spectra of all of the records, arranged 
successively from left to right according to the time of the corresponding 
record in the sound. Each spectrum is displayed as a tall, narrow bar (Fig‐
ure 5.2, upper view). The vertical axis of each bar represents the frequency 
axis of the spectrum. The color of the bar varies from bottom to top, with 
the color at a particular frequency (i.e, height along the bar) representing 
relative power or intensity at that frequency for the corresponding record.

In a spectrogram slice, Raven displays only one spectrum at a time (Figure 
5.2, lower view). The choice of which spectrum is displayed at any 
moment depends on the time position of the spectrogram slice view, as 
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described later in this chapter (see “Time position of a spectrogram slice 
view” on page 123).

Figure 5.2  Boxy gram and slice

Figure 5.2.  Relationship between spectrogram and spectrogram slice 
views. The spectrogram shown here is a close-up of about 1 second 
from Figure 5.1, encompassing 17 individual spectra. Spectrogram 
smoothing has been turned off to reveal the individual spectra in the 
spectrogram. The highlighted selection identifies the one spectrum that 
appears in the spectrogram slice view. The time position of the spectro-
gram slice view is indicated by the time position marker in the spectro-
gram (at 20.555 sec).
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In a selection spectrum view, Raven displays an average spectrum based 
on a series of short spectra computed over the time interval of the active 
selection (Figure 5.1, bottom view).

Since all three spectrographic views start with calculating spectra of a 
series of records, most of the parameters that must be specified for all 
three view types are the same. The next section briefly explains each 
parameter.

Configuring spectrographic views

To create a new spectrogram, spectrogram slice, or selection spectrum 
view, click on the appropriate New View button in the view toolbar (Fig‐
ure 5.3) or choose a view type from the View > New menu.

Figure 5.3.  New View buttons

Figure 5.3.  The New View buttons, in Raven’s view toolbar.

Raven now introduces a slight change in the calculation of 
power spectra.  The new method includes energy in the neg-
ative frequency bins of the DFT, as well as normalization of 
the power spectrum by the number of points in the DFT win-
dow.  Power measurements made using this method will dif-
fer from the same measurements performed with previous 
versions of Raven by a multiplicative factor of 2/Nfft (1/Nfft for 
the zero frequency component).  To use this updated power 
spectra calculation, check the box on the option screen that 
appears when Raven starts for the first time.

The new power spectra calculation should be used in cases 
when measurements need to be consistent with those made 
in Canary.

For more specific information on this new measurement 
method, including how to change the current method and run 
comparisons between the methods, see “Power Spectra Cal-
culation Method” in Chapter 11 (page 257).
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A dialog box appears, containing parameters for configuring the 
requested type of spectrographic view (Figure 5.4). The dialog boxes for 
configuring spectrogram and spectrogram slice views are identical, except 
for their titles. The dialog boxes are identical because both view types cal‐
culate a spectrogram of the entire sound; the only difference between 
spectrogram and spectrogram slice views is in how the data are displayed 
(see “How the spectrographic views are related” on page 98). The dialog 
box for configuring a selection spectrum view is the same, except that it 
lacks the Averaging parameter.

The remainder of this section explains each of the parameters in the con‐
figuration dialog box.

Figure 5.4 Configure Spectrogram dialog

Figure 5.4.  The Configure New Spectrogram dialog box. 

Window type Each data record is multiplied by a window function before its spectrum is 
calculated. Window functions are used to reduce the magnitude of spuri‐
ous “sidelobe” energy that appears at frequencies flanking each analysis 
frequency in a spectrum. These sidelobes appear as a result of analyzing a 
finite (truncated) portion of a signal. A window function can reduce these 
sidelobes by “tapering” the portion of the waveform that appears in each 
window. Window functions are discussed further in Appendix B, “A Biol‐
ogist’s Introduction to Spectrum Analysis”.

Raven provides six different window functions: Blackman, Hamming, 
Hann (sometimes called Hanning), Kaiser, rectangular, and triangular 
(sometimes called Bartlett). Each window function is characterized by the 
magnitude of the sidelobes relative to the center lobe. The difference in 
decibels between the center lobe magnitude and the magnitude of the 
largest sidelobe is called the sidelobe rejection (Figure B.10 on page 294). In a 
grayscale spectrogram, differences among windows in sidelobe rejection 
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result in different amounts of gray “fringing” above and below black or 
very dark areas.

For a given window size, different window functions will result in differ‐
ent filter bandwidths (see “3 dB Bandwidth” on page 104). In terms of a 
spectrogram, this means that the vertical thickness of a horizontal line rep‐
resenting a pure tone will depend on which window function is used.

Figure 5.5 and Figure 5.6 illustrate the effect of different window functions 
on spectrogram and spectrogram slice views of the same signal.

Figure 5.5.  Window comparison‐

SPG

Figure 5.5.  Effect of choice of window function on spectrograms. The 
signal is a series of calls from a red-breasted nuthatch, digitized at 44.1 
kHz. All three spectrograms have the same window size (= 512 points, 
11.6 mS), hop size = 5.8 mS (frame overlap = 50%), and frequency grid 
spacing = 86.1 Hz (FFT size = 512 samples). 3 dB bandwidths: (a) 141 
Hz, (b) 124 Hz, (c) 76.2 Hz.
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Figure 5.6. Window compare‐

slice

Figure 5.6.  Effect of window function on spectrogram slice views. 
These spectrogram slice views were made at the point indicated by the 
position marker in Figure 5.5, midway through the second call. All three 
spectra have the same window size (= 512 points, 11.6 mS), and fre-
quency grid spacing = 86.1 Hz (FFT size = 512 samples). 3 dB band-
widths: (a) 141 Hz, (b) 124 Hz, (c) 76.2 Hz.

The appearance of sidelobes in spectra of finite‐length signals, the use of 
window functions to reduce their magnitude, and differences among the 
various window functions are discussed further in Appendix B, “A Biolo‐
gist’s Introduction to Spectrum Analysis”.

Window size The Window Size parameter controls the length of each data record that is 
analyzed to create each of the individual spectra that together constitute 
the spectrogram. You can specify window size either in number of sam‐
ples from the digitized signal, or in time units (seconds or milliseconds) by 
choosing the preferred unit from the drop‐down menu. The default unit is 
samples. If you specify window size in seconds or milliseconds, Raven 
uses the number of samples that most closely approximates the window 
size that you enter.

The maximum value of the Window Size parameter depends on whether 
the DFT Size parameter is locked, as discussed in “Frequency grid spacing 
and DFT size” on page 108. When DFT Size is unlocked, Window Size can 
Raven Pro 1.3 User’s Manual 103



Chapter 5:  Spectrographic Analysis
be set to a maximum of 65,536 samples (= 216). When DFT Size is locked, 
the maximum value of the Window Size is equal to the DFT Size. 

Window Size slider control
Adjacent to the Window Size field is a slider control that provides an alter‐
nate means for changing the window size. Sliding the control to the right 
increases the window size. The control is logarithmic: the farther the slider 
is moved to the right, the more the window size changes in response to a 
given movement. The window size slider is useful primarily when the 
Auto-apply checkbox is checked (see “Apply and Auto‐apply” on 
page 115). When Auto-apply is turned on, Raven recalculates the spectro‐
gram immediately as you adjust the slider, allowing you to instantly see 
how changes in window size affect the tradeoff between time and fre‐
quency resolution.

Beta (Kaiser
window only)

For the Kaiser window, you can set an additional parameter, called Beta, 
to values between 0 and 20. For a given window size, higher values of Beta 
result in larger filter bandwidths and smaller sidelobes.

3 dB Bandwidth 3 dB bandwidth is the filter bandwidth of the individual analysis filters in 
the filterbank simulated by the short‐time Fourier transform (STFT) with 
the selected window type and size (see Appendix B, “A Biologist’s Intro‐
duction to Spectrum Analysis”). Specifically, the 3 dB Bandwidth field dis‐
plays the width (in Hz) of the main lobe of the spectrum of a sinusoid at 
the point where the power is 3 dB lower than the maximum power in the 
spectrum (Figure 5.7).

Figure 5.7. 3dB bandwidth

Figure 5.7. Spectrum of a pure tone sinusoidal signal. The 3 dB band-
width is the width BW (in Hz) of the spectrum’s main lobe at the point 
where the power is 3 dB less than the maximum power in the spectrum.

Use of the Window Size slider with Auto-apply turned on may 
result in unacceptable delays in redrawing the spectrogram 
with longer signals and/or slower computers.
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When you change the window size or the window type, the 3 dB Band-
width field is immediately updated to display the corresponding band‐
width. For a given window type, improved time resolution (shorter 
windows) inevitably results in poorer frequency resolution (larger band‐
widths). You can edit the 3 dB Bandwidth field to specify a desired value 
directly. When you press <Enter>, click on another field in the dialog, or 
click OK or Apply, Raven will choose the window size that results in the 
closest available approximation to the 3 dB Bandwidth value you entered. 
For further discussion of the tradeoff between time and frequency resolu‐
tion in spectrograms, see Appendix B, “A Biologist’s Introduction to Spec‐
trum Analysis”.

Choosing the
window size

In a spectrogram, where you are typically interested in frequency varia‐
tions with time, the “best” choice of window size depends in part on the 
nature of the signal, and on what features you are most interested in 
observing or measuring. If you are most concerned with precise frequency 
measurements, you will probably want to choose a large window size 
(hence better frequency and poorer time resolution). If you want better 
time resolution, choose a shorter window size; the bandwidth will then be 
larger (poorer frequency resolution; Figure 5.8). 

Figure 5.8.  Cassin’s KB, win size compare

Figure 5.8.  Effect of choice of window size on time and frequency 
smearing in spectrogram views  of Cassin’s kingbird sound (digitized at 
44.1 kHz). For both views, window type = Hann, hop size = 64 samples, 
Frequency grid spacing = 22 Hz. (a) Window size = 800 samples, 3 dB 
bandwidth = 79 Hz. (b) Window size = 150 samples, 3 dB bandwidth = 
423 Hz. View (a) has better frequency resolution (note sharpness of the 
nearly constant-frequency bands in selection #2), but poorer time reso-
lution (note horizontal smearing of the rapid downsweep in  selection 
#1, and in the oscillating frequencies in the second part of the call). 
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Figure 5.9 shows an extreme example of how choice of window size can 
change the appearance of a spectrogram. See Appendix B, “A Biologist’s 
Introduction to Spectrum Analysis” for further discussion and more 
examples of the effect of varying window size and bandwidth.

Figure 5.9.  Window size spg demo (dolphin)

Figure 5.9.  Effect of varying analysis resolution on spectrograms. The 
signal is part of a rapid series of clicks produced by a spotted dolphin, 
digitized at 48 kHz. The period between clicks is about 1.4 mS, corre-
sponding to a frequency of about 720 Hz (= 1/0.0014). The two spectro-
grams differ only in window size, and hence bandwidth. In both 
spectrograms, hop size = .208 mS, window = Hamming. (a) Bandwidth 
= 3121 Hz (window size = 20 points = .417 mS), overlap = 50%. In this 
representation, each click appears as a broad-band vertical stripe on 
the spectrogram because the window size is short enough to resolve 
individual clicks. (b) Waveform. When played at normal speed, the sig-
nal sounds to a human like a buzz. (c) Bandwidth = 61 Hz (window size 
= 1024 points = 21.3 mS), overlap = 99%. In this representation, indi-
vidual clicks cannot be resolved because each window encompasses 
about 15 clicks; instead the click repetition frequency appears as a 
series of horizontal bands spaced 720 Hz apart (the click repetition fre-
quency).

Time grid: Window
Overlap and

Hop Size

Hop size1 refers to the time interval (measured either in samples or in time 
units such as seconds or milliseconds) between the beginnings of succes‐
sive windows or records. In an unsmoothed spectrogram (see “Smoothed 
vs. unsmoothed display” on page 120), the hop size can be seen as the 

1. Hop size was called time grid spacing in versions prior to Raven 1.2. 
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width or duration of the individual cells in the spectrogram (Figure 
5.10).Hop size can be smaller than the window size because successive 
windows can overlap each other. Windows can also be contiguous (0% 
overlap) or separated by time intervals that are omitted from the analysis 
(negative overlap).

Window overlap is usually expressed as percent of window size. For 
example, an overlap of 50% means that each window begins halfway 
through the preceding window. An overlap of ‐100% means that one win‐
dow of data is skipped between successive windows that are analyzed;      
‐300% skips three frames, and so on. The relationship between hop size 
and window overlap is given by

hop size = window size * (100% ‐ overlap%).

The Hop Size and Overlap fields in the dialog box are coupled so that you 
can specify hop size either directly, by typing a value in the Hop Size field, 
or indirectly, by typing a value in the Overlap field. Using the units drop‐
down menu, you can specify the measurement units for hop size as either 
samples (the default), seconds, or milliseconds. If you enter a value in the 
Overlap field that does not correspond to an integer number of samples, 
Raven substitutes the closest overlap value that does.

Figure 5.10 shows three spectrograms that differ only in hop size.
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Figure 5.10. Window overlap comparison

Figure 5.10.  Effect of varying hop size in spectrograms. The signal is 
part of a song of a lark sparrow, digitized at 44.1 kHz. The three spec-
trograms are unsmoothed and differ only in hop size (window overlap). 
In all three spectrograms, window type = Hann, window size = 512 
samples (= 11.6 mS; 3 dB bandwidth = 124 Hz), frequency grid spacing 
= 86.1 Hz (DFT size = 512 samples). (a) Hop size = 11.6 mS (window 
overlap = 0%). (b) Hop size = 5.8 mS (window overlap = 50%). (c) Hop 
size = 1.1 mS (window overlap = 90%).

Lock Overlap vs. Lock Hop Size
Next to the Overlap and Hop Size fields are two buttons, marked with 
open and closed padlock icons. The button that displays the closed pad‐
lock indicates which value— window overlap or hop size— will be locked 
or held constant when you make changes to the window size. Clicking on 
either button reverses the state of both buttons. 

Frequency grid
spacing and DFT

size

The frequency grid spacing of a spectrogram (visible as the height of the 
individual boxes in an unsmoothed spectrogram; see “Smoothed vs. 
unsmoothed display” on page 120) depends on the sample rate (which is 

A spectrogram made with a negative window overlap ignores 
some of the available data, and can give an extremely mis-
leading picture of a signal. Negative window overlaps should 
generally be avoided unless you have some specific reason 
for wanting to omit some parts of a signal from analysis.
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fixed for a given digitized signal) and a parameter of the STFT called DFT 
size.1 The relationship is 

frequency grid spacing = (sampling frequency) / DFT size

where frequency grid spacing and sampling frequency are measured in 
Hz and DFT size is measured in samples. DFT size is constrained to be a 
power of 2 that is greater than the current window size.

The DFT Size and frequency Grid Spacing fields in the Configure Spectro‐
gram dialog box are linked: you can specify the frequency grid spacing 
either directly by choosing a value from the Grid Spacing drop‐down 
menu, or you can choose a value from the DFT Size drop‐down menu.  
The DFT Size menu displays powers of 2 greater than or equal to the cur‐
rent window size. Larger DFT sizes correspond to smaller frequency grid 
spacings. 

Lock DFT Size
Next to the DFT Size drop‐down menu is a button marked with a padlock 
icon. When this button is unlocked (the default), Raven adjusts the DFT 
size as you change the window size, in order to maintain a consistent rela‐
tionship to the window size, subject to the constraint of being a power of 2. 
For example, in the default spectrogram parameters, the DFT size is the 
smallest power of 2 greater than or equal to the window size. If you 
increase the window size from 512 to 513, Raven changes the DFT size 
from 512 to 1024. If you manually choose the DFT size to be, for example, 
the second power of two greater than or equal to the window size (e.g., 
with window size of 512, you set DFT Size to 1024 instead of 512), then 
Raven will change DFT Size to maintain this relationship as you adjust 
window size.

When the DFT Size padlock button is locked, the DFT size (hence fre‐
quency grid resolution) is fixed, and will not change when the window 
size changes. 

Clipping level The Clipping Level parameter allows you to specify a “noise floor” below 
which any amplitude value is altered, in order to reduce or eliminate the 

1. The parameter that Raven calls DFT Size is sometimes called FFT size in other 
programs. FFT stands for fast Fourier transform, which is a particular algorithm 
used to compute the discrete Fourier transform or DFT. Size is a characteristic of 
a particular DFT, not of the FFT algorithm used to compute it.   

Because the window size cannot exceed the DFT Size, the 
maximum value you can specify for Window Size, either by 
typing a value, or by moving the slider control, is limited to the 
DFT Size value when DFT Size is locked.
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effect of the noise.  After you enable clipping, you can modify it using two 
paramaters: (1) the power level below which values will be altered, and (2) 
the power level to which to set the altered values.

Figure 5.11

Figure 5.11.  The Clipping dialog box.

In a spectrogram view, if you choose to clip to a value of ‐Infinity, every‐
thing that is below your noise floor will appear as white.  If you clip to a 
different value (for example, 0 dB), everything below your noise floor will 
appear as very light.  These differences will result in different appearances 
once your spectrogram is smoothed, so you may wish to vary your param‐
eters and examine the results as you explore.  See Figure 5.12 for an exam‐
ple.

In a spectrogram slice view, if you choose to clip to a particular dB value, 
then the result will be a smooth slice view without any dropouts; but if 
you choose to clip to ‐Infinity dB, the result will contain many dropouts 
and will be more difficult to read.  See Figure 5.13 for an example.

There are several reasons to perform clipping.  First, because of the finite 
precision of the digitization process, a digitized sound always contains 
some error and has a limited dynamic range.  For signals digitized with 8‐
bit samples, the dynamic range is limited to 48 dB; for 16‐bit samples, the 
dynamic range is limited to 96 dB.1  Therefore any power value in an 8‐bit 
spectrogram that is more than 48 dB below the highest peak in the signal 
must be noise introduced by the digitizing process, and should be disre‐
garded.2  The noise floor can also be useful for removing noise that was 
present before the digitizing process (for example, from a recording with 
low‐level wind or other broad‐band noise).

A more pragmatic reason for noise clipping is that very small power val‐
ues show up on a log scale as large negative dB levels (because the loga‐

1. The dynamic range of a digitized sound is 6 dB/bit.
2. If the highest spectral peak in a signal is smaller than the digitizer’s maximum 

output level, the dynamic range between the peak and noise introduced by 
digitizing will be less than 6 dB/bit.  However, it can never be more than 6 dB/
bit.
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rithm of zero is negative infinity).  The noise floor allows Raven to ignore 
very small power values.

Finally, the noise floor can also be used to eliminate spectral sidelobes 
(which show up as gray fringes around strong signal components in spec‐
trograms).

If the noise floor is set too low, excessive noise will be displayed in the 
spectrogram or spectrogram slice along with the signal.  If it is set too 
high, portions of the signal will not be visible.  You may need to experi‐
ment with different clipping levels in order to find a value that produces a 
satisfactory display.

As an alternative to clipping, you can alter the look of a spectrogram with‐
out changing the underlying spectrogram data by altering the brightness 
and contrast of the view.  Note, though, that this method does not change 
the noise floor in the spectrogram data stored in memory.  If you are only 
using spectrograms for visual examination and display, then the distinc‐
tion between brightness/contrast and the noise floor of the spectrogram 
data is unimportant.  However, if you plan to do any quantitative analysis 
(e.g., correlations) using the spectrogram data, remember that the only 
way to change the noise floor is to recalculate the spectrogram, specifying 
a different Clipping Level in the spectrogram dialog box.

If you want to raise or lower the noise floor in a spectrogram (either in the 
display or in the data itself), you must recalculate the spectrogram with a 
higher or lower Clipping Level.

Figure 5.12 and Figure 5.13 show spectrograms and spectrogram slices 
that differ in Clipping Level as well as in brightness and contrast.  Note 
that if you want to have different clipping levels for your spectrogram and 
spectrogram slice views, you must unlink those views in their spectro‐
gram parameters.
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Figure 5.12

Figure 5.12.  Effect of clipping level on spectrograms.  The signal is 
part of a song of a Black-capped Vireo.  First row: no clipping level set, 
standard brightness (50) and contrast (50) settings, spectrogram 
smoothing enabled.  Second row: no clipping level set, brightness set to 
65, contrast set to 78, smoothing enabled. The underlying power values 
have not changed so all measurement values will be the same as those 
measured in the first row. Third row: clipping enabled, values below 60 
dB clipped to -Infinity dB, spectrogram smoothing enabled. Measure-
ment values will differ between this view and the first row. Fourth row: 
clipping enabled, values below 60 dB clipped to -Infinity dB, spectro-
gram smoothing disabled. Without smoothing, more of the clipped 
spectrogram is visible.  Fifth row: clipping enabled, values below 60 dB 
clipped to 0 dB, spectrogram smoothing enabled. Since values were 
only clipped to 0 dB, more of the clipped values are vislble than in the 
third row.
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Figure 5.13

Figure 5.13.  Effect of clipping level on spectrogram slices.  All three 
slices are on a single 256-point frame approximately 1.378 seconds 
into the Black-capped Vireo song shown in Figure 5.12.  The signal was 
digitized with 16-bit resolution, and thus has a dynamic range of 96 dB.  
The highest power values are near 90 dB, so there is little perceptible 
noise inserted by the digitization process.  First row: no clipping level 
set.  Second row: clipping level = 60 dB, with values clipped to 60 dB.  
Third row: clipping level = 60 dB, with values clipped to -Infinity dB.  
Notice the dropouts in the slice view.  For this reason, we recommend 
against clipping spectrogram slice views to -Infinity dB, but for analysis 
purposes, you may want to clip spectrograms to -Infinity dB.

Spectrum
averaging

The Averaging field allows you to specify the number of individual spec‐
tra over which Raven should average the power values to obtain the val‐
ues in each cell of the spectrogram. In most situations, Averaging should 
be left at its default value of one spectrum.

Higher Averaging values may provide more satisfactory spectrogram 
images when more than a few seconds of a signal are displayed. There are 
two reasons why averaged spectrograms may be preferable at certain time 
scales. First, if the time scale of a spectrogram view is such that the num‐
ber of spectra in the visible time span is much greater than the number of 
pixels in the time dimension of the sound window, then many spectra will 
not be displayed at all. Some acoustic events that span only a few spectra 
may not be visible (unless you zoom in to display a finer time scale) 
because the only spectra in which they appear fall between the pixels 
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shown in the display. By setting the Averaging field to a value greater than 
one spectrum, you can make visible short‐duration events that would oth‐
erwise be lost between pixels. Second, spectrum averaging smooths back‐
ground noise, which can result in a higher signal‐to‐noise ratio in the 
spectrogram image   (Figure 5.14). At finer time scales (i.e., greater magni‐
fication in the time dimension), however, spectrum averaging tends to 
blur signals (Figure 5.14). 

You can specify the amount of data to average in units of seconds or milli‐
seconds (rather than spectra), using the units drop‐down menu.

Figure 5.14.  Spectrum averaging example.

Figure 5.14.  Spectrum averaging can yield clearer spectrograms when 
the interval in view is long compared to the number of spectra in view. 
All four spectrograms of a nearby common yellowthroat and a distant 
yellow warbler were made with Window Type = Hann, Window Size = 
512 samples, Window Overlap = 50%. All four are linked by time posi-
tion. (a) and (c) Averaging = 1 spectrum. (b) and (d) Averaging = 4 
spectra. When viewing a longer time span (views (a) and (b)), the view  
that uses spectrum averaging provides a clearer image, especially of 
the faint signal from a distant bird. For the more magnified image ((c) 
and (d)), the view without averaging appears clearer.
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Apply and Auto-
apply

If you click the Apply button, Raven immediately calculates and displays 
the spectrogram, using the parameters currently displayed in the dialog, 
without closing the dialog. (Clicking OK closes the dialog before calculat‐
ing the spectrogram.)

If the Auto-apply checkbox is checked, Raven immediately recalculates 
and displays the spectrogram each time you change any parameter in the 
dialog, without you needing to click the Apply button. For parameters that 
you enter by typing in a field (e.g., Time grid spacing or window Overlap), 
the spectrogram is recalculated when you complete an entry by pressing 
the <Enter> or <Tab> key, or by clicking another field or control in the dia‐
log. 

Spectrogram
presets

You can save and retrieve sets of spectrogram parameters using com‐
mands on the Preset menu within the Configure Spectrogram dialog. A 
set of saved spectrogram parameters is called a spectrogram preset. To save 
a preset, choose Presets > Save As... . When the Save Spectrogram Param‐
eters dialog appears, enter a name for the preset, and click OK.

To retrieve a spectrogram preset, choose the name of the preset from the 
Preset menu. When you retrieve a preset, all of the spectrogram parame‐
ters in the Configure Spectrogram dialog are immediately set to the saved 
values. If you then change some parameters and want to revert to the 
saved values, click the Reset button or select the name of the preset from 
the Preset menu again. If you want to save changes you’ve made under 
the name of the last preset you loaded, choose Preset > Save “Preset-
Name”.

Spectrogram views

Significance of the
color (grayscale)

values

Spectrograms displayed by Raven have a logarithmic power (color) axis. 
That is, the color (by default, grayscale) values shown in the cells of an 
unsmoothed spectrogram represent the logarithm of the power at the cor‐
responding frequency for each spectrum in a spectrogram. Hence, the 
color value is proportional to the power expressed in decibels (relative to 
an arbitrary reference power).

The numeric values for relative power level associated with each point are 
displayed in decibels (dB) in the mouse measurement field at the bottom 

Spectrogram presets must be saved in the folder Presets/
Spectrogram Parameters/ within the Raven program 
folder. You can also create additional folders within the Spec-
trogram Parameters folder by clicking on the New Folder icon 
within the Save dialog. These folders will appear as sub-
menus in the Preset menu, with each submenu listing the 
presets in the corresponding folder.
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of the signal window. These decibel measurements are relative to an arbi‐
trary spectrogram bin reference value of 1.

Brightness and
contrast

The section on “Spectrogram brightness and contrast” in Chapter 3 (page 
60) provides a basic introduction to the operation of the spectrogram 
brightness and contrast controls. This section provides a more detailed 
explanation of how these controls work. The information in this section is 
not needed to use the controls effectively; it is provided for those who are 
interested in a quantitative explanation of how these controls affect the 
spectrogram image.

Each spectrogram has an associated floor value and ceiling value. Powers 
that are less than or equal to the floor value are displayed as the floor color; 
powers that are greater than or equal to the ceiling value are displayed as 
the ceiling color. In a default grayscale spectrogram, the floor and ceiling 
colors are white and black respectively. For power values between the 
floor and ceiling values, Raven interpolates between the floor and ceiling 
colors. Changing the brightness of a spectrogram changes the floor and 
ceiling values by the same amount in the same direction. If we plot color 
value as a function of power, changing the brightness has the effect of 
shifting the brightness‐vs.‐power function left or right, without changing 
its slope (Figure 5.15). Increasing the contrast shifts the floor and ceiling 
values toward each other, which increases the slope of the brightness‐vs.‐
power function, without shifting the center point of the function (Figure 
5.16).

Raven 1.3 does not display calibrated sound amplitude mea-
surements. In other words, the dB values given by Raven do 
not represent absolute sound levels. Raven’s amplitude mea-
surements can be used to obtain accurate relative measure-
ments within signals.
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Figure 5.15.  Brightness graph

Figure 5.15.  Relationship between color and power values in a default 
grayscale spectrogram for two different brightness settings. f1 and f2: 
power floor values for Brightness 1 and 2 respectively. c1 and c2: power 
ceiling values for Brightness 1 and 2 respectively. g1 and g2: color val-
ues associated with power P for Brightness 1 and 2 respectively. 
Increasing the brightness (arrow) increases the power floor and ceiling 
values by the same amount. The result is that the color associated with 
a given power P gets lighter.  
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Figure 5.16.  Contrast graph

Figure 5.16.  Relationship between color and power values in a default 
grayscale spectrogram for two different contrast settings. f1, f2, c1, and 
c2 defined as in Figure 5.15. Increasing the contrast (arrows) decreases 
the range of power values between white (floor) and black (ceiling).

When Raven initially displays a spectrogram, the floor and ceiling values 
are set to values that yield acceptable spectrogram displays with a wide 
range of signal amplitudes. The initial contrast and brightness settings are 
arbitrarily assigned values of 50%.

If you set contrast to 100%, the floor and ceiling values are set equal to 
each other, so that the spectrogram displays only two colors, which are the 
floor and ceiling colors (by default, white and black). In this case, adjust‐
ing the brightness moves the threshold between these two colors. 

Time alignment of
spectrogram data

Each individual spectrum in a spectrogram has a time associated with it, 
called the spectrum time. The spectrum time is the time halfway through 
the block of samples from which the spectrum was calculated (the spec‐
trum source data). In an unsmoothed spectrogram, Raven displays each 
individual spectrum in a spectrogram so that its horizontal midpoint is at 
the spectrum time. Thus, in a waveform and spectrogram linked to each 
other by time position and scale, the midpoint of each individual spec‐

In Raven 1.2, this provided acceptable spectrogram displays, 
but if you choose to use the new Raven 1.3 power spectrum 
computation, you may find that a brightness value of 33% 
might be more appropriate because the power levels are 
lower.
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trum is aligned with the midpoint of the corresponding source data (Fig‐
ure 5.17, Figure 5.18).

Figure 5.17.SPG align boxy 0% overlap

Figure 5.17.  Time alignment of individual spectra in a spectrogram 
made with window size = 10 samples, and time grid resolution = 10 
samples (overlap = 0%). The waveform and spectrogram are linked in 
time position and scale, and have been zoomed in to show individual 
samples. The colored overlays identify the correspondence between 
spectra and the samples from which they were calculated. Each spec-
trum is associated with the time at the midpoint of its corresponding 
data interval (dashed vertical lines). Compare with Figure 5.18.

If the window overlap is set to 0%, the left and right edges of each spec‐
trum are aligned with the start and end of the source data (Figure 5.17). 
However, if the window overlap is greater than 0%, the edges of individ‐
ual spectra can’t be aligned with the edges of the sample window, because 
the width of the displayed spectrum (i.e., the time grid resolution, or hop 
size) is smaller than the width of the source data (Figure 5.18).

Whenever a spectrogram’s time grid resolution is less than the size of the 
spectrum window (i.e., whenever window overlap is greater than 0%), 
there is a gap between the time of the first sample in the signal, and the left 
edge of the first spectrum in a spectrogram, where Raven displays the “no 
data” color (gray by default; Figure 5.18). This gap is often narrow enough 
to be unnoticeable or invisible unless you zoom in to a high magnification.
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Figure 5.18.  SPG align boxy 30% overlap

Figure 5.18.  Time alignment of individual spectra in a spectrogram 
made with window size = 10 samples, and time grid resolution = 7 sam-
ples (overlap = 30%). The colored overlays identify the correspondence 
between spectra and the samples from which they were calculated. 
Each spectrum is associated with the time at the midpoint of the corre-
sponding source data (dashed vertical lines). Note the gray area of no 
data prior to the beginning of the first spectrum. Compare with Figure 
5.17.

Smoothed vs.
unsmoothed

display

Raven can display spectrograms in either of two modes: smoothed (the 
default) or unsmoothed (Figure 5.19). 
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Figure 5.19.  Smoothed and unsmoothed spg.

Figure 5.19. Close-up view of portion of two spectrogram views of a 
signal digitized at a sample rate of 44.1 kHz. The upper view is 
smoothed (the default); the lower view is unsmoothed. For both views, 
window type = Hann, window size = 512 points, overlap = 50%.

To switch between smoothed and unsmoothed displays, click the check‐
box next to Smooth Spectrogram in the view’s contextual menu or in the 
View menu when the spectrogram view is active.

An unsmoothed view more accurately represents the actual data in the 
spectrogram. A smoothed spectrogram may provide a more visually satis‐
fying image. In an unsmoothed spectrogram, each actual data point on the 
spectrogram grid is represented by a rectangular gray box. The width and 
height of the boxes depend on the hop size and frequency grid spacing 
respectively (see “Time grid: Window Overlap and Hop Size” on page 106 
and “Frequency grid spacing and DFT size” on page 108). 

In an unsmoothed spectrogram, the horizontal center of each box is 
located at the time that is halfway through the set of samples from which 
that spectrum was made (see “Time alignment of spectrogram data” on 
page 118). The vertical center is located at the center frequency of the 
bandpass filter whose output power is represented by the darkness of the 
box. The size and visibility of the boxes on the screen depends on the size 
of the entire spectrogram on the screen, which in turn depends on the size 
of the sound window and the signal length (which affects the time dimen‐
sion only), and on the display scale (determined by the zoom controls). 
Figure 5.20 shows an unsmoothed spectrogram of the entire time and fre‐
quency range of a 1.8‐second signal and a portion of the spectrogram after 
a zoom; individual cells of the spectrogram are indistinguishable in the 
full‐scale view, but are clearly visible in the magnified portion.
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Figure 5.20. Boxy spg‐two scales

Figure 5.20.  Unsmoothed spectrogram views at two different magnifi-
cations. The signal is a song of a chestnut-sided warbler. Both views 
are made with a 512-sample Hann window and 50% overlap. The 
upper view shows the entire song; the lower view is zoomed to the 
selection. The individual spectrogram cells are clearly visible in the 
lower panel.

In a smoothed spectrogram, the color of each individual display pixel is 
determined by bilinear interpolation between the power values calculated 
at the grid points (i.e., the centers of the boxes shown in an unsmoothed 
spectrogram). Each time the spectrogram is resized, the color values for 
individual pixels are recalculated. Thus no matter how much you stretch a 
smoothed spectrogram, you will not see sharp‐edged boxes as you would 
with an unsmoothed spectrogram. In a smoothed spectrogram, the “no 
data” color is displayed before the time of the first spectrum, and after the 
time of the last spectrum because Raven cannot interpolate power values 
beyond these points.

Spectrogram smoothing is not a substitute for the finer spectrogram grid 
resolution obtained by increasing the window overlap and DFT size, how‐
ever. Both may make a spectrogram more esthetically pleasing, but only 
finer grid resolution will reveal some structural details of the signal that 
are invisible in a low‐resolution spectrogram (Figure 5.21). 
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Figure 5.21. Low‐res spg boxy/smooth vs hi‐res

Figure 5.21.  Difference between smoothed spectrogram calculated on 
low-resolution time grid and unsmoothed spectrogram calculated on a 
higher-resolution time grid. The signal is part of a song from a Cassin’s 
kingbird, digitized at 44.1 kHz. All three spectrograms use a 300-sam-
ple Hann window. (a) Unsmoothed spectrogram on default time grid. 
Time grid spacing = 3.4 mS = 150 samples (50% window overlap). (b) 
Same spectrogram parameters as (a), but with smoothed display. (c) 
Unsmoothed spectrogram with higher-resolution time grid. Time grid 
spacing = .68 mS = 30 samples (90% window overlap). The rapid peri-
odic frequency modulation is more clearly represented in (c) than in (a) 
or (b).

Spectrogram slice views

Time position of a
spectrogram slice

view

A spectrogram slice view, like a spectrogram view, has a time axis and a 
time position. Unlike a spectrogram or waveform view, however, the time 
axis of a spectrogram slice view is not displayed. In order to change the 
time position of a spectrogram slice view, its time position must be linked 
to a waveform or spectrogram view (see “Linking and unlinking views” in 
Chapter 3, page 53). You can then change the time position of the spectro‐
gram slice view by moving the time position marker of the linked wave‐
form or spectrogram view.

If the spectrogram slice view’s time position is before the spectrum time of 
its first spectrum (see “Time alignment of spectrogram data” on page 118), 
Raven displays a message in the view pane indicating that there are no 
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spectrogram data available at the current time position (Figure 5.22). Since 
Raven by default sets the time position of a view to the start of the sound 
when a sound file is first opened, this message is often shown when a 
spectrogram slice view is first displayed. To see valid data in the slice 
view, simply move the time position marker in any linked waveform or 
spectrogram view.

Figure 5.22.  No slice data

Figure 5.22.  Three views all linked by time position. No data are avail-
able for display in a spectrogram slice view when the time position is at 
the very start of the signal, before the time of the first spectrum in the 
underlying spectrogram. 

Significance of the
spectrum values

The power values shown at each frequency in a spectrogram slice view 
displayed are expressed in decibels relative to an arbitrary power value of 
1. The numeric values for frequency and relative power level at the fre‐
quency where the mouse pointer is located are displayed in hertz (Hz) and 
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decibels (dB) in the mouse measurement field at the bottom of the signal 
window.

Selection spectrum views

Raven updates selection spectrum views whenever the active selection 
changes. If there is no active selection, or if the active selection is shorter 
than the window size specified in the current view parameters, selection 
spectrum views display a text message indicating why no spectrum is 
shown.  

By default, selection spectra are shown in red, to distinguish them from 
spectrogram slice views (shown in blue by default). You can specify a dif‐
ferent color for selection spectrum views by editing the color scheme as 
discussed in “Editing color schemes” in Chapter 3 (page 61).

Significance of the
spectrum values

The power values shown at each frequency in a selection spectrum view 
displayed are expressed in decibels relative to an arbitrary power value of 
1. The numeric values for frequency and relative power level at the fre‐
quency where the mouse pointer is located are displayed in hertz (Hz) and 
decibels (dB) in the mouse measurement field at the bottom of the signal 
window.

Changing parameters for an existing spectrographic view

To change any of the parameters of a spectrogram, spectrogram slice, or 
selection spectrum view, choose Configure View... from the view’s contex‐
tual menu or from the View menu when the view is active. You can then 
enter new parameters into the dialog box that appears, then click Apply or 
OK.

Raven 1.3 does not display calibrated sound amplitude mea-
surements. In other words, the dB values given by Raven do 
not represent absolute sound levels. Raven’s amplitude mea-
surements can be used to obtain accurate relative measure-
ments within signals.
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Chapter 6 Selections:  
Measurements, Annotations, & Editing

About this Chapter

This chapter contains information on making selections, measurements, 
and editing within sound files in Raven.  In particular, you’ll learn more 
about:

• selection basics such as creating, committing, deactivating, and clearing.
• editing sounds, using filters and amplification.
• selection tables.
• working with selections.
• measurements.
• measurement formats, precision, and presets.
• exporting samples from various views to text files.
• annotations.

Selection Basics

About selections A selection is a specified portion of a signal with a start time and duration, 
and a lower and upper frequency. You can define a selection by clicking 
and dragging the mouse across part of a view. (Other ways of defining and 
modifying selections are discussed below.) Selections are shown in views 
by colored rectangles. In earlier chapters of this manual you have seen 
how to select part of a waveform or spectrogram and play or zoom to that 
selection. Selections are also used to identify parts of signals that you want 
to measure, edit, or save. 

Selections can either be range selections or point selections. A range selection 
identifies a continuous range of times and/or frequencies. A point selec‐
tion identifies a single point in time, and optionally a single frequency. 
You can define range or point selections in any type of view. 

Although you initially define a selection in a particular view, 
selections are associated with a sound, not with any particu-
lar view, and are displayed in all views.
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Creating and
modifying range

selections

There are two ways to create a range selection. One way, which you’ve 
already seen, is to click and drag the mouse pointer across the portion of a 
view that you want to select. The other way to create a range selection is to 
click once at one edge or corner of the selection, and then shift‐click at the 
opposite edge or corner. In a waveform, all of the time between the initial 
click and the shift‐click will be selected. In a spectrogram, a rectangular 
region will be selected, with the locations of  the click and shift‐click defin‐
ing diagonally opposite corners. 

Shift‐clicking provides a way of selecting a section that is too long to be 
displayed in the window at the current scale. Click once at the beginning 
of the section, and then use the scroll thumb to move the view so that the 
end of the desired section is visible, and shift‐click there. The entire section 
will be selected, even though one end of the selection is beyond the edge 
of the window.

When you first create a selection, the selection is displayed with a dashed 
border that is red by default. (You can change the color used to draw new 
selections, as described in “Editing color schemes” in Chapter 3 (page 61).) 
By default, a selection label appears near the top left corner of the selection, 
displaying the selection ID number. 

Selection control points
As soon as you release the mouse button, selection control points appear at 
the edges and at the center of the selection. In spectrogram views, selec‐
tion control points also appear at the corners of a selection. Selection con‐
trol points are small squares that you can grab and move with the mouse 
to adjust the boundaries of the selection or move the selection (Figure 6.1). 
When you move the mouse pointer over a selection control point, the 
mouse pointer changes to an icon indicating the directions that you can 
move that control point. At any given time, one control point may be 
active. The active control point is shown as a solid square; inactive control 
points are shown as open squares. For example, the bottom right control 
point in Figure 6.1 is active; the others are inactive. The active control 
point can be moved using the arrow keys on the keyboard. To activate a 
selection control point, click on it. Once one of a selection’s control points 
is active, you can activate successive control points for that selection by 
repeatedly pressing the <Tab> key.

Whenever the mouse is over a view containing an active selection, one of 
the selection control points, called the extender point, will be displayed at a 
slightly larger size than the others. The extender point is always the closest 
control point to the current position of the mouse pointer. For example, in 
Figure 6.1, the upper right corner control point is the extender point. You 
can move the extender point to a new location in a view by shift‐clicking at 
that location.
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Figure 6.1. Single selection, active, uncommitted

Figure 6.1.  An active, uncommitted range selection. The bottom right 
control point is active. The top right control point is the extender point. 

Committed vs. uncommitted selections
When you first create a selection, it is uncommitted. An uncommitted selec‐
tion is temporary— it disappears as soon as you click somewhere else in 
one of the sound window’s views to create a new selection. Thus there can 
only be one uncommitted selection in a sound window at any one time. To 
commit a selection, press the <Enter> key when any one of the selection’s 
control points is active. Once a selection is committed, it will persist in the 
signal until you explicitly clear it. When you commit a selection, its border 
changes from a dashed to a solid line. 

The active selection
When you first create a selection, it is active. After a selection has been 
committed, it becomes inactive when you define a new selection (which 
then becomes active). Thus, only one selection (at most) can be the active 
selection. Active and inactive selections are highlighted in different colors. 
By default, the active selection is highlighted in red; inactive selections are 
highlighted in cyan (Figure 6.2). Only the active selection has control 
points. Certain operations— such as playback, zoom, and editing— apply 
only to the active selection. To activate an inactive selection, point to the 
selection and choose Selection N > Activate (where N is the selection num‐
ber) from its contextual menu.
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Figure 6.2.  Multiple selections on spg.

Figure 6.2.  A spectrogram showing multiple selections. The committed 
active selection is outlined in red; inactive selections are outlined in 
cyan.

Point selections A point selection is created by clicking (without dragging the mouse) in a 
view. A point selection is always shown in a waveform view as a colored 
vertical line. The appearance of a point selection in a spectrogram or spec‐
trogram slice view depends on which type of view was clicked to create 
the selection. If a point selection is created by clicking on a waveform, it is 
shown on spectrogram views as a colored vertical line (Figure 6.3). This is 
because a point selection created in a waveform includes all frequencies by 
default. In a spectrogram slice view, such a selection would appear as a 
highlighted rectangle covering the entire spectrum that is visible only 
when the view’s time position is at the time of the selection.

If a point selection is created by clicking on a spectrogram or spectrogram 
slice view, it’s shown as a colored ‘+’ symbol in spectrogram views, and as 
a vertical line in spectrogram slice and waveform views (Figure 6.3).

A point selection is visible in a spectrogram slice view only if 
the view is positioned at the time of the selection.
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Figure 6.3.  Point selections.

Figure 6.3.  Point selections (in green) as they appear in different view 
types. Time positions of all three views are linked to each other. Selec-
tion 1 was created by clicking in the waveform. Selection 2 was created 
by clicking in the spectrogram. Selections 1 and 2 are not visible in the 
spectrogram slice view because the time position is not at the time of 
either selection. Selection 3 was made by clicking in the spectrogram 
slice view. In the waveform, selection 3 is hidden behind the time posi-
tion marker.

Deactivating and
clearing selections

To deactivate the active selection, choose Selection N > Deactivate from 
the selection’s contextual menu, or activate another selection. To remove 
the active selection, choose Active Selection > Clear from the selection’s 
contextual menu or press the Clear Active Selection button on the View 
toolbar. To remove an inactive selection, choose Selection N > Clear from 
the selection’s contextual menu. You can also remove all selections by 
choosing Clear All Selections either from the View menu, from the contex‐
tual menu for any selection, or by pressing the Clear All Selections button 
on the View toolbar.

To clear a selection means to remove the selection, leaving 
the data in it untouched. To delete a selection means to 
delete the data identified by that selection; in the process the 
selection itself is cleared.
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Renumbering
selections

When you initially create selections, Raven assigns selection ID number in 
the order that you create the selections, beginning at 1. To renumber selec‐
tions beginning at 1, in the order determined by the current sort order of 
the selection table, choose Renumber Selections from the selection table’s 
contextual menu. 

Editing a sound

The clipboard can hold only one item at a time; whenever you Cut or Copy, 
the data that go into the clipboard replace what was there before. You can 
delete the data in the active selection either by choosing  Edit > Delete, by 
pressing the Delete button, by pressing <Ctrl-Delete> (Windows) or 
<Command-Delete> (Mac OS), or by pressing the Delete key on your key‐
board when a selection control point is active.

Cut, Copy, Paste, and Delete operations apply only to the time dimension 
of a sound window. If you select a region for one of these operations in a 
spectrogram, the operation applies across all frequencies in the signal for 
the duration of the selection, irrespective of the frequency limits of the 
selection.

When you modify a sound, Raven adds an asterisk (*) to the beginning of 
the title of the sound window to show that you’ve edited the sound. If the 
file is restricted to read‐only access, the title bar tells you that, too.

Undoing changes The most recent change to a sound window can be undone by choosing 
Edit > Undo  or by typing <Ctrl-Z> (Windows) or <Command-Z> (Mac OS). 
By repeatedly using the Undo command, you can undo multiple changes, 
from most to least recent. You can redo a change you’ve undone by choos‐
ing Edit > Redo or by typing <Ctrl-shift-Z> (Windows) or <Command-shift-
Z> (Mac OS). You can redo, one at a time, as many changes as you’ve 
undone. By default, you can undo (and then redo) up to five changes. You 
can change this number by altering the user preferences (see “About 
Raven preferences” in Chapter 11 (page 252) for more information).

Renumbering is useful if the order in which selections were 
created is not the order in which they occur in the sound, or if 
some selections were cleared, creating gaps in the number-
ing sequence. Sort the table by Begin Time, then renumber to 
create an uninterrupted series of selection IDs in time order.

In Raven 1.3, if you perform Cut, Paste, or Delete operations 
in a sound window that contains selections at times later than 
the time where the editing operation is performed, those 
selections will no longer refer to the same data as they did 
before the editing operation.
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Filtering and
amplifying sounds

Raven enables you to selectively filter out all energy in particular fre‐
quency bands of a selection or an entire sound window. You can also 
amplify all or part of a sound by any specified factor, including factors less 
than 1. Amplifying by a factor less than 1 attenuates the sound.

Filtering Raven allows you to filter out or filter around a selected frequency band in a 
sound. When you filter out a frequency band, frequency components in 
that band are removed from the signal. When you filter around a fre‐
quency band, frequency components outside of that band are removed, 
leaving only the frequencies in the selected band. The filtering operation 
can be performed on the entire signal or on a time interval that you select.

To filter out or around a particular frequency band, make a spectrogram of 
the sound, and then use the mouse to select the frequency band to be fil‐
tered. To filter the selected frequency band over just the selected time 
interval, choose Edit > Filter > Around Active Selection or Edit > FIlter > 
Out Active Selection. To filter the selected frequency band over the entire 
length of the sound, choose Edit > Filter > Around All or Edit > FIlter > Out 
All. If there is no active selection, the Edit > Filter menu is not available.

Defining your own
filters

Raven allows you to save named presets for bandpass or bandstop filters 
covering a specified frequency band.  To define a new filter, choose Edit > 
Filter > Active Selection With > New Filter... or Edit > Filter > All With > 
New Filter...  In the ensuing dialog box, you can specify Bandpass or Band‐
stop and the filter limits, and optionally save the filter settings as a preset.  
To apply a saved filter preset to the active selection or to the entire sound, 
choose Edit > Filter > Active Selection With > filterPresetName or Edit > 
Filter > All With > filterPresetName. If you choose to create your own filter, 
you can enter your own frequency band information in the dialog box that 
appears (see Figure 6.4). 
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Figure 6.4 Create filter

Figure 6.4. The Create New Filter dialog box. In this case, we chose to 
define a filter to work on an active selection.

Amplifying To amplify all or part of a sound, choose Edit > Amplify... . The Amplify 
Sound dialog box that appears (Figure 6.5) lets you choose whether to 
amplify the entire sound or just the active selection. You can also choose 
between two methods of amplification— you can either specify a factor by 
which Raven will multiply each sample in the sound, or you can specify 
that Raven should multiply the entire sound or the active selection by 
whatever factor necessary to make the RMS amplitude of the active selec‐
tion equal to a specified value.

To reduce the amplitude of a sound, amplify by a factor 
greater than 0 and less than 1. Amplifying by 0 will silence the 
chosen portion of a sound.
134 Raven Pro 1.3 User’s Manual



Chapter 6:  Selection, Measurements, & Editing
Figure 6.5. Amplify dialog

Figure 6.5.  The Amplify Sound dialog.

Selection Tables

The Selection Table At the bottom of each sound window is a selection table, which by default is 
collapsed so that it’s not visible. To expand the selection table so that it’s 
visible, click on the upward‐pointing Expand Selection Table button at the 
left (Windows) or right (Mac OS) end of the textured separator bar along 
the bottom edge of the sound window. If you click on the same button 
again, the selection table will expand to occupy the entire window, hiding 
the window’s views. Clicking on the downward‐pointing Collapse Selec-
tion Table button reduces the size of the selection table. You can also drag 
the textured separator bar up or down to open or resize the selection table.

By default, the selection table displays one row for each selection in each 
view of the sound (Figure 6.6). Raven assigns a sequential selection ID, 
beginning at 1, to each selection that is defined for a sound window. Each 
selection’s ID is shown in the first column of the selection table, along with 
a colored square that indicates whether or not the selection is the active 
selection (by default, red for the active selection, cyan for all others). The 
second column, labeled “View”, displays an icon to indicate whether the 
row refers to a waveform, spectrogram, spectrogram slice, or selection 
spectrum view. (The icons for the view types are the same ones used on 
the New View buttons in the view toolbar, Figure 2.10, page 31.) The num‐
ber next to the icon indicates which view of a particular type the entry 
refers to, for cases where more than one view of a given type exists.

The remaining columns in each row display measurements for the given 
selection and view. 
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Figure 6.6. Spg and selection table.

Figure 6.6.  A sound window containing one waveform and one spec-
trogram view, with multiple selections, and the corresponding selection 
table..

Using selection
tables

Unless otherwise specified, initial selections made within a sound window 
will be part of a default selection table. New selection table(s) can be cre‐
ated by selecting File > New > Selection Table from the menu. Running a 
detector on the data will also create a new selection table (see “Displaying 
detector information” in Chapter 10 (page 218) for more information).

Also from the File menu, you can choose to close the active selection table 
(File > Close Selection Table) or save the table (File > Save Selection Table 
or File > Save Selection Table As...)

Selection tables appear in tabbed format, and each table has a context 
menu affiliated with it. To access the context menu, simply position the 

Each sound window may have multiple selection tables. 
They will be tabbed across the bottom of the sound window, 
and each table operates independently and can be edited as 
such.
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mouse cursor over the table’s tab and right‐click. You can rename, remove, 
change the color of, or save the table. You can also open a new table or 
merge tables.

There is a context menu for the tables’ contents as well. Simply right‐click 
while the mouse is over the table and the menu will appear. The menu has 
options for you to edit columns and rows, edit cell contents, and even edit 
selections that appear in the table.

Visibility of view and
channel entries

The selection table displays one row for each visible view of each visible 
channel of the signal (Figure 6.7). To hide entries for a view or a channel in 
the table, turn off display of that view or channel in the side panel’s Layout 
tab.

Selections in each table can be different colors and can be shown or hidden 
independently. The Draw checkbox in the upper right‐hand corner of the 
area controls whether selections in that particular selection table are 
drawn or not drawn in the sound window’s view(s). Also, the arrows next 
to the Draw checkbox provide an easy way to scroll through the selections 
contained in each table (see Figure 6.7).

Figure 6.7. Selection Table, 2 views

Figure 6.7.  A signal window showing three selections for two views in 
one selection table (Table 1). Note also the Draw checkbox as well as 
the selection scroll arrows in the upper-right corner of the table. 
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Sort order of view
and channel entries

By default, Raven sorts the entries in a selection table first by selection 
number, then by view, and finally by channel. This default sort order is 
illustrated for a single‐channel signal in Figure 6.7. You can choose a dif‐
ferent sort order (e.g., by View, Channel, Selection) from the Sort Rows By 
menu in the selection table’s contextual menu. Figure 6.8 shows selections 
sorted by view, then by selection for a single‐channel signal.

Figure 6.8. Selection table sort by view, selection

Figure 6.8.  The same selections shown in Figure 6.7, sorted by view, 
then by selection.  

You can also choose to have the selection table sorted in ascending order 
of any one of the displayed measurements by clicking on the column 
header for that measurement. To sort in descending order, shift‐click on 
the header.

Saving the
selection table to a

text file

Choose File > Save Selection Table As... to save the measurements that 
are visible in the selection table as a tab‐delimited text file, for easy import 
into statistical, spreadsheet, or other programs. You can also retrieve selec‐
tion information later within Raven, as described in the following section.

If the selection table contains any unsaved changes, Raven displays an 
asterisk (*) at the left end of the selection table’s title bar.

Retrieving
selections from file

Once a selection file has been saved, you can retrieve the selections by 
choosing File > Open Selections... .

When Raven retrieves selections from a file, it uses the Begin Time, End 
Time, Low Frequency, and High Frequency values read from the file 

If you try to save a selection table file that does not include 
values for Begin Time, End Time, Low Frequency, and 
High Frequency, Raven will warn you that you won’t be 
able to retrieve the selections later, and will ask if you want to 
proceed.
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to create new selections in the active signal. These four measurements are 
collectively known as the selection bounds. Measurement values other than 
the selection bounds saved in the file are ignored. Raven computes the val‐
ues of whatever measurements are currently displayed in the selection 
table based on the retrieved selection bounds. 

The file from which selection bounds are retrieved need not have been cre‐
ated by saving measurements in Raven. Any tab‐delimited text file can be 
used for selection retrieval, as long as it has the right format (see below). 
This means that selection files can be created manually or by an auto‐
mated process, such as a signal detection or classification program that is 
not part of Raven.

If one or more selections already exist in the active sound window when 
you retrieve selections from a file, Raven will ask you to choose whether to 
(a) discard the old selections before retrieving, (b) merge the existing selec‐
tions and the retrieved selections, (c) add a new table to store the new 
selections, or (d) cancel the retrieval. If you choose to merge selections, the 
retrieved selections will be assigned new selection numbers if the saved 
numbers conflict with existing ones.

Format of selection
files

In order for Raven to retrieve selections from a file, the first line of the file 
must be a header row that contains column headings for Begin Time, 
End Time, Low Frequency, and High Frequency, separated from 
each other by the <tab> character. These columns can appear in the file in 
any order. If the file also contains a Selection column, Raven will assign 
the selection numbers saved in that column; otherwise, the imported selec‐
tions are numbered consecutively, starting at 1. Column headers for other 
measurements may be present or absent; Raven ignores values in other 
columns.

Subsequent lines in the file must contain valid entries for each of the col‐
umns identified in the header row, separated from each other by <tab> 
characters.

If any of the selection bounds given in a selection file is outside the limits 
of the active signal (e.g., a time beyond the end of the signal, or a frequency 
greater than the Nyquist value), Raven will alert you to this and ask 
whether to abort importing selections. If you choose to continue, selections 
with bounds outside of the signal limits are ignored.

Working with selections

Activating a
selection from the

selection table

To activate a selection, click on any one of its rows in the selection table, or 
choose Selection N > Activate from the row’s contextual menu. If the 
newly activated selection is not visible in the active view, the view’s time 
position is moved so that the selection appears in the center of the view. In 
paged windows (see “Paging” in Chapter 7 (page 157)), if the selection is 
not presently in memory, the necessary pages of the sound will automati‐
cally be loaded, and the selection activated. You can activate successive 
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selections in the table (according to the current sort order) using either the 
Activate Next Selection (down) and Activate Previous Selection (up) 
arrow buttons in the table’s title bar or the up and down arrow keys. 

Finding the active
selection

If the active selection is not visible in the active view or in the selection 
table, choosing Active Selection N > Find from the View menu or the con‐
textual menu for the view or the selection table will cause the active view 
and the selection table to scroll to the active selection. 

Modifying selection
bounds

There are three ways to modify the bounds (i.e., Begin Time, End Time, 
Low Frequency, and High Frequency) of existing selections. 

Moving selection control points
When a selection is active, you can modify its selection bounds by manip‐
ulating its selection control points in any view. Selection control points can 
be moved either by dragging with the mouse, or using the arrow keys on 
the keyboard. In order to move a control point with the arrow keys, you 
must first activate the control point by clicking on it. You can activate dif‐
ferent control points in succession by repeatedly pressing the <Tab> key 
when any control point is active. 

Editing in the selection table
You can change the Begin Time, End Time, Delta Time, Low Frequency, 
High Frequency, and Delta Frequency values for a selection by editing the 
value directly in the selection table. Any change that you make to one of 
these fields takes effect when you press <Enter>, <Tab>, or any of the 
arrow keys. If you change Delta Time or Delta Frequency field, Raven 
keeps the Start Time and Low Frequency fields constant, and adjusts the 
End Time or High Frequency as necessary.

Using the Selection tab in the side panel
The Selection tab in the side panel displays the Begin Time, End Time, 
Delta Time, Low Frequency, High Frequency, and Delta Frequency for the 
active selection (Figure 6.9). All six of these fields are editable, so you can 
adjust the selection bounds by typing values into these fields. Any change 
that you make to one of these fields takes effect when you press <Enter> or 
<Tab>, or when you click anywhere outside of the field that you’ve 
changed. If you change Delta Time or Delta Frequency field, Raven keeps 
the Start Time and Low Frequency fields constant, and adjusts the End 
Time or High Frequency as necessary.
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Figure 6.9. Selection side panel

Figure 6.9.  The Selection tab in the side panel. This example is from a 
four-channel sound file.

Modifying selection
channels

For multi‐channel signals, the Selection tab also displays a list of the chan‐
nels in the signal (Figure 6.9), with checkboxes indicating the channels in 
which the active selection is defined. To change the channels in which the 
active selection is defined, check or uncheck channels as needed.

Selection tables in
paged sound

windows

Paged sound windows provide a mechanism for working with sounds 
that are too large to fit in the memory available to Raven. In a paged win‐
dow, only part of the entire sound, called a page, is in memory at any given 
moment. Paged sound windows are discussed in detail in “Paging” in 
Chapter 7 (page 157). The selection table in a paged sound window dis‐
plays all of the selections in the signal irrespective of whether the selec‐
tions are presently in memory, with their associated measurements and 
annotations. If you activate a selection in the table for which the audio 
data are not in memory, the page centered around the selection is loaded 
(replacing the current page), and the active view is centered around the 
selection.

Saving the active
selection

To save the audio data in the active selection to a separate file, choose File 
> Save Active Selection As... or use the Save Active Selection button in 
the control toolbar.
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Saving all
selections

To save the audio data in all selections to a series of separate sound files, 
choose File > Save All Selections In Current Table As... or use the Save All 
Selections button in the control toolbar. Raven will display the Save All 
Selections dialog box, which allows you to specify a file format and a nam‐
ing scheme for the files to be saved.

Note that when you save the audio data in all selections, Raven will also 
create a list file, which is a text file listing all of the selections’ file names.  
This list file can be used to open all of the selections at once in a file 
sequence.  You can specify the list file’s name in the File Names tab of the 
Save All Selections dialog.  The File Names and File Format tabs in this 
dialog work in the same way as those used in the New Recorder dialog.  
For more information, see “Recording to a file sequence” in Chapter 4 
(page 82).

Copying selected
rows from the

selection table

You can copy selected rows from a window’s selection table, and paste the 
measurements into another program, such as a spreadsheet, word pro‐
cessing, or statistics program. 

To select a single row for copying, click anywhere in the row. To select a 
range of rows, click on the first (or last) row you want, then shift‐click on 
the last (or first) row you want. To select multiple rows that are not adja‐
cent to each other, hold down the <Ctrl> (Windows) or <Command> (Mac 
OS) key while clicking on additional rows after selecting the first row. 
Rows that are selected are highlighted in color.

To copy the selected rows, choose Copy Selected Rows from the selection 
table’s contextual menu, or press <Ctrl-Shift-C> (Windows) or <Command-
Shift-C> (Mac OS).

Clearing selections To clear a selection means to remove the selection information, without 
modifying the audio data contained in the selection. In contrast, to delete a 
selection means to delete the audio data contained in the selection, as well 
as the selection information.

To clear the active selection, do one of the following:
• Choose View > Active Selection N > Clear.
• In any view, Choose Active Selection N > Clear from the selection’s con‐
text menu.

• In the selection table, Choose Clear Selection N from the context menu 
for any of the selection’s rows.

• .Press the Clear Active Selection button in the control toolbar.

To clear a single inactive selection, do one of the following:
• In any view, Choose Selection N > Clear from the selection’s context 
menu.

• In the selection table, Choose Clear Selection N from the context menu 
for any of the selection’s rows.
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To clear multiple selections at once, highlight rows from those selections 
in the selection table, then choose Clear Selections from the context menu 
for any of the highlighted rows. To highlight a series of contiguous rows, 
click on the row at one end of the series (i.e., the first or last row of the 
series), then shift‐click on the row at the other end of the series. To high‐
light multiple non‐contiguous rows, click on the first row to be high‐
lighted, then control‐click on other rows.

To clear all selections in a signal choose Clear All Selections from the 
View menu, from the contextual menu for any view or selection, from any 
row in the selection table, or by pressing the Clear All Selections button in 
the control toolbar.

Creating duplicate
selections at

different times

To create a selection identical to the active selection, but located at a differ‐
ent time, first choose View > Active Selection N > Copy Bounds. Then 
position the mouse pointer at the point in time where you want the new 
selection to be centered, right‐click (Windows) or Ctrl‐click (Mac OS) to 
and choose Paste Selection Bounds from the contextual menu. 

Cloning selections To create a duplicate selection that is superimposed upon the active selec‐
tion choose View > Active Selection N > Clone Bounds. The new selection 
will be activated and displayed on top of the previously active selection. 
You can then manipulate the new selection via its control points. 

Using cloning to segment a sound
You can use cloning to segment a sound into a series of contiguous selec‐
tions by the following procedure: 

1. Create the first selection in a series, either in a waveform or spectro‐
gram view. 

2. Clone the selection as described above. 
3. Drag the new selection’s left edge to the right, past the selection’s right 

edge to the end time of the second selection in the series. The edge that 
initially defined the end of the selection now defines its start, which is 
at the same time as the end of the first selection. The edge that origi‐
nally defined the start now defines its end. 

4. Clone the second selection, and then repeat step 3 as needed. 

Measurements

Choosing
measurements to

display

By default, Raven displays four measurements in the selection table: Begin 
Time, End Time, Low Frequency, and High Frequency. These values, col‐
lectively called the selection bounds, define the edges of a selection in a 
spectrogram view. However, you can choose to have Raven display any 
combination of measurements from a large repertoire. Choosing Choose 
Measurements from the View menu or from the selection table’s contex‐
tual menu displays the Measurement Chooser dialog box (Figure 
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6.10).The left list shows the measurements that are currently displayed in 
the selection table. The right list shows all of the measurements that are 
available in Raven. To add a measurement, select the name of the mea‐
surement in the right list and then click the left‐pointing arrow between 
the two lists to add it to the left list. To remove a measurement, select its 
name in the left list and then click the right‐pointing arrow. Shift‐click to 
select multiple adjacent measurements in either list; control‐click to select 
multiple non‐adjacent measurements. When you’ve finished configuring 
the set of measurements you want, click OK.

Figure 6.10.  Choose Msmts dialog.

Figure 6.10.  The Measurement Chooser dialog box.

Measurements
based on

spectrogram values

In Raven, Power Spectral Density is computed by:

1. defining the signal in the time domain by selecting it
2. taking a Fourier transform to define the signal in the frequency domain
3. and squaring the magnitude of each resulting Fourier coefficient.

The resulting values are used to create the columns of gray‐scale or color 
values of the pixels that make up Raven’s spectrogram view. The following 
measurements all make use of power spectral density, or spectrogram, val‐
ues.

The order in which measurement columns are displayed in 
the selection table is determined by the order in which they 
appear in the list of Displayed Measurement in the Measure-
ment Chooser.
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Average Power
(spectrogram, spectrogram slice, selection spectrum)

The value of the spectrogram’s power spectral density, as it appears in 
each pixel, or bin, of the spectrogram, averaged over the selection (that is, 
the frequency‐time rectangle that forms a selection in Raven). The values 
of the spectrogram’s power spectral density are summed, and the result is 
then divided by the number of time‐frequency bins in the selection.

In the spectrogram slice view, Average Power is the value of the power 
spectrum (the power spectral density of a single column of spectrogram 
values) averaged over the frequency extent of the selection. The values of 
the power spectrum are summed between the lower and upper frequency 
bounds of the selection, and the result is divided by the number of fre‐
quency bins in the selection. Units: dB.

Delta Power
(selection spectrum)

The difference between the value of the power spectrum (power spectral 
density, in power per unit frequency) at the upper and lower frequency 
limits of the selection; computed as the value of the power spectrum at the 
upper frequency limit minus the value of the power spectrum at the lower 
frequency limit. Units: dB.

Energy
(spectrogram, spectrogram slice, selection spectrum)

The total energy within the selection bounds.

For a spectrogram, the energy is calculated as

Formula 6.1

where f1 and f2 are the lower and upper frequency limits of the selection, 
t1 and t2 are the beginning and ending frame numbers of the selection, W0 
is the power dB reference value, St,f is the spectrogram poewr spectral 
density in frame t at frequency f (in dB), and Δf is the frequency bin size 
(which is equal to the sampling rate divided by the DFT size). In Raven, 
the reference power W0 is always equal to unity.

For a spectrum, energy is calculated as

W0 10
St f, 10⁄( )
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Formula 6.2

where f1 and f2 are the lower and upper frequency limits of the selection, 
and Sf is the value of the power spectrum (power spectral density) at fre‐
quency f, in dB. Units: dB.

Max Frequency, Peak Frequency
(spectrogram, spectrogram slice)

The frequency at which Max Power, Peak Power occurs within the selec‐
tion. If Max Power, Peak Power occurs at more than one time and/or fre‐
quency, the lowest frequency at Max Time at which Max Power, Peak 
Power occurs. Units: Hz.

Max Power, Peak Power
(spectrogram, spectrogram slice)

The maximum power in the selection. In a grayscale spectrogram, the 
maximum power in a selection is the power at the darkest point in the 
selection. Units: dB re 1 dimensionless sample unit.

Robust signal
measurements

The following eight measurements are considered robust signal measure‐
ments.  They should not vary much based on the exact bounds of the selec‐
tion that a user or detector creates.  Unlike the selection‐based 
measurements, which rely entirely on the time and frequency endpoints of 
the selection, these measurements take into account the energy that is 
stored in the selection; so small changes in the borders of the selection 
rectangle should have little effect on the computed measurement values.  
For an in‐depth description of the robustness of these measurements, and 
more detail regarding the research behind them, see http://www.birds.cor‐
nell.edu/brp/research/algorithm/automated‐and‐robust‐measurement‐of‐
signal‐features/.

Center Frequency
(spectrogram, spectrogram slice, selection spectrum)

The frequency that divides the selection into two frequency intervals of 
equal energy. For the spectrogram view, the Center Frequency fc is the 
smallest discrete frequency within the selection which satisfies the ine‐
quality

Formula 6.3

W0 10
Sf 10⁄( )

⋅⎝ ⎠
⎛ ⎞

f f1=

f2

∑
⎝ ⎠
⎜ ⎟
⎜ ⎟
⎛ ⎞

Δf

St f,
t t1=

t2

∑
f f1=

fc

∑ St f,
t t1=

t2

∑
f fc 1+=

f2

∑≥
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where St,f is the value of the spectrogram power spectral density at dis‐
crete time t and discrete frequency f.  It can also be stated that the Center 
Frequency is the smallest discrete frequency in which the left side of the 
formula exceeds 50% of the total energy in the selection.

For the spectrogram slice view, the procedure is the same except that the 
summation over time is not necessary since selections in the slice view 
occupy only one time bin. Units: Hz.

1st Quartile Frequency
(spectrogram, spectrogram slice, selection spectrum)

The frequency that divides the selection into two frequency intervals con‐
taining 25% and 75% of the energy in the selection.  The computation of 
this measurement is similar to that of Center Frequency, except that the 
summed energy has to exceed 25% of the total energy instead of 50%.

For the spectrogram slice view, the procedure is the same except that the 
summation over time is not necessary since selections in the slice view 
occupy only one time bin.  Units: Hz.

3rd Quartile Frequency
(spectrogram, spectrogram slice, selection spectrum)

The frequency that divides the selection into two frequency intervals con‐
taining 75% and 25% of the energy in the selection.  The computation of 
this measurement is similar to that of Center Frequency, except that the 
summed energy has to exceed 75% of the total energy instead of 50%.

For the spectrogram slice view, the procedure is the same except that the 
summation over time is not necessary since selections in the slice view 
occupy only one time bin.  Units: Hz.

IQR (Inter-quartile Range) Bandwidth
(spectrogram, spectrogram slice, selection spectrum)

The difference between the 1st and 3rd Quartile Frequencies.

Units: Hz.

Center Time
(spectrogram, spectrogram slice, selection spectrum)

The point in time at which the selection is divided into two time intervals 
of equal energy. For the spectrogram view, the Center Time tc is the small‐
est discrete time within the selection which satisfies the inequality

Formula 6.4  St f,
t t1=

tc

∑
f f1=

f2

∑ St f,
t tc 1+=

t2

∑
f f1=

f2

∑≥
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where St,f is the value of the spectrogram power spectral density at dis‐
crete time t and discrete frequency f.  It can also be stated that the Center 
Time is the smallest discrete time in which the left side of the formula 
exceeds 50% of the total energy in the selection.  Note that the accuracy of 
this measurement is limited to the resolution of the spectrogram, as deter‐
mined by the DFT size.

For the spectrogram slice view, the procedure is the same except that the 
summation over time is not necessary since selections in the slice view 
occupy only one time bin. Units: seconds.

1st Quartile Time
(spectrogram, spectrogram slice, selection spectrum)

The point in time that divides the selection into two time intervals contain‐
ing 25% and 75% of the energy in the selection.  The computation of this 
measurement is similar to that of Center Time, except that the summed 
energy has to exceed 25% of the total energy instead of 50%.

For the spectrogram slice view, the procedure is the same except that the 
summation over time is not necessary since selections in the slice view 
occupy only one time bin.  Units: seconds.

3rd Quartile Time
(spectrogram, spectrogram slice, selection spectrum)

The point in time that divides the selection into two time intervals contain‐
ing 75% and 25% of the energy in the selection.  The computation of this 
measurement is similar to that of Center Time, except that the summed 
energy has to exceed 75% of the total energy instead of 50%.

For the spectrogram slice view, the procedure is the same except that the 
summation over time is not necessary since selections in the slice view 
occupy only one time bin.  Units: seconds.

IQR (Inter-quartile Range) Duration
(spectrogram, spectrogram slice, selection spectrum)

The difference between the 1st and 3rd Quartile Times.

Units: seconds.

Measurements
based on waveform

values

The following measurements are based on the amplitude values of the 
individual samples that make up the audio data.

Max Amplitude
(waveform)

The maximum of all the sample values in the selection. Note that this mea‐
surement can be thrown off slightly by interpolation.  The value plotted on 
the edge of the selection in monotonic data is not exactly the same as the 
measured Max Amplitude.  Units: dimensionless sample values.
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Min Amplitude
(waveform)

The minimum of all the sample values in the selection. Units: dimension‐
less sample values.

Peak Amplitude
(waveform)

The greater of the absolute values of Max Amplitude and Min Amplitude. 
Units: dimensionless.

RMS Amplitude
(waveform)

The root‐mean‐square amplitude (sometimes called “effective ampli‐
tude”) of the selected part of the signal. RMS amplitude is equal to

Formula 6.5    

where n is the number of samples in the selection, and xi is the amplitude 
(in dimensionless sample units) of the ith sample in the selection. Units: 
dimensionless sample units.

Max Time
(all view types)

For a waveform view, the first time in the selection at which a sample with 
amplitude equal to Max Amplitude occurs. For a spectrogram view, the 
first time in the selection at which a spectrogram point with power equal 
to Max Power, Peak Power occurs. Units: seconds.

Min Time
(waveform)

The first time in the selection at which a sample with amplitude equal to 
Min Amplitude occurs.

Peak Time
(waveform)

The first time in the selection at which a sample with amplitude equal to 
Peak Amplitude occurs.

Selection-based
measurements

Begin Time
(all view types)

The time at which the selection begins. Units: seconds.

xi
2

n
------

i 1=

n

∑
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Delta Frequency 
(all view types)

The difference between the upper and lower frequency limits of the selec‐
tion. Units: Hz. 

Delta Time 
(all view types)

The difference between Begin Time and End Time for the selection. Units: 
seconds.

End Time
(all view types)

The time at which the selection ends. Units: seconds.

High Frequency
(all view types)

The upper frequency bound of the selection. Units: Hz.

Low Frequency
(all view types)

The lower frequency bound of the selection. Units: Hz.

Other
measurements

Length
(all view types)

The number of frames contained in a selection. For waveform views, the 
number of frames equals the number of samples in a single channel. For 
spectrogram and spectrogram slice views, the number of frames equals 
the number of individual spectra in the selection in one channel. For selec‐
tion spectrum views, the number of frames always equals 1.

Max Bearing
(beamogram)

The bearing angle with the maximum power for a specific selection. The 
angle will be represented by the area of highest energy in the beamogram. 
Units: degrees.

Peak Correlation
(correlation)

The maximum value of a correlation plot. This measurement is analogous 
to Peak Amplitude in the waveform view. Units: dimensionless.

Peak Lag
(correlation)

The time in a correlation plot at which the Peak Correlation occurs. This is 
analogous to Peak Time in the waveform view except that it represents the 
relative offset into the first sound file of the correlation at which the sec‐
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ond sound file achieves the best correlation with the first file. Units: sec‐
onds.

Measurement
precision and

format

The number of digits of precision displayed by default for measurement 
values is determined by measurement precision preferences, which you 
change by editing the Raven preference file. For general information on 
editing the preference file, see “About Raven preferences” in Chapter 11 
(page 252); for specific information on changing preferences for measure‐
ment precision, see “Measurement presets” in Chapter 11 (page 255).

You can change the measurement precision and format for a given mea‐
surement at any time by choosing Format Column... from the contextual 
menu for the measurement’s column in the selection table. The dialog box 
that appears lets you choose either a decimal or scientific format for mea‐
surement values, and lets you specify the number of digits of precision 
used. 

Using
measurement

presets

The section “Choosing measurements to display” on page 143 describes 
how to use the Measurement Chooser to choose which measurements are 
displayed in the selection table. You can use measurement presets to save 
sets of measurement choices that can later be applied to a selection table 
without having to add or remove one measurement at a time. Measure‐
ment presets also save the format and precision of the measurements that 
are displayed.

To save a measurement preset, first choose the set of measurements to be 
displayed in the selection table, as described in “Choosing measurements 
to display” on page 143. Then choose Save As... from the Preset menu in 
the Measurement Chooser dialog (Figure 6.11).When the Save Measure‐
ment List dialog appears, enter a name for the preset, and click OK. 

To apply a saved measurement preset to the selection table, choose the 
name of the preset from the Preset menu in the Measurement Chooser 
dialog, and click OK. 

Measurement presets must be saved in the folder Presets/
Measurement List/ within the Raven program folder. You 
can also create additional folders within the Measurement 
List folder by clicking on the New Folder icon within the 
Save Measurement List dialog. These folders will appear as 
submenus in the Preset menu, with each submenu listing the 
presets in the corresponding folder.
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Figure 6.11. Measurement Chooser

Figure 6.11.  The Measurement Chooser dialog box. 

If you make changes to the list, order, format, or precision of measure‐
ments displayed in a selection table to which a saved preset has already 
been applied, you can save the changes under the same name by opening 
the Measurement Chooser and choosing Preset > Save “Preset-Name”.

Exporting samples from various views to text files

A list of the numerical sample values contained in the active view of a 
sound can be exported to a text file. This facilitates examination and analy‐
sis of the data using other software applications.  For instance, it might be 
useful to export spectrographic information from Raven for display as a 
3D plot.

For waveform, spectrogram, correlation, and beamogram views, samples 
are exported from the current page.  To export from a segment of sound 
other than what is represented on the page, update the page size. Samples 
in spectrum slice views and selection spectrum views are exported from 
the represented slice or active selection respectively.

In a Sound Window, click on the narrow, vertical view selection button to 
the left of the view for which you want to export sample values.  The color 
of this vertical button will change from white to blue when highlighted.

Choose File > Export “Sound <x>” <selected view> Samples... A sug‐
gested name, <FileName>.samples‐ch<cc>.txt, appears in a dialog box. 
Files can be saved in either Tab‐delimited .txt or Comma‐separated Value 
.csv format.  To finish, click Save.

Export output and
text file content

The specific axis values contained in Raven views are not included in the 
exported text files.  That is, only sample power values are exported; the 
specific values on the x‐ and y‐axes are not included.  For 2‐dimensional 
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data, the sample values are organized in a single column, with reference to 
the x‐axis values of the Raven view (but not the actual values) represented 
vertically.  Multi‐dimensional data is exported as power values, but in this 
case, columns represent the Raven view’s y‐axis values, and rows repre‐
sent the Raven view’s x‐axis values.

Annotations

In addition to the measurements provided by Raven, you can define addi‐
tional columns in the selection table to contain annotations that you enter 
interactively. Each annotation column has a name that you define (e.g., 
“Song Type” or “Individual ID”) and can contain any information you 
want (Figure 6.12). 

Figure 6.12. Annotated view and table

Figure 6.12.  A series of selections with annotations. A single annota-
tion column named “Unit Type” is defined. Selection labels (see “Selec-
tion Labels” on page 155) have been configured to display the 
Selection ID and Unit Type values, separated by “/”. 

Creating, renaming,
and deleting

annotation columns

To create and name a new annotation column, choose Add Annotation Col-
umn... from the selection table’s contextual menu. Enter a name for the 
new annotation column in the dialog box that appears, and click OK.

To rename an existing annotation column, choose Rename Column from 
the contextual menu for that column, enter a new name for the column, 
and click OK.
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To delete an annotation column from the selection table, choose Delete 
Column from the column’s contextual menu.

Entering
annotations

There are three ways to enter annotation values for selections.

Entering annotations when committing selections
When you commit a new selection (see “Committed vs. uncommitted 
selections” on page 129), Raven by default displays the Annotate Selection 
dialog box (Figure 6.13), which lets you enter values for all annotation col‐
umns that are currently defined. If you do not want Raven to display this 
dialog each time you commit a selection, uncheck the box labelled Show 
this dialog whenever a selection is committed.

If you check the box labelled Use specified values as defaults before you 
click OK, then Raven will automatically enter those values in the corre‐
sponding dialog fields when annotating subsequent selections. When 
Raven enters default values in this dialog box, you can either change the 
values, or just press <Enter> or click OK to accept them. 

Figure 6.13.  Annotate selection dialog

Figure 6.13.  The Annotate Selection dialog box. Two annotation col-
umns have been defined, named “Song Type” and “Individual ID”.

Entering annotations directly in the selection table
To enter an annotation value for a particular selection, you can click on the 
annotation cell in the selection table and then type the annotation value, 
followed by <Enter>.

To enter the same annotation value into a series of consecutive entries in a 
selection table, 

If you delete an annotation column that contains annotations, 
the annotation values will be deleted and cannot be retrieved. 
Note that this is different from deleting a column containing 
one of Raven’s built-in measurements, which will be recom-
puted automatically if you later add the column again.
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1. Enter the annotation for the first entry in the series.
2. Highlight the annotation cells for a series of consecutive rows begin‐

ning with the row for which the annotation has been entered.
3. Choose Fill Selected Cells > Down from the contextual menu for the 

annotation column, or press Ctrl-D (Windows) or Command-D (Mac 
OS).

To fill a  series of consecutive annotation cells with the value in the bottom 
cell, choose Fill Selected Cells > Up, or press Ctrl-D (Windows) or Com-
mand-D (Mac OS).

Using the Annotate Selection command
You can enter annotation values into the Annotate Selection dialog box 
(Figure 6.13) for a selection by choosing Annotate from the contextual 
menu that appears for the selection displayed in any view. (Depending on 
whether the selection is active, the menu command will either be dis‐
played as Active Selection N > Annotate or Selection N > Annotate.) 

Selection Labels By default, Raven displays each selection’s ID number in selection labels in 
views. To toggle display of selection labels on and off, use the checkbox in 
the component list of the side panel’s Layout tab (Figure 2.13, page 34). 

Selection labels can display selection IDs and/or any combination of mea‐
surements or annotations that are shown in the selection table. To choose 
which measurements are included in selection labels, as well as specifying 
font size and a string to use as a separator between items in selection 
labels, choose Configure Selection Labels from the View menu or any 
view’s contextual menu. To add a measurement or annotation to selection 
labels, highlight that item’s name in the list of Available Items, and click 
the left‐pointing arrow button in the Configure Selection Labels dialog box 
(Figure 6.14). To remove an item from selection labels, highlight its name 
in the list of Displayed Items, and click the right‐pointing arrow button. 
You can also enter a string of text that will appear as a separator between 
items in the selection labels; the default separator is a single space charac‐
ter.
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Figure 6.14. Configure selection labels dialog

Figure 6.14.  The Configure Selection Labels dialog box.

You can specify colors for active and inactive selection labels via the color 
scheme editor (View > Color Scheme > Edit...), as described in “Editing 
color schemes” in Chapter 3 (page 61). .

Colors chosen in the above manner will pertain to selections 
made in the first selection table. Colors for additional selec‐
tion tables can be set in the corresponding tab’s context menu.
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About this Chapter

Sounds can be collected and managed in a variety of ways. Some continu‐
ous recordings are made into sequences of large files, while others are 
made into sequences of many small files. Other recordings are separated 
into smaller clips of relevant information by using detectors or browsing 
and making selections by hand and saving the selections into individual 
files. All of these cases fall into a broad category of having a lot of data to 
manage, or having a large dataset.

Raven offers many features for working with large datasets including pag‐
ing, performing batch operations, and handling streams.  This chapter 
includes sections on the following topics:

•Paging
•Batch operations
•Opening file sequences
•Opening multiple sound files in multiple windows
•Streams
•Opening sounds with altered speeds

Paging

Paged sound windows enable you to open sounds that are too large to fit in 
the memory available to Raven. In a paged sound window, Raven loads 
only a specified amount of the sound, called a page, into memory at one 
time. The portion of the entire signal that is presently in memory is called 
the current page. A paged sound window includes a page navigation panel 
that enables you to jump easily to any other part of the signal that’s not 
presently in memory. Paged sound windows can be used to display single 
sound files or file sequences.

Paged sound windows behave like non-paged windows, 
except that you cannot perform editing operations that alter 
the audio data (i.e.Cut, Paste, Delete, Filter, or Amplify).
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Configuring a new
paged sound

window

When you first open a sound file or a sound file sequence, Raven displays 
the Configure New Sound Window dialog box, which gives you the choice 
of loading the entire sound into memory or creating a paged sound win‐
dow (Figure 7.1). To open a sound in a new paged sound window, choose 
Page Sound. To specify how much of the sound should be loaded into 
memory at any given time, enter a value into the Page size field. You can 
choose units of seconds or minutes for page size from the drop‐down 
menu. Page increment and Step increment specify the amount by which 
the paged display moves when you click the Page Forward, Page Back, 
Step Forward, or Step Back controls as described in “Moving the page 
incrementally: the Page and Step buttons” on page 160. You can specify 
Page increment and Step increment either as a percent of the page size or 
as an absolute number of seconds or minutes by choosing the appropriate 
units from the drop‐down menu next to each field.

Figure 7.1. Configure Sound Window dialog

Figure 7.1.  The Configure New Sound Window dialog box.

The Configure New Sound Window dialog box also allows you to choose 
a window preset to be applied to the new window when it is first created, 
as discussed in “Window preset and paging” in Chapter 1 (page 4).

Navigating through
signals in paged
sound windows

When you open a single file or a file sequence in a paged sound window, a 
page navigation panel is displayed at the top of the window, above any 
views that are displayed (Figure 7.2). 
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Figure 7.2. Paged sound window‐‐ file sequence

Figure 7.2.  A file sequence of five files opened in a paged sound win-
dow, with page size of 30 seconds. The entire file sequence is slightly 
over 13 minutes long. For a single file opened in a paged window, the 
current file name and the file sequence number are not displayed.

The paging scrollbar
The page navigation panel contains a paging scrollbar whose length corre‐
sponds to the entire signal, including those portions of the signal that are 
not presently in memory. The scroll box in the paging scrollbar represents 
the data in the current page (i.e., the data currently in memory). The length 
of this scroll box, relative to the length of the entire scrollbar, indicates 
what proportion of the entire signal is included in the current page. The 
position of the scroll box within the scrollbar indicates the position (in 
time) of the current page within the entire signal. The start time of the cur‐
rent page is displayed below the scrollbar. You can move the page to any 
point within the signal by dragging the scroll box. As you drag the scroll 
box, the displayed start time of the page is continually updated to corre‐
spond to the position of the scroll box. If the signal is a file sequence, the 
name and sequence number of the file containing the start of the page are 
also continually updated as you move the scroll box. When you release the 
scroll box at a new start time, Raven loads the data for the new page posi‐
tion as needed from the file or file sequence and updates the views dis‐
played in the window. Depending on the page size and the number and 
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type of views shown, there may be a slight delay while Raven updates the 
views.

Clicking in the scrollbar to the right or left of the scroll box pages forward 
or back, equivalent to clicking the Page forward or Page back button (see 
below).

Moving the page incrementally: the Page and Step buttons
The Page Forward, Page Back, Step Forward, and Step Back buttons (Fig‐
ure 7.2) move the current page to a new location within the entire signal 
by large or small increments. The amount that the page moves forward or 
back through the signal depends on the values that were entered in the 
Page increment and Step increment fields of the Configure New Sound 
dialog box (see “Configuring a new paged sound window” on page 158). 
By default, paging forward or back moves the page by 90% of the page 
size, resulting in a 10% overlap between successive pages. Stepping for‐
ward or back moves the page by 10% of the page size by default, resulting 
in a 90% overlap between successive pages.

Jumping directly to a particular time within a signal
To jump to a particular page start time within the entire signal, enter a 
time value in the Page Start Time field in the page navigation panel (Fig‐
ure 7.2), and press <Enter>. You can enter a time either in units of seconds, 
or minutes and seconds, or hours, minutes, and seconds. The latter two 
formats use colons to separate the units, for example 1:02:03 to repre‐
sent 1 hour, 2 minutes, and 3 seconds. 

The current file indicator; jumping to a particular file in a sequence
For file sequences, the page navigation panel displays the name of the file 
containing the start of the current page. To move the start of the page to 
the beginning of a particular file, choose the name of that file from the file 
name drop‐down menu.

Selections
spanning pages

You can create a selection that spans boundaries between pages by shift‐
clicking. Click once at the start or end of the interval you wish to select, 
then page forward or back as needed, and shift‐click at the other limit of 
the interval. Once the selection is created, you can copy or save it as you 
would with any selection in a non‐paged window.

Don’t confuse the functions of the two horizontal scrollbars in 
a paged sound window. The scrollbar in the page navigation 
panel at the top of a paged sound window refers to the time 
dimension of the entire signal. The scrollbar and navigation 
controls at the bottom of the window refer to the horizontal 
axis of the active view for the current page. 
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Reconfiguring
paging for an

existing window

You can change the page size and the page and step increments for a 
paged sound window at any time by choosing Configure Paging... from 
the contextual menu for the page navigation panel (right‐click with a 2‐
button mouse or <Control> + click on a Mac). You can then enter new val‐
ues for any of the page configuration parameters in the Configure Paging 
dialog box (Figure 7.3).

Figure 7.3.  Configure paging dialog

Figure 7.3.  The Configure Paging dialog box, which is used to recon-
figure paging for an existing paged sound window.

Batch Operations

Raven has a batch channel exporter which operates on subsets of channels 
from a collection of sound files. More information on this feature, includ‐
ing how to use it, can be found in “Batch channel export” in Chapter 8 
(page 175).

Opening file sequences

Raven allows you to open multiple sound files as a file sequence, provided 
that the files have the same file format (e.g., AIFF or WAVE), sample rate, 
and number of channels. When files are opened as a sequence, the audio 
data in the files are concatenated into a single sound signal that opens in 
one window. A sound window containing data from a file sequence looks 
and behaves the same as a single‐file sound window, except that there is 
no file name displayed in the title bar (Figure 7.4), and Cut, Delete, and 
Paste operations are prohibited.

You can open a sound file sequence either by giving Raven the name of a 
list file, or by manually choosing a set of files to be opened as a sequence.  

Using a list file A list file is a plain text file (filename extension .txt) that lists the names 
of a series of sound files to be opened together as a sound file sequence. A 
list file is created automatically by Raven when you record to a file 
sequence (see “Recording to a file sequence” in Chapter 4, page 82). You 
can also create a list file manually in a word processing or text editing pro‐
gram.
Raven Pro 1.3 User’s Manual 161



Chapter 7:  Large Datasets
To open a file sequence using a list file, choose File > Open Sound Files... 
or type <Ctrl-O> (Windows) or <Command-O> (Mac OS). In the Open 
Sound Files dialog box that appears (Figure 1.2, page 3), choose or type the 
name of the list file, then click OK. In the Configure New Sound Window 
dialog box, you can then choose either to open the entire file sequence or 
to open the sequence in a paged sound window. Paged sound windows 
are discussed in “Configuring a new paged sound window” on page 158. 
A new sound window will appear displaying all of the audio data from all 
of the sound files specified in the list file, or data from the first page of the 
sequence, in the order that the file names appear in the list file.

Format of a list file
A list file consists of a series of file name entries, one per line. Each entry 
can be a simple file name, a relative path name, or an absolute path name. 
If the entry is a simple file name, Raven looks for the file in the same direc‐
tory as the list file. A relative path name can start with the name of a sub‐
directory within the list file’s directory, or it can use the double‐dot (..) 
notation to indicate the parent directory of the list file’s directory. For 
example, consider a list file that resides in the directory c:\SoundData 
and contains the following four entries:

firstFile.wav
moreData\secondFile.wav
..\otherSounds\thirdFile.wav
c:\frogSounds\fourthFile.wav

When opening this file sequence, Raven will look for the following files:
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c:\SoundData\firstFile.wav
c:\SoundData\moreData\secondFile.wav
c:\otherSounds\thirdFile.wav
c:\frogSounds\fourthFile.wav

On a Mac, consider the list file /Applications/RavenPro1.3/Sounds/MyL‐
ist.txt that contains the following entries:

sound.wav
../examples/CanyonWren.wav
birds/Chickadee.wav
/users/Amanda/Sounds/rugbyGrunt.wav

When opening this file sequence, Raven will look for the following files:

/Applications/RavenPro1.3/Sounds/sound.wav
/Applications/RavenPro1.3/examples/CanyonWren.wav
/Applications/RavenPro1.3/Sounds/birds/Chickadee.wav
/Applications/RavenPro1.3/Sounds/users/Amanda/Sounds/rug‐

byGrunt.wav

Selecting files in a
sequence

individually

You can manually specify a set of sound files to open as a sound file 
sequence by choosing multiple files from within the Open Sound Files dia‐
log box. There are three ways to choose multiple files to open as a 
sequence:
•Click on the name of the first file you want to open in the list of files. 
Then select additional files to open by clicking on their names while 
holding down the Ctrl key. The names of all of the files you clicked will 
be highlighted, and will be shown in the File Name field. Each file name 
in the File Name field will be enclosed in double quotation marks (Fig‐
ure 7.5).

•If the names of the files you want to open are listed consecutively (with 
no intervening file names) in the file list, click on the name of the first 
file to open, then shift‐click on the name of the last file. The names of the 
two files you clicked and all files between those two will be highlighted, 
and will be shown in the File Name field. Each file name in the File 
Name field will be enclosed in double quotation marks.

•You can type the names of the files that you want to open in the File 
Names field, with each name enclosed in double quotation marks (like 
“myFile.wav”), and a space between successive quoted file names.

After you click OK in the Open Sound Files dialog box, the Configure New 
Sound Window dialog box appears (Figure 7.6). In the Multiple Files pane 

When specifying directories in list files, the forward slash (/) 
and back slash (\) characters may be used interchangeably.
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at the bottom of the Window tab, click on Open as file sequence in one 
window. 

After choosing either to open the file sequence in its entirety in a single 
window or in a paged sound window (see “Configuring a new paged 
sound window” on page 158), click OK. A new sound window will appear 
displaying all of the audio data from all of the sound files specified in the 
Open Sound Files dialog box, or data from the first page of the file 
sequence. When Raven opens a sequence of files that were individually 
specified (as opposed to given in a list file), the order in which data from 
the different files are displayed is determined by the lexicographic order 
of the file names.1

When data from more than one file in a sequence are visible in a view, 
Raven displays dashed green file boundary markers (Figure 7.4) between the 
data from each file.

Figure 7.4. Sequence of 2 files

Figure 7.4.  The files “ChestnutSidedWarbler.aif” and “LarkSparrow.aif” 
from the Raven Examples folder opened as a file sequence. The 
dashed green vertical line shows the boundary between the two sound 
files. 

1. In lexicographic ordering, numbers precede letters. For example, if you were 
to open two files named abc.wav and ab1.wav as a sequence, the data 
from ab1.wav would be displayed first followed by the data from abc.wav. 
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Opening multiple sound files in separate windows

You can open more than one sound file at a time, with each sound appear‐
ing in a separate window, by choosing multiple files from within the Open 
Sound Files dialog. To display the Open Sound Files dialog, choose File > 
Open Sound Files.... There are three ways to choose multiple files to open:

•Click on the name of the first file you want to open in the list of files. 
Then select additional files to open by clicking on their names while 
holding down the Ctrl key. The names of all of the files you clicked will 
be highlighted, and will be shown in the File Name field. Each file name 
in the File Name field will be enclosed in double quotation marks (Fig‐
ure 7.5).

•If the names of the files you want to open are listed consecutively (with 
no intervening file names) in the file list, click on the name of the first 
file to open, then shift‐click on the name of the last file. The names of the 
two files you clicked and all files between those two will be highlighted, 
and will be shown in the File Name field. Each file name in the File 
Name field will be enclosed in double quotation marks.

•You can type the names of the files that you want to open in the File 
Names field, with each name enclosed in double quotation marks (like 
“myFile.wav”), and a space between successive quoted file names.

•You can click on a .txt file that contains a list of file names to open, like 
those produced by the Raven file sequence recorder. See a description of 
list files in “Using a list file” on page 161.

Once you have chosen all of the files you want to open, click OK. 

Figure 7.5. Open dialog 2 files selected

Figure 7.5.  The Open Sound Files dialog box, with two files selected 
by control-clicking in the file list.
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After you click OK in the Open Sound Files dialog box, the Configure New 
Sound Window dialog box appears (Figure 7.6). In the Multiple Files pane 
at the bottom of the Window tab, click on Open in separate windows. 

After choosing either to open each file in its entirety in a single window or 
in a paged sound window (see “Configuring a new paged sound win‐
dow” on page 158), click OK. Each of the chosen files will open in a sepa‐
rate window, using the window preset that was specified in the dialog.

Figure 7.6. Config multi‐file window

Figure 7.6.  The Configure New Sound Window dialog for opening mul-
tiple files.
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Figure 7.7 separate windows

Figure 7.7. The sound files selected in Figure 7.5 shown in separate 
sound windows after selecting “Open in separate windows” in the Con-
figure New Sounds Window dialog.

Correcting sounds acquired at altered speeds

It is sometimes necessary or useful to acquire sounds from recordings 
played at speeds slower or faster than the speed at which they were 
recorded, as discussed in “Advanced options: acquiring from recordings at 
altered input speeds” in Chapter 4 (page 88). Sounds that were acquired 
with the appropriate speed correction in Raven 1.2 and subsequent ver‐
sions, as discussed in that section, require no further corrections. How‐
ever, if you have sound files that were acquired at altered input speeds 
with older versions of Raven or with another program that did not correct 
for the altered input speed, you can correct the speed when opening the 
file. 

Correcting speed
when opening file

The Speed tab in the Configure New Sound Window dialog box (Figure 
7.8) allows you to specify the factor by which the sound was slowed down 
or sped up (relative to normal speed) when it was acquired. The Configure 
New Sound Window dialog box is displayed after you choose one or more 
files to open in the Open Sound Files dialog box.
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Figure 7.8.  Configure window‐‐ speed tab

Figure 7.8.  The Speed tab in the Configure New Sound Window dialog 
box.

If you provide the appropriate speed correction factor when opening the 
file, then Raven will display time and frequency axes of views, and mea‐
surements so that they refer to the original sound at normal speed. 

Raven corrects a file’s speed by altering its sample rate. If you save a file 
after applying a speed correction, it is saved with the new corrected sam‐

Sounds that are acquired at an altered speed using the 
appropriate speed correction factor behave in Raven as if 
they had been acquired at normal speed. Thus, to hear 
sounds that were originally above or below the human hear-
ing range, you will need to specify an appropriately low or 
high speed for playback, as described in “Playback rate” in 
Chapter 1 (page 9).
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ple rate. The next time the file is opened (either by Raven or any other pro‐
gram), its speed will be correct without any adjustment. 

In order to save a file with a corrected speed, you must open 
a single file (not a sequence) in its entirety (not in a paged 
sound window). For file sequences, you must either apply the 
correction each time you open the sequence, or else open 
and save each individual file once with a speed correction. 
For files that are too large to open in unpaged windows, you 
must apply the speed correction each time you open the file.
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Chapter 8  Multi‐channel Sounds

About this chapter

Raven allows you to work with sounds containing any number of chan‐
nels. The sound cards supplied with most computers allow you to record 
and play back sounds containing either one or two channels (i.e., mono or 
stereo). 

To record or play back sounds with more than two channels, you need to 
have a multi‐channel sound card or external device installed on your com‐
puter.

Extensible multi-
channel audio input

device support

Raven 1.3 includes support for multi‐channel recording using both NI‐
DAQ (National Instruments Data Acquisition hardware) and ASIO 
(Audio Stream In/Out) audio input devices. The NI‐DAQ technology pro‐
vides input capabilities of up to 32 channels with an adjustable voltage 
range. ASIO devices provide 24‐bit audio sample size capabilities. Both of 
these are Windows platform devices. Raven also supports Java Sound for 
Windows, which provides  mono and stereo recording capabilities. The 
Macintosh version of Raven supports Java Sound and also Appleʹs Core 
Audio, which provides multi‐channel recording capabilities with 24‐bit 
audio sample size (see Chapter 4, “Signal Acquisition (Recording)” for 
more information).

In this chapter you will learn:

•the basics of working with multi‐channel files.
•how to export subsets of channels from a single file or batch of files.
•how to create selections in multi‐channel files.
•how to use multi‐channel files for bearing analysis.

Working with multi-channel files

Displaying and
hiding channels

The Layout tab of Raven’s side panel contains a Channels pane that lists all 
of the channels of the active sound window (Figure 8.1). Each channel is 
identified by a number. A checkbox next to each channel number controls 
whether that channel is visible in the sound window. To display or hide a 
channel, turn the checkbox on or off by clicking on it. You can display or 
hide all channels in a sound at once by clicking the Show All or Hide All 
icon above the checkboxes (Figure 8.1).
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Figure 8.1. Channels pane in side panel

Figure 8.1.  The Channels pane on the Layout tab of Raven’s side 
panel.

In the Layout tab of Ravenʹs side panel, checking Line Titles in the Compo‐
nents menu causes channel numbers to be displayed along with the view 
type and the number of each view. 

Editing multi-
channel sounds

Each channel of a multi‐channel sound must be exactly the same length 
(i.e., must contain the same number of samples) as every other channel in 
the sound. Therefore, editing operations that change the length of a 
sound— Cut, Paste, and Delete— always apply to all channels in a sound. 
Editing operations that do not change the length of a sound— Copy, Filter 
and Amplify— can apply to some channels and not to others.

If a sound window contains any data, you can paste into it only if the 
number of channels in the window is the same as the number of channels 
of data that were placed on the clipboard by a Copy or Cut operation. If a 
sound window is empty (either a new window or one from which all data 
have been deleted), its number of channels is undefined, and you can 
paste any number of channels into it.

Selecting channels for editing operations

By default, all editing operations apply to all channels. If you want an 
operation (such as copying) to apply only to some channels, you must first 
select those channels for editing. In the following descriptions, the <Com-
mand> (MacOS) key functions in the same way as the <Ctrl> (Windows) 
key.

In multi‐channel signals, hiding or showing particular chan‐
nels of a view will also hide or show those channels in other 
views that are linked by Channel Visibility. (See “Linking and 
unlinking views” in Chapter 3 (page 53))
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To select a channel for editing, click the channel number(s) (to the right of 
the check box in the side panel’s channel panel) of the channel(s) that you 
want to save; the channel number(s) will become highlighted in yellow. 
<Ctrl> + click (or <Command> + click) can be used to select more than one 
channel. 

A channel can also be selected by holding down the <Ctrl> (or <Com-
mand>) key and clicking the view selection button (see Figure 3.2, page 
41). To select additional channels, <Ctrl> + click (or <Command> + click) in 
their view selection buttons. 

To deselect a channel that is already selected, either click again on (or to 
the right) of its channel number in the Layout panel, or <Ctrl> + click (or 
<Command> + click) on its yellow view selection button. 

Moving channels to display in different order

By default, the channels will be listed, top to bottom, from 1 to n. How‐
ever, you can choose to rearrange the order in which the channels are dis‐
played. To do this, select the channel you wish to move and then click to 
drag‐and‐drop the highlighted channel up or down in the channel list. 
This will change the order the channels are displayed in all views in the 
sound window.

If there are multiple channels selected, in order to deselect a 
channel that is already selected from the Layout panel, you 
must <Ctrl> + click on or to the right of its channel number.

If you choose to save the channels after rearranging them, the 
channels will be saved in the new order.
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Figure 8.2 Selected Channels

Figure 8.2. Shows a 4-channel sound displayed in a window (right) with 
channels 1-3 selected in the Side Panel (left) as indicated by the yellow 
highlights.

Saving a subset of
channels from an

open signal

 If a sound contains any data, the number of channels in the sound cannot 
be changed. To save a subset of channels from an open sound, first select 
the channels as described above. Then choose File > Save Selected Chan‐
nels As… . You can choose to Save the new file in a number of different 
formats: 8‐bit, 16‐bit, or 24‐bit .aiff or 8‐bit, 16‐bit, or 24‐bit .wav. Choose 
the file type, then click Save.

In contrast to Raven 1.2, Raven 1.3 allows an entire channel or channels of 
data to be saved without a selection having to be made, and so this feature 
replaces the need to select an entire view in order to save a channel.

 If you want to select an entire view for saving or editing, 
make sure you are zoomed to the entire signal, then choose 
Edit > Select All. (This will select all of the currently viewed 
data in the active view.)
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Figure 8.3. Channel selection

Figure 8.3. A multi-channel sound window, with Channels 1 and 3 
selected for editing. The view selection buttons for the selected chan-
nels and their entries in the side panel’s Channels list are yellow.  

Exporting channels

Saving selected
channels

You can export subsets of channels from an open sound file by selecting 
the desired channels and choosing File > Save Selected Channels As... 
from the menu. More information on this process can be found in “Saving 
a subset of channels from an open signal” on page 174.

Batch channel
export

To export a specific subset of channels from a collection of sound files, put 
the collection of files (or copies of the files) in one directory. Then choose 
Tools > Batch > Channel Exporter... As the Input Folder, enter the name of 
the directory containing the collection of files you’d like to change, then 
enter the name of the Output Folder in which you want to store the new 
files. Choose the channels that you would like to export and click OK (Fig‐
ure 8.4).
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Figure 8.4 Batch Channel Export dialog

Figure 8.4. Batch Channel Export dialog showing Input/Output Folders, 
and the channels selected to be exported (in this case, channels 1 and 
3.)

Creating selections in multi-channel sounds

Selections in multi‐channel sounds can be defined for any subset of the 
channels in the sound (Figure 4.3). By default, when you create a new 
selection in a multi‐channel sound, the selection is defined only in the 
channel in which you outlined the selection. To define new selections 
simultaneously in more than one channel, you must first select the chan‐
nels in which you want the selections to be created. As described above, to 
select channels for creating selections, hold down the <Ctrl> (Windows) or 
the <Command> (MacOS) key and click in the view selection button at the 
left edge of any view of each channel to be selected.  
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Figure 8.5. Channel‐restricted selections

Figure 8.5.  Channel-restricted selections in two channels of a four-
channel sound. Channels 1 and 3 are hidden. Selection 1 is defined in 
channel 2 only; selection 2 is defined in channel 4 only; selection 3 is 
defined in both channels.

When you create a selection in a selected channel, the selection will be 
defined in all selected channels. When you create a selection in a non‐
selected channel, it will be created in that channel only. 

To change the channels in which a selection is defined after it is initially 
created, open the Selection tab in the side panel. Checkboxes indicate the 
channels in which the active selection is defined. To change the channels in 
which the active selection is defined, check or uncheck channel check‐
boxes.

Bearing analysis: Beamforming, Beamogram View, and Max Bearing Measurement

It is often useful in bioacoustic analysis to use an array of sound sensors as 
a means of determining the source direction of signals recorded by the 
array. One common way of doing this is to process the sound with a beam‐
forming algorithm. Beamforming indicates only the bearing (a line repre‐
senting a specific direction) along which a sound arrives at a sensor. The 
distance between source and sensor is not computed. Also, the results of 
beamforming using a straight, linear array will contain right/left ambigu‐
ities. That is, it will not be possible to obtain information regarding on 
which side of the aray the source is located. However, if you know the 
general location of the sound source relative to the array, or if your array is 
not linear, beamforming provides information that can help to determine 
specific bearing locations and to potentially distinguish different individu‐
als that are producing sounds in the same region.
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Figure 8.6

Figure 8.6. A visual representation of an array (the black squares along 
the y-axis), a sound source (the black circle), and the bearing of the 
sound relative to the origin of the graph.

Beamogram view Beamforming in Raven provides a means for determining sound source 
locations, as bearing lines, relative to a 2‐dimensional, multi‐channel array 
of sensors. The result of Raven’s beamforming process is a set of angles, 
displayed in a beamogram view, that represent potential bearing angles 
between a reference direction and potential bearing line directions. Raven 
iteratively tests all possible locations within a range of angles specified in 
the beamogram configuration. Areas of higher energy on the beamogram 
indicate the relative likelihood that specific bearing angles represent 
actual sound source bearings.
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Figure 8.7 Beamogram view

Figure 8.7. 5-channel synthesized sound, showing waveform, spectro-
gram, and beamogram views, with the beamogram being the active 
view. The Max Bearing measurement (see “Max bearing measurement” 
on page 179) is also included in the selection table. The sound used to 
create this display is 
TestBeamo_SS1500_5ChanArray_0_17_50_60_80_d143.wav and can 
be found in the Raven Examples directory.

Max bearing
measurement

In the beamogram, bearing angles (beams) are represented in degrees on 
the y‐axis, and time is represented in seconds on the x‐axis. To find the 
bearing angle with the maximum power for a specific selection in Raven, 
choosing the Max Bearing measurement will give you the angle repre‐
sented by the area of highest energy in the beamogram. See “Measure‐
ments” in Chapter 6 (page 143) for more information on this and other 
measurements.

Configuring a
beamogram

To create a beamogram, open a multi‐channel sound file and choose View 
> New > Beamogram View... or choose the New Beamogram button in the 
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toolbar. You will be need to enter information about the recording 
medium, array geometry, bandpass filtering, beamforming, and channels 
in each of the tabbed pages (see “Beamogram parameters” on page 180 for 
details).

Choose OK to apply the configuration and close the window (alternately, 
you can choose Apply to preview your parameters without closing the 
window). To update parameters for an existing beamogram view, be cer‐
tain that the beamogram is the active view and choose View > Beamogram 
Configuration... or right‐click anywhere on the beamogram view and 
choose Beamogram Configuration... from the context menu.

Figure 8.8 Configure Beamogram dialog

Figure 8.8. The Configure Beamogram dialog, showing the different 
parameter tabs (Medium, Array, etc.) across the top. Incidentally, these 
are the array settings used to create the beamogram in Figure 8.7.

Beamogram
parameters

When creating a beamogram view, Raven needs to know certain informa‐
tion about your recording setup. Information about these parameters can 
be entered into the Configure Beamogram dialog, on any or all of the 
tabbed pages (see Figure 8.8). More information about these parameters is 
below. 

Medium
Sound speed refers to the speed of sound within the recording medium, 
typically either air or water. The speed of sound varies in these media 
based on a number of parameters, including the temperature and density 
of the media. However, a useful approximate value for the speed of sound 
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in air is 330 meters/second, and in saltwater, a useful approximate value is 
1500 meters/second.

Array
On this tab, you must enter the X‐ and Y‐ locations of the sensor array ele‐
ments. The sensor positions need to be expressed using coordinates that 
indicate positions (in meters) relative to one another. So, if you have lati‐
tude and longitude values, you will need to convert these to UTM values, 
and then derive the relative positions in meters.

Filtering
If you would like the signal to be bandpass filtered before the beamform‐
ing calculations are made, enter low‐ and high‐ frequency limits to define 
the bandwidth that will be passed through the filter. If your recording unit 
produces a DC‐offset signal, it can be useful to filter this out for beam‐
forming. Also, it may be useful to filter out upper harmonic or noisy fre‐
quencies to reduce the appearance of aliasing in the beamogram by using 
a bandpass filter. (As an aside, no filtering was used in creating the beamo‐
gram in Figure 8.7.) More information on how to filter a signal can be 
found in “Filtering and amplifying sounds” in Chapter 6 (page 133).

Beamforming
The beamforming tab has several parameters to specify, which are listed 
with brief descriptions below. See Figure 8.9 for a picture of the tab.

•Time Grid: Hop size, Record size
The system computes one group of samples (with length specified in 
Record Size section) at a time. Before computing each subsequent 
group of samples, it ‘hops’ by the number of samples given in the Hop 
size box. This process is repeated iteratively for all beams (bearing 
angles). A smaller hop size will create more ‘columns’ in the beamo-
gram.

Record size is the number of samples of sound over which a beam will 
be computed.

•Normalize channels
If the gain imbalance between the recorded channels is large, it may 
become the main information used in the beamformer computation. 
Therefore, unless the microphones and recording unit are carefully cal-

It can be helpful to experiment with turning on and off the 
View > Smooth Beamogram setting as a way to explore how 
the Hop size and Record size settings affect the beamogram 
display.
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ibrated to produce a uniform gain, normalizing the signal will probably 
be useful.

•Bearing Grid: Minimum bearing, Maximum bearing, Number of bear‐
ings

The Minimum bearing and Maximum bearing values (in degrees) 
define the range over which the series of individual beams (bearings) 
will be calculated. It is generally useful to restrict the range to the direc-
tional region most likely to contain the source.

The Number of bearings is the number of beams that will be computed. 
A larger number of beams will usually produce a more accurate mea-
surement. The resolution of the beamformer system is defined by the 
difference between the Maximum and Minimum bearings, divided by 
the Number of bearings.

•Bearing Coordinate System: Reference bearing, Bearings increase
When the Reference bearing is set to zero degrees, the array is set to be 
perpendicular to a line pointing toward the source. However, this may 
or may not be the physical case in every situation. If the array is not 
“straight” the beamogram coordinates will be in line with the array 
coordinates for the actual array. Using information about the possible 
location of the sound source relative to the array can provide a more 
accurate beamforming result. Altering the Reference bearing angle 
alters the orientation of the array relative to the sensor for the purposes 
of the beamformer calculation.

The direction of rotation of the bearing grid that results from altering 
the reference angle can be specified as either clockwise or counter-
clockwise in the Bearings increase box.
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Figure 8.9 Beamforming tab on configure dialog

Figure 8.9. Parameters contained on the Beamforming tab in the Con-
figure Beamogram dialog. These parameters were used to create the 
beamogram shown in Figure 8.7.

View channels
You can create different subsets of channels to use with the beamformer 
calculation and compare the results. Depending on the quality of signals 
received by each sensor, it may be useful to view different combinations of 
sensor signals in the Beamogram view. Each combination is called a Chan‐
nel. The limit on the number of different combinations that can be viewed 
simultaneously is equal to the number of channels in the sound. Channels 
are added to the end of the list and are removed from the end of the list.

Hints for working
with beamograms

A useful way to work, after setting the initial parameters, is to ‘steer’ the 
beamformer by adjusting the reference bearing and the min and max bear‐
ings. Begin with a large number of bearings (200 or more) to create a high 
resolution. As mentioned before, filtering the signal can also be helpful. 
Figure 8.10 gives a graphical representation of how orienting the beam‐
former can work.
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Figure 8.10 Beamformer orientation

Figure 8.10. Orienting the beamformer using the Maximum, Minimum, 
and Reference bearing parameters.
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About this chapter

This chapter explains how Raven’s correlation tool works. Correlations are 
a way to perform quantitative comparisons between spectrograms or 
waveforms. In this chapter youʹll learn:

•some general information about correlation
•how correlation functions are calculated
•how to use the correlation function and specify options common to both 
spectrogram and waveform correlations

•about issues and options specific to each type of correlation
•about batch correlation

Overview of Correlation

Correlations are performed by ʹslidingʹ two inputs (either two spectro‐
grams or two waveforms) past each other in time. At each time offset, a 
correlation value between the inputs is calculated. These correlation values 
are then plotted versus time in a correlation plot to show a measure of simi‐
larity between the inputs. The time axis of the plot is shown relative to the 
first input, so a peak at a positive time offset indicates that the first signal 
is ahead of the second.

Correlation types Raven provides the capability to run correlations between either two spec‐
trograms or two waveforms.
•Correlating spectrograms:  Usually when correlating spectrograms,  the 
most important information provided is the peak correlation value 
which shows the similarity between the spectrogram images. 

•Correlating waveforms:  Waveform correlation can help determine the 
time offset, also called lag, at which two signals most closely resemble 
each other, as shown in Figure 9.2.

Calculating Correlation Functions

Spectrogram
correlations

For each time offset Δt, Raven calculates either a normalized or non‐nor‐
malized correlation value CΔt between two spectrograms.  If the Normalize 
option is selected, each correlation value is calculated using the following:
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Formula 9.1  

where n equals (N1+N2) ‐ 1 and N1 and N2 are the numbers of frames in 
the two spectrograms.  FFT equals the number of frequency bins, which 
must be the same for the two spectrograms being correlated.  Xt,f and 
Yt+Δt,f are the amplitude values (in this case, the power of the spectrogram) 
in the two spectrograms at frequency f and times t and t+Δt, respectively.  
The normalized correlation value for spectrograms can vary between 0 
and 1. A correlation of 0 means that the non‐zero values in the two spec‐
trograms do not coincide at all; a correlation of 1 indicates that the two sig‐
nals are identical (given the time offset Δt.) Successive correlation values 
are calculated by incrementing the value of Δt in steps equal to the time 
grid resolution (which must be the same for both spectrograms) in effect 
sliding the two spectrograms past each other in time.  If normalization is 
turned off, only the numerator of Formula 9.1 is used.

Figure 9.1

Figure 9.1. A spectrogram correlation between two calls of a Black-
capped vireo.
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Waveform
correlations

For each time offset, Raven calculates either a normalized or non‐normal‐
ized correlation value between two waveforms. If the normalize option is 
selected, each correlation value is calculated using:

Formula 9.2  

where n equals (N1+N2) ‐ 1 and N1 and N2 are the numbers of digitized 
samples in the two waveforms. xt and yt+Δt are the values of sample num‐
bers t and t+Δt of the two waveforms, respectively.  If the two signals differ 
in length, the shorter signal is zero‐padded to the length of the longer sig‐
nal.  The correlation value for waveforms can vary between ‐1 and 1 (If 
you choose to plot the complex envelope of a waveform correlation, the val‐
ues that are plotted vary between 0 and 1, as discussed in “Spectrogram 
correlation” on page 192). 

A correlation of 0 means that the signals are orthogonal1; a correlation of 1 
indicates that the two signals are identical; a correlation of ‐1 indicates that 
the signals are identical in magnitude, but opposite in phase.

Successive correlation values are calculated by incrementing the value of 
Δt in steps equal to the inverse of the sampling frequency, in effect sliding 
the two waveforms paste each other in time.  If normalization is turned off, 
only the numerator of Formula 9.2 is used.

1.  Whether or not two signals are orthogonal depends on their frequency con‐
tent and on their relative phase. For example, sinusoidal signals of very differ‐
ent frequencies are orthogonal, as are signals of the same frequency that are 
90o out of phase with each other.

Although Formula 9.1 and Formula 9.2 are written in the 
time domain, Raven actually performs these computations in 
the frequency domain.  This improves the performance of the 
correlator.

CΔt

xt yt Δt+⋅( )

t 1=

n

∑

xt
2

t 1=

n

∑
⎝ ⎠
⎜ ⎟
⎜ ⎟
⎛ ⎞

yt Δt+
2

t 1=

n

∑
⎝ ⎠
⎜ ⎟
⎜ ⎟
⎛ ⎞

-------------------------------------------------------------=
Raven Pro 1.3 User’s Manual 187



Chapter 9:  Correlation
Figure 9.2

Figure 9.2. A normalized waveform correlation plot.  The peak correla-
tion lag is shown on the x-axis by the vertical magenta line.  Note that a 
positive correlation lag indicates that the first waveform is ahead of the 
second in time.

Using the correlation tool

To perform a correlation, choose Tools > Correlator and select the two files 
to be compared.  Next, choose whether to correlate the waveform or the 
spectrogram views and select any appropriate parameters (see below for 
more information on specific options).

Note that both signal files must be recorded at the same sam‐
ple rate in order to be correlated.
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Figure 9.3 Correlation Dialog Box

Figure 9.3. The Correlation dialog box.  After selecting which two files 
to correlate, you can choose which type of view to correlate (waveform 
or spectrogram) along with other parameters and options as well.

Peak correlation values can be important when comparing spectrograms; 
however, it is important to note that there are serious limitations to corre‐
lation comparisons.  Spectrogram correlation is not a tool for generalized 
ʺpattern recognitionʺ and it is important to remember that the measured 
similarities are simple and narrowly defined and may not be relevant in a 
given context.

The timing of a peak correlation value from a waveform correlation plot is 
often useful as well.  It can determine the time offset at which two inputs 
(possibly from the same source signal) most closely match each other.  
Usually, waveform correlations are less useful than spectrogram correla‐
tions for assessing ʺsimilarityʺ between signals in an intuitive way.  This is 
partly because (unlike spectrogram correlations) waveform correlations 
are sensitive to phase differences in inputs that our auditory system does 
not detect.

Canary users will find much of the correlation functionality similar, 
although there are a few added features.

Band Pass Filter Choosing to add a Band pass filter is helpful for signals containing noise.  
Checking the filter box allows you to enter a lower and upper frequency 
limit that will filter the data before it is correlated.  
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In most applications, filtering is advisable for both waveform and spectro‐
gram correlations. By selecting a frequency band corresponding to the rel‐
evant signal(s), you reduce the effect of any other noise or signals on the 
correlation values.  

The effect of filtering on the correlation function (for both waveforms and 
spectrograms) depends very much on the particular signals being corre‐
lated. If neither file contains much energy outside the frequency band 
occupied by the signals, filtered correlations may not differ much from 
unfiltered correlations. If there is a significant amount of energy outside 
the frequency band of interest, the difference between the filtered and 
unfiltered correlations can be much larger. Also, it is important to note 
that filtering may either raise or lower correlation values, depending on 
the particular signals being correlated.

Normalization If Normalize is checked, the sum of the products of the data values from 
the two signals is divided by the square root of the product of the sums of 
values from the two signals, as indicated in Formula 9.1 and Formula 9.2. 
The units in the numerator and denominator cancel and the correlation 
value is scaled to a dimensionless value.  For spectrograms, which contain 
only non‐negative amplitude values, the normalized correlation value is 
always between 0 and 1. For waveforms, which can contain positive, nega‐
tive, and zero values, the normalized correlation varies between ‐1 and 1.

If Normalize is left unchecked, the correlation is calculated as the sum of 
the products of the data values from the two signals (i.e. just the numera‐
tor of Formula 9.1 and Formula 9.2.) A non‐normalized correlation is 
given in arbitrary units.

Normalizing a correlation will compare the overall 2‐dimensional shape of 
signals but will ignore any amplitude differences. Examples of normalized 
and non‐normalized correlations, and how the overall amplitude level 
affects the correlation values, can be seen in Figure 9.4. Unless your appli‐
cation requires that similarity measurements incorporate information 
about the absolute amplitude levels of the signals, you should most likely 
leave the Normalize option checked.
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Figure 9.4 Normalizing a correlation

Figure 9.4. Comparison of normalized and non-normalized correla-
tions. (a) Waveform of a portion of song from a Chestnut Sided Warbler. 
(b) The same waveform amplified by a factor of 2. (c) Normalized corre-
lation between (a) and (b). This correlation is identical to the correlation 
between (a) and itself. (d) Non-normalized correlation between (a) and 
itself. (e) Non-normalized correlation between (a) and (b). Notice the 
differences in correlation value amplitudes among the plots.

Biased/Unbiased By default, a biased normalization is performed during correlations.  How‐
ever, you can choose to perform an unbiased normalization simply by check‐
ing the Unbiased box.  The expected value of an unbiased normalization 
equals the quantity it estimates; however, this sometimes leads to large 
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variance in endpoints because only a few data points are used.  To avoid 
large variations at correlation endpoints, do not check the Unbiased box.

Spectrogram correlation

Often, the only point of interest in a spectrogram correlation plot is the 
maximum value of the correlation function. The peak correlation value 
can provide a quantitative measure of one type of similarity between spec‐
trograms.

Figure 9.5 Spectrogram Correlation

Figure 9.5. The two spectrograms shown were produced in succession 
during the song of a Chestnut Sided Warbler. Above in green, you can 
see the correlation between the two spectrograms. The entire correla-
tion graph is selected using Edit > Select All, and in the selection table, 
the peak correlation measurement of 0.813 is included.  Note that the 
peak correlation and peak lag are shown on the axes and by the 
magenta lines on the correlation plot, in addition to being shown in the 
selection table in their measurement columns.  The spectrograms are 
zoomed in frequency to show the detail.
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While the peak value of a spectrogram correlation function can provide an 
objective, well‐defined, repeatable, and comparable measure of the simi‐
larity of two spectrograms, it is NOT a tool for generalized “pattern recog‐
nition”. The “similarity” that is measured is simple and narrowly defined, 
and may or may not be appropriate to the research question being asked. 
The usefulness of spectrogram correlations as a measure of similarity thus 
depends very much on the specific context in which they are being used. 
The best way to develop a feel for how to interpret spectrogram correla‐
tions is to experiment with correlating a variety of spectrograms.

Figure 9.6 High vs Low Peak Correlation values

Figure 9.6. Two correlation windows, one showing two sounds with a 
low peak correlation value (left), and the other showing two sounds with 
a high peak correlation value (right).  Note that although the signals on 
the left appear to be similar, their high energy components are offset in 
frequency around the 4314 Hz line, marked by the magenta frequency 
position marker in the view.  Raven does not do any frequency shifting 
when it performs spectrogram correlations.  The peak correlation value 
on the left is 9.85 milli-units, whereas the peak on the right is 0.463 
units, or 463 milli-units.  Always be sure to check the units on the y-axis 
of the correlation view.

When Raven displays a correlation plot, it allows you to scroll the time 
position of the view to see how the two parent signals line up at different 
points in the correlation plot.  The default view when a correlation plot is 
initially shown is to show the lag at the peak correlation value, and to have 
the parent signals lined up at their peak correlation.  Moving the time 
scroll bar in the view allows you to see how the parent signals line up at 
Raven Pro 1.3 User’s Manual 193



Chapter 9:  Correlation
other correlation values, as shown in Figure 9.7 for spectrogram correla‐
tion.  The same type of time scrolling can be done with a waveform corre‐
lation.

Figure 9.7

Figure 9.7.  Three correlation windows of the same correlation plot 
scrolled to three different time positions.  The first shows a lesser peak 
to the left of the highest peak, the second shows the main peak, or peak 
lag, the time position at which the signals are most highly correlated, 
and the third shows a lesser peak to the right of the highest peak.  
Observe how in both the first and the third, two of the three calls in each 
signal are aligned, but that the correlation value is much higher when all 
three are aligned in time.

Scale of
spectrogram power

values

Raven can compute spectrograms using either the logarithmic power val‐
ues from the spectrogram, in units of decibels, or using the linear power 
values, in units of squared amplitude units.  Linear power values are the 
traditional method used to compute spectrogram correlations and provide 
a good spread between spectrograms that look similar and those that look 
different.  Because the logarithmic scale compresses the range in which 
power values exist, the corresponding correlation plots also tend to be 
more concentrated with higher peaks, which can lead users to think that 
signals are similar when they are really dissimilar.  Figure 9.8 shows two 
normalized spectrogram correlation plots using linear and logarithmic 
power values.  The peak correlation values are marked on the y‐axis by the 
horizontal magenta line.  The spectrograms are shifted in time to show the 
best alignment of the images, as indicated by the peak correlation lag, 
which is the vertical magenta line.
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Figure 9.8

Figure 9.8. A comparison between a correlation using linear power val-
ues (on the left) and the same correlation using logarithmic power val-
ues (on the right). 

Spectrogram
correlation

parameters

You can configure the view and results of spectrogram correlations (see 
Figure 9.9) as you would adjust display parameters for typical spectro‐
grams. In general, increasing the overlap will decrease the hop size and 
increase the number of frames in the spectrogram for a more detailed cor‐
relation. Decreasing the overlap will oppositely affect the hop size and 
number of frames. Increasing the window size will result in more fre‐
quency bins in the FFT and a more detailed analysis of frequency, but at 
the cost of time resolution. Decreasing the window size will oppositely 
affect the frequency bins and time resolution. For more information on 
configuring spectrogram display parameters, see Appendix B, “A Biolo‐
gist’s Introduction to Spectrum Analysis”.
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Figure 9.9 Spectrogram correlation options

Figure 9.9. The spectrogram configuration dialog box. You can adjust 
the view of spectrogram correlations by changing these parameters.

Waveform correlations

When working with waveforms, one might be interested in the time at 
which the peak correlation value occurs. To determine the position of a 
sound in space, for example, an array of microphones in a known geome‐
try can be used to record onto separate but synchronized recording tracks. 
The time offsets of the correlation peaks between signals on these synchro‐
nized recordings then indicate the delays between the arrival times of the 
sound at different microphones. These time delays can then be used to cal‐
culate the location of the sound source relative to the positions of the 
microphones, based on known information (including the speed of sound 
and the microphone array geometry).
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Figure 9.10 Waveform Correlation

Figure 9.10. Waveform correlation between song syllables simulta-
neously recorded at two different microphones.  (b) Waveform from 
microphone 1. (c) Waveform from microphone 2. (a) The correlation 
between (b) and (c). The time delay of -.026 s indicates that the bird 
was 8.9 m closer to microphone 1 than to microphone 2 (assuming a 
speed of sound of 344 m/s).

In most applications, waveform correlations are less useful than spectro‐
gram correlations for assessing the degree of “similarity” between signals 
in a way that is intuitively satisfying, in part because (unlike spectrogram 
correlations) they are sensitive to phase differences that our auditory sys‐
tem does not detect.

Complex envelope If you are performing a correlation between two waveforms, you can 
check the Complex envelope box which will display the complex envelope 
of the correlation function, as opposed to the correlation function itself. A 
complex envelope varies between 0 and 1. The relationship between the 
complex envelope and the correlation function itself is illustrated in Figure 
9.11.
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Figure 9.11 Complex envelope

Figure 9.11. (a) The waveform correlation of two sounds. (b) The com-
plex envelope of the correlation function in (a). (c) The complex enve-
lope function superimposed over the correlation function. For clarity of 
illustration, the complex envelope (in red) is shifted slightly upward in 
the figure from the raw correlation plot (in green) and the horizontal axis 
has been zoomed in to show more detail.
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Correlation functions always contain high‐frequency oscillations, which 
are related to the frequencies present in the signals being correlated. If the 
signals are approximately sinusoidal (i.e. at any moment, most of the 
energy in each signal is concentrated at a single frequency, as in the fre‐
quency‐modulated whistles common in bird song), their correlation func‐
tion will itself be close to an amplitude modulated sinusoid. In this case, 
the complex envelope is roughly equivalent to the amplitude envelope of 
the absolute value of the correlation function. If the signals being corre‐
lated are spectrally complex (with energy distributed over many frequen‐
cies, as in human speech), their correlation function contains high‐
frequency oscillations that are generally not sinusoidal.

Taking the complex envelope removes much of the high‐frequency oscilla‐
tion in a correlation function, which can make it easier to visually identify 
the peak of a waveform correlation. Since the qualitative relationship 
between the appearance of the complex envelope and the raw correlation 
plot depends somewhat on the signals being correlated, you should exper‐
iment with the type of signals that you work with in order to get a feel for 
the relationship between the two types of plot.

Batch correlation

Ravenʹs batch correlator provides a mechanism for automatically perform‐
ing the same correlation operation on an arbitrarily large number of files 
and saving the results. For example, a batch spectrogram correlation lets 
you perform correlations of many files at a time, using a set of spectro‐
gram parameters that you specify only once. The batch correlation process 
runs in the foreground so you have to wait for it to finish before you can 
perform any more analysis within Raven, but you can use other applica‐
tions while the batch correlator is running.

To run the batch correlator, choose Tools > Batch Correlator... from the 
menu bar. This will display the batch correlation configuration dialog Fig‐
ure 9.12.
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Figure 9.12batch correlation configuration dialog

Figure 9.12. The batch correlation configuration dialog.

Input and output For Raven’s batch correlator, you must specify which files are to be used as 
input and where the output file should be saved. The input files must all 
be stored in the same folder, and the output file can be saved in a folder 
(which can be different from the input folder).

For batch correlation, there are two sets of file inputs (see Figure 9.12). 
Each set can consist of a file or folder. If you choose a folder, then all files 
within that folder will be used as input to the batch correlation process.

After you select the input files or folders, you must select the output 
options (see Figure 9.12). The default settings are to save the output to a 
text file and to view the results within the Raven window. One of these 
options must be chosen for the correlator to run. You can change the out‐
put folder and name by using the Browse... button, or just enter the name 
of the output file by typing in the text box.
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All other options within the batch correlation configuration dialog are 
identical to those in the correlation configuration dialog box, as discussed 
earlier in this chapter.

Running the
correlator

When you click the OK button, Raven starts calculating the correlations 
and displays a status window, titled “Spectrogram Correlation” or “Wave‐
form Correlation” depending on your selected option, as shown in Figure 
9.13. The progress bar in the status window shows the progress of the 
entire batch process. Clicking the Cancel button stops the batch correla‐
tion.

Figure 9.13 spectrogram correlation window

Figure 9.13. The correlation status window (for a batch spectrogram 
correlation, in this case).

The batch correlator computes correlations for each possible pair of files in 
the two input sets. When all of the correlations have been calculated, 
Raven displays a window containing the correlation table (Figure 9.14). 
The title of the window specifies whether the correlation was of waveform 
or spectrogram views. The correlation table contains a peak correlation 
value (in correlation units) for each pair of files. Clicking on the Lags radio 
button will change the view to show the lag values (in seconds), or time 
offsets at which the peak correlation values occur.

The columns of the correlation table may be resized by positioning the 
mouse pointer on the line between the column headings, and then drag‐
ging the line to a new position. The window itself may be resized in order 
to show more columns, or the horizontal scroll bar at the bottom of the 
window may be used to scroll to different columns in the table. If there are 
enough rows in the table such that they cannot all be seen, then a vertical 
scrollbar is provided to allow you to scroll to other rows.
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Figure 9.14 Batch Correlation Table

Figure 9.14. A batch correlation table showing peak correlation values 
for each file pair using linear power values in the correlations.

To view the correlation function of a single correlation, just double‐click 
on any peak or lag value in the table. Raven will launch a new correlation 
window showing the correlation function in one view along with the two 
files that were correlated, each in their own views (see Figure 9.15). This 
window is identical to the one that would be shown if a correlation had 
been run on the individual files.
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Figure 9.15 single correlation view from table

Figure 9.15. By clicking on a single cell in the batch correlation table 
(top), Raven displays the individual correlation view between the files in 
a new sound window. Note that the frequency position marker in the 
correlation view marks the peak correlation value, and the time position 
marker marks the peak lag value.  You can also add these measure-
ments to the selection table, as shown in the figure.

Correlator output can also be saved to a tab‐delimited text file, where the 
correlation peak table and correlation lag table are displayed one after the 
other (see Figure 9.16). You can specify the output file name on the initial 
correlator dialog.
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Figure 9.16 correlation table output to txt file

Figure 9.16. A correlation table saved as a file, and subsequently 
opened using Microsoft Excel.

If you are correlating the contents of a folder with itself, the peak correla‐
tion value for X*Y and Y*X will be in the same table, but one lag will have 
a positive value and the other a negative value, as shown in the lag section 
of the spreadsheet of Figure 9.16.

For multi‐channel files correlated in the batch correlator, each channel is 
displayed as its own row or column (Figure 9.17).  If the same files were 
correlated using Tools > Correlator, the resulting batch correlation table 
would not be created, and all channel correlations would be in their own 
windows.  For ease of viewing the results, you should use the batch corre‐
lator when dealing with multi‐channel files.

Figure 9.17 multi‐channel correlation table

Figure 9.17. A correlation table with results from a multi-channel file 
correlation. In this correlation, the input files are both the same (Bird 
array 4-channel.aif), so each channel of the file is correlated with itself 
and with the other channels.

If a single file is batch correlated with a folder of files, the resulting table 
will either be a single row (if the file is specified as input 1) or a single col‐
umn (if the file is specified as input 2). See Figure 9.18 for an example.
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Figure 9.18 file and folder correlation

Figure 9.18. Correlations between one file and a folder of files. a) the 
file was specified as input 1 and the folder as input 2. b) the folder was 
specified as input 1 and the file as input 2.

Correlator example

Open sound file
and selection table

Shipped with Raven, you will find an audio file (located in the Examples 
folder) named BlackCappedVireo.aif and a text file containing selections 
(located in the Selections folder) named BlackCappedVireo.selections.txt. 
Opening the sound file and then opening the selection table should give 
you the following image (Figure 9.19).
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Figure 9.19 Black‐capped Vireo with selections

Figure 9.19. Recording of a Black-capped Vireo, showing 44 selections 
within the recording (achieved by opening the BlackCappedVireo.aif file 
along with the BlackCappedVireo.selections.txt file).

Save selections into
a new folder

Next, choose File > Save All Selections As... from the menu and click on 
the File Names tab. In the Directory field, type “/BCV” after the default 
“Selections” entry, creating a new folder named BCV (see Figure 9.20). 
Also, adjust the Sound File entry to read “BCV<ii>.aif (this will name the 
selection files BCV01.aif, BCV02.aif, BCV03.aif and so on.) Finally, clicking 
the Save button will complete the process, saving the named selections 
into the newly created folder.
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Figure 9.20 Save All Seelctions

Figure 9.20. The Save All Selections As dialog box with fields com-
pleted as described in “Save selections into a new folder” on page 206.

Run batch
spectrogram

correlation

After saving all of the selections to the BCV folder, you can now run a 
batch correlation of all the files in the folder against each other. (Note that 
you could also choose to correlate a single file against all the files in the  
folder. However, this example uses the BCV folder as both input 1 and 
input 2.)

To perform the batch correlation, choose Tools > Batch Correlator... which 
will display the appropriate dialog box. For both input files, choose 
Browse... and select the new folder you created, BCV (it should be in the 
Selections folder in your Raven directory). Next, adjust the name of the 
output text file to read “BlackCappedVireo.specCorr.txt” and make sure 
that spectrogram (under the correlate section) and normalize (under the 
options section) are selected. After veryifying your inputs with Figure 
9.21, select OK to begin the correlation.
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Figure 9.21 Batch Spectrogram correlation dialog

Figure 9.21. The Batch Correlation Configuration dialog with informa-
tion filled in to correlate the selections contained in the BCV folder 
against themselves.

The correlation
table

After running the correlation, you should get a 44 x 44 table of correlation 
values (Figure 9.22) where each cell in the table represents the correlation 
of one of the files against another of the files.
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Figure 9.22 correlation table

Figure 9.22. A portion of the correlation table from the previous exam-
ple (correlating all files in BCV against each other).

You can view individual correlation functions by double‐clicking in any 
cell showing a peak value (or lag value). Double‐clicking the boxes for 
BCV14 * BCV01 and for BCV17 * BCV03 displays two sound windows. 
Each shows the correlation function view (top) as well as the two spectro‐
gram views for the sounds that were correlated.

As shown in Figure 9.23, the correlation peak values and peak lags are 
marked with the magenta frequency position marker and time position 
marker, respectively.  In each window, select the entire correlation func‐
tion, and then display the selection table.  You can format the table to 
include only the measurements for Peak Correlation and Peak Lag. For a 
refresher on working with selection tables, see “Selection Tables” in Chap‐
ter 6 (page 135).

After doing this for both sound windows, you should have something 
similar to Figure 9.23. This example demonstrates the difference between 
correlation functions with high and low peak correlation values. In this 
example, the correlation values seem to correspond with the similarity 
between the calls being compared. While this is an important example, it is 
essential to remember that not all results will be this evident; not all corre‐
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lation values will correspond to visual similarity/dissimilarity of spectro‐
grams.

Figure 9.23 high and low correlation values

Figure 9.23. a) Linear power spectrogram correlation (top view) of 
BCV14 (middle view) with a low peak correlation value of 0.00813 (see 
selection table at bottom of window).  b) Linear power spectrogram cor-
relation (top view) of BCV17 (middle view) with BCV03 (bottom view) 
with a high peak correlation value of 0.37982 (shown in selection table 
at bottom of window).
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About this chapter

When users work with large datasets, they often seek to first identify all 
sounds of a particular type, then they make measurements on the selected 
sounds and perhaps associate annotations with the sounds to classify 
them as to type or source. The process of manually browsing through 
hours, days, or months of recordings can be daunting.

An alternative to manually browsing through large datasets is to use auto‐
matic detection. Detection is the process of finding specific sounds of inter‐
est within recordings. Often, the signals of interest are short in duration 
compared to the overall recording. Detection can be a useful tool when 
compared to the alternative process of manually browsing days of record‐
ings in order to find small samples of interesting sounds.

Automatic detection software may be able to reduce the amount of time 
that it takes to analyze a recording. Whereas detection is the process of 
identifying these signals of interest, an individual detector is the mecha‐
nism in which a detection algorithm is implemented in order to detect spe‐
cific signals of interest. Users must be aware of trade‐offs that they will 
need to make before deciding if detection is the correct approach for their 
analysis.

In this chapter, you will learn about:

•the three modes of Raven detectors.
•trade‐offs involved with using detectors.
•running an interactive detector.
•running a detector in full mode and while recording.
•saving detected selections
•instructions for detectors provided with Raven.

The three run-modes of Raven detectors

In order to shorten the amount of time that users take to analyze their 
recorded datasets, Raven has a detector infrastructure built around 
Raven’s extensible software architecture. Raven provides an Application 
Programming Interface (API) as well as a reference implementation of a 
specific detector meant to both get users started with detection and get 
developers on the road to creating their own detectors.
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Detectors in Raven can be run in one of the following three modes:

1. Interactive detection: Within a short recording or a set of pages of a 
long recording, users can test several sets of parameters in order to see 
how a detector will perform. Interactive detection is available in Raven 
on the View menu and in the context menus of applicable sound views. 
The user sets up the input parameters and then runs the detector. The 
detector will then search through the paged area of the sound file to 
find areas that match the parameters defined by the detector. The detec‐
tor will then create selections from these matches and display the selec‐
tions in the opened page display. The user is able to run multiple 
detectors on the page, and each detector will display color‐coded 
results for easy discrimination. Altering the parameters of a detector 
and then rerunning it in interactive mode will allow the user to opti‐
mize the detector parameters.

2. Full detection: Once specific parameters are chosen that work for short 
sections of a recording, Raven can run a full detection process on the 
entire recording. Full detection is useful for bulk processing of large 
datasets. Full detection is available in Raven on the Tools menu and 
from the “Run Full” button in the Interactive detector panel on the 
Detection Tab in the Raven side panel (see Figure 10.1). The detector is 
run against the entire recording even if only a single page is shown in 
the window.

3. Real‐time detection and the recorder: Within the recorder window, 
Raven can run a real‐time detector that can find signals of interest as 
they are recorded. This can be a useful way of detecting events as they 
occur.  These events can then be reviewed further in the recorded file 
sequence.  The real‐time detector can also be used to avoid recording to 
a file sequence by saving the detected signals as individual sound clip 
files for later review. Note that for those users who are not fully familiar 
with Raven detection processing, we recommend that you record to file 
sequences so that the entire dataset is available for review in case the 
detector does not perform as you intended. You can run real‐time 
detection at the same time that you save to file‐sequences, or you can 
post‐process the file sequence by running a detector on the full 
sequence. Real‐time detection is available in Raven by starting an inter‐
active detector in the recorder window before starting the recorder. 
(See Figure 10.2.)
212 Raven Pro 1.3 User’s Manual



Chapter 10:  Detection
Figure 10.1 Run Full

Figure 10.1. The Run Full button in the detector tab on the side panel.
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Figure 10.2 Detector during recording

Figure 10.2. Real-time detection in progress.

For users For users, Raven comes with sample detectors that are described in more 
detail in “How to run a detector: Full mode and within a recorder” on 
page 221. These detectors run on a specific view of a sound. If the correct 
view is not opened, Raven will prompt you to open the required view 
prior to running the detector. Some Raven detectors have the ability to 
save presets from the user interface while others have presets that can be 
set by opening a separate file and setting parameters.

For developers Raven comes with the detector infrastructure and API capable of support‐
ing detectors written in either Java or Python (running in the Jython inter‐
preter). Java detectors can use JNI or Java Builder for MATLAB to include 
algorithms written in other languages. The Python detector Cornell.Band‐
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LimitedEnergy is supplied as an example for developers to use in the cre‐
ation of additional detectors.

Different detectors can be associated with different views. In a spectro‐
gram view, the energy detector detects changes in energy in a given fre‐
quency band. In a waveform view, the amplitude detector detects changes 
in amplitude of the waveform. For more information on the detector infra‐
structure and API, visit http://RavenSound Software.com/

Installing third-party
detectors

Third‐party detectors can be installed by saving the files in a specific loca‐
tion. More information on creating, installing, and sharing detectors will 
be provided on our website at http://RavenSoundSoftware.com/.

Tradeoffs involved with using detectors

Detectors allow a user to search for repetitions of a set of user‐defined sig‐
nal characteristics such as a particular call or note produced by an animal. 
Detectors have the advantage of being able to search and select for a given 
signal within large datasets, perhaps months’ worth of data, in a relatively 
short period of time compared to what it would take a human operator to 
complete the same task. It should be noted, however, that detectors are not 
necessarily able to capture 100% of the target signals and this should be 
taken into account when deciding whether or how best to use a detector. 
The accuracy of your detections may be diminished by any or all of the fol‐
lowing factors:

•High background noise
•Low signal strength
•High signal complexity
•Clutter.

If your signal contains significant background noise, is not very loud, is 
especially complex, or if there are other sources of noise that would be rel‐
atively indistinguishable to the detector with a given set of parameters, the 
detection accuracy could be compromised.

Results of detecting
in less-than-perfect

recordings

Two specific results could occur if your sound recordings are imperfect:

1. You may miss some of the signals that were present in the recording (a 
false negative, or FN).

2. You may have detections which are not part of the set of signals for 
which you were searching (a false positive, or FP).

One way to quantify your error rate is to take a sub‐sample of the data set 
and manually browse for the signals you want. You can then run the 
desired detector on the same data set. A comparison of the number of 
selections from hand‐browsing with the number of detections can then be 
made. You will then have some idea of the accuracy that you will achieve 
for the whole dataset.
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In addition to comparing a hand‐browsed dataset with a detector run, you 
can also compare one detector against another or even compare different 
parameter settings within the same detector. Comparing a sub‐sample of 
your dataset can therefore allow you to make a choice between using a 
detector and hand‐browsing, and will help you decide which detector, 
with what parameters, is the best to use.

Receiver operating
characteristic

The Receiver Operating Characteristic (ROC) curve refers to the percent‐
age of true positives (TPs) captured and the percentage of FPs captured.

Figure 10.3 ROC curve

Figure 10.3. ROC curve showing the difference between a ‘good’ 
detector and a ‘bad’ detector.

The ROC curve in Figure 10.3 quantifies the trade‐off between the percent‐
age of TP captured and the percentage of FP captured. It shows that if we 
need to capture at least 70% of the TP, then using the ‘good’ detector, we 
would expect to also detect 20% of the FP. Using the ‘bad’ detector would 
select 70% of the FP.

The particular method you choose should be determined by your objec‐
tives and the amount of time and effort you are prepared to put into the 
task. Bear in mind that the most important thing to know is what type of 
results you expect. Then, you can adjust the detector parameters accord‐
ingly before beginning the detection process.
216 Raven Pro 1.3 User’s Manual



Chapter 10:  Detection
Changing a
detector parameter

A good first step toward efficiently running a detector is to optimize the 
detector’s parameters with the interactive detection mode. The following 
graph shows the effect of changing a detector parameter on the proportion 
of desired signals captured (TP) and the number of missed signals (FN) as 
well as the number of incorrect signals captured (FP).

Figure 10.4 Changing a detector parameter

Figure 10.4. (a) The signal-to-noise ratio is high enough that all of the 
TP can be captured without capturing any of the true negatives (TN). (b) 
The signal-to-noise ratio is lower so that it becomes impossible to cap-
ture all the TP without either capturing some FP and/or rejecting some 
of the FN. Changing the parameter setting alters the ratios of TN:FP 
and FN:TP. (c) To capture all the TP, you will also capture most of the 
FP. Because of the high number of FP that would have to be “weeded 
out”, this is a time-consuming task. (d) By not capturing any TN, you will 
also be rejecting the majority of the FN.
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How to run a detector: Interactive detection

Running a detector
on an existing

sound file

First, open the sound file, making sure that the appropriate view is active 
in the window. Next, open the detector by selecting View > Interactive 
Detectors... > [Detector Name] from the toolbar, or by opening the view’s 
context menu and selecting Interactive Detectors... > [Detector Name]..

Once a detector is selected, the configuration dialog will be displayed, 
allowing the user to set certain detector parameters. After setting the 
parameters, and clicking the OK button, the detections (if there are any) 
should appear in the sound window. Figure 10.5 shows the Amplitude 
Detector configuration dialog.

Figure 10.5 Amplitude Detector configuration dialog

Figure 10.5. The configuration dialog for the Amplitude Detector. After 
setting the detection parameters, choosing OK will run the detector.

Displaying detector
information

Once you’ve run the detector, basic information can be found by selecting 
the Detector tab in the side panel.  Also, if you make the selection table 
view of the current sound visible, the name of the active detector will 
appear on a new tab. The tab will be color‐coordinated with the detector’s 
selection boxes in the sound window and will display detections (selec‐
tions created by the detector) in the selection table. See Figure 10.6 for an 
example.

If the recording is long, choose to open it one page at a time 
with a page size that is large enough to capture one or more 
of the signals of interest, but not so large that you run into 
memory issues. For further information on memory manage‐
ment, go to “The Memory Manager” in Chapter 11 (page 
261).
218 Raven Pro 1.3 User’s Manual



Chapter 10:  Detection
Figure 10.6 Detector tab

Figure 10.6. The detector tab, activated in the side panel, shows infor-
mation about the current detector.  Also, detection information is shown 
on its own tab in the sound window’s selection table.

You can add and remove measurements from the detection selection table 
in the same way as you would with the default selection table. You can 
also rename the tab by opening the tab’s context menu and selecting 
Rename Table. See “Selection Tables” in Chapter 6 (page 135) for more 
information.. 

After running a detector, the detector selections tab will 
become the current active tab. This means that if you make a 
manual selection in the sound window, the data will be 
added to the detector tab and not the default selections tab. 
To add selections to the default tab, you must make it the 
active tab by clicking on it before making selections.
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Running an
interactive detector

in a paged sound

To test a detector on a long sound, first open the sound in a paged sound 
window, then configure an interactive detector as described previously. 
This will run the detector on the current page. To see the results on differ‐
ent pages in the sound recording, use the page scroll bar at the top of the 
screen to advance one page in the recording. The detector will then create 
selections for that page based on the input detection parameters.

Once you are satisfied with the results of a detector, you can choose to run 
it on an entire recording. To do this, you can press the Run Full button in 
the corresponding box on the detector tab in the side panel.  

Detection options If you display the contents of the detector tab in the side panel, you will 
see some boxes containing basic information about the detector(s) cur‐
rently open. These boxes also give you the ability to access or change some 
other detector information.

Configure: This button allows you to change the detector parameters via 
the standard configure dialog box. Once the parameters are changed and 
the OK button is pressed, the detector will be run again on the currently 
displayed page or the entire sound if it is all in memory.  Note that recon‐
figuring the detector will cause all current selections to be deleted.

Run Full: Pressing this button causes Raven to run the detector, with the 
current set of parameters, on the entire sound recording. The results are 
stored in the selection table associated with this detector. While the detec‐
tion is running, the Configure Button will be grayed out. When the detec‐
tion is completed, the Configure Button will become accessible again.

Detector Active: Checking this item box means that the detector will be 
run on each page as it is opened. Unchecking the box means that the detec‐
tor will not run on subsequent pages as you display th

Clear Selections: Interactive detectors are one way to test a set of parame‐
ters.  If testing parameters is your only goal, you may not want to have all 
selections from every page saved.  Checking the Clear Selections box 
forces Raven to clear the selection table for that detector each time it is run 
on a new page.  Note that reconfiguring the detector will clear all selec‐
tions, even if the Clear Selections is unchecked..

Running multiple
interactive
detectors

You can configure multiple interactive detectors and run them simulta‐
neously in Raven. Each will be given its own tab in the selection table with 
a corresponding color for the selections in the sound window. See Figure 
10.7.

The Run Full button, Detector Active box, and Clear Selec‐
tions box are only available when a detector is configured in a 
paged sound. Otherwise, you will not be able to select these 
options.
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Figure 10.7 Multiple detectors

Figure 10.7. Two detectors that have been run on the same spectro-
gram view. The first detector (blue selection table tab and blue selec-
tions) is in a higher frequency range than the second detector (pink tab 
and selections).

How to run a detector: Full mode and within a recorder

Full detection mode Once you are satisfied with the results of a detector, you can choose to run 
it on an entire recording. To do this, you can press the Run Full button in 
the corresponding box on the detector tab in the side panel. Or, you can 
use the Tools > Detector menu to start running a detector on an entire file.

An alternative is to bypass interactive mode and run the detector on the 
full sound initially. Use the Tools > Detector menu to choose the detector 
you want. The dialog in Figure 10.8 will appear, allowing you to choose an 
existing file or open a new file (Raven will open any sound that is not 
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already open). This mode of detection can be used to post‐process record‐
ings; by first recording to a file sequence, you can then run a detector on 
the entire sequence at once.

Figure 10.8 detection input dialog

Figure 10.8. The detection input dialog. This allows you to choose the 
full sound on which you’d like to run the detector.

Running a detector
within a recorder

You can also run a detector within a recorder. To do this, first open a 
recorder window, and then configure an interactive detector that you 
would like to run. Next, start the recorder and watch as the detector finds 
signals according to the configured parameters, and creates corresponding 
selections in the recording.

There are three ways to process detections from a recording:

1. Post‐processing: This process involves running a recorder to a file 
sequence, and then running a full detector on the file sequence after the 
recorder has finished running. For this, you must record to a file 
sequence completely, open the file sequence in a sound window, and 
then run a detector on the file.

2. Real‐time processing while saving the entire recording: In this case, 
you will save the entire recording but will run the detector while the 
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recording is running. To set up this type of recording session, run the 
recorder to record to a file sequence, making sure to record to file (red 
button). This will ensure that the times in the selection table correspond 
to the times in the file sequence. In addition to saving the entire file 
sequence, you can also save individual sound clips as the recorder is 
running. Or, since the entire session will be recorded, you can also save 
individual sound clips after the recorder is finished by using the File > 
Save All Selections As... menu item.

3. Real‐time processing without saving the entire recording: Here, you 
set the recorder to record to memory and you also configure the 
recorder to save any selections as sound clips. With this method, you 
are not saving the entire recording; you are only saving those selections 
that the detector identifies. Note that using this method will not allow 
any post‐processing on non‐selected data, so you should only use this 
technique when you are confident that the detector is working as antic‐
ipated so you don’t lose data.

Example  of running
a detector within a

recorder

This example shows, step by step, how to run a recorder with a configured 
detector that saves clips to files, and then how to open and browse the 
results.

First, configure a recorder to record from your selected audio input 
device.  Configure it to record to memory and to save clips to files.

Figure 10.9

Figure 10.9.  Configuring a recorder to record to memory and save clip 
files to disk.  Note that the names of the files are saved to a list file.

Next, configure a detector to find the signals that are of interest to you.  
(For more information on how to do this, see the next section, “Instruc‐
tions for detectors provided with Raven” on page 228.)  In this example, 
the target signal is a short whistle.
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Figure 10.10

Figure 10.10.  Configuring a detector to find short whistles.
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Figure 10.11

Figure 10.11.  A configured recorder with a selection table created for 
the detector.

Turn on the recorder and watch as detections are made and clip files are 
saved to disk.
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Figure 10.12

Figure 10.12.  A running detector saving detected clips to files.

You can then open the list of clip files to view them as a file sequence.

Figure 10.13

Figure 10.13.  Selecting a clip list file to open.
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Figure 10.14

Figure 10.14.  Choosing to open the list as a file sequence as opposed 
to opening each sound in a separate window.
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Figure 10.15

Figure 10.15.  The clip files, opened in a file sequence.

Saving detected selections

Once you are satisfied with the selections created by your detector, you 
can save your selections as a text file by selecting File > Save Selection 
Table As... or File > Save Selection Table. In the Save dialog, you must 
provide a name and path for the text file to be saved. The default folder is 
the Selections folder within the Raven folder.

To save sound clips of the selections, you must select File > Save All Selec-
tions As... or you can use the shortcut <Ctrl-Shift-A>.

In addition to saving the detections, you may wish to save the detector set‐
tings as well, in case you wish to run the detector again on the same or dif‐
ferent data.  Some Raven detectors provide a preset menu to allow you to 
save parameters. If a preset menu is not provided, then you should record 
these settings on your own.

Instructions for detectors provided with Raven

Band Limited
Energy Detector

(Energy Detector)

The Energy Detector supplied in Raven is a time‐frequency energy detec‐
tor. It calculates the background noise of a signal and uses this to find sec‐
tions of signal that exceed a user‐specified signal‐to‐noise ratio threshold 
in a specific frequency band, during a specific time. This detector runs on a 
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spectrogram view only. In order to run it, the associated view must be 
open or Raven will prompt you to open the required view before running 
the detector.

Since this detector makes a rolling estimate of the background noise in the 
band of interest, it is more useful when there is more uniform, non‐
sourced, or “white” noise, because the estimate can provide an adaptive 
threshold from which real signal can be estimated.  In more detail, the 
noise estimation process begins by summing up the energy in the band for 
each frame in the previous “block size” seconds.  Then, it takes this list of 
energies and sorts them before picking one according to the “percentile” 
paramater.  For example, a “30” in the “noise estimate percentile” parame‐
ter will take the energy value 3/10th of the ways up from the bottom of the 
list.  Likewise, a value of “50” would result in the median value being cho‐
sen.  This number is then taken to be the noise estimate for that block, at 
which time the “block” is advanced according to the hop size and the pro‐
cess is repeated.  So, if the noise block size is 5 seconds and the hop size is 
1 second, the next noise estimate will re‐use the last 4 seconds, plus one 
more.  This gives a smooth “rolling average”.

A few consequences of this procedure are that a broad band setting will 
result in a very small range of energy values for a block, resulting in a very 
small difference between the noise estimate and the “highest” energies.  
Also, to make a seletion, the in‐band energy needs to exceed the noise esti‐
mate (by the SNR threshold amount) and then drop below it again accord‐
ing to the duration/separation parameters.  So, a noise estimate that is too 
low can result in fewer selections, as can one that’s too high.  This makes 
the “percentile” number very important.

Figure 10.16 shows the configuration dialog while an explanation of each 
parameter is detailed in Table 10.1. 
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Figure 10.16 BLED configuration

Figure 10.16. The configuration dialog for running the Energy Detector 
in interactive detection mode.

Table 10.1. Parameter settings for the Energy Detector

Parameter Function Strict Setting Lenient Setting

Presets A list of predefined param‐
eter settings

N/A N/A

Intermediate Output Produces a diagnostic dis‐
play when selected

N/A N/A

Low Band Frequency 
(Hz/kHz)

Floor of Frequency Band Select frequen‐
cies as narrow 
as possible.

Select broader 
frequencies.
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To demonstrate the use of the Band Limited Energy Detector, we will walk 
through an example, demonstrating how to configure an effective set of 
detector parameters for the file BlackCappedVireo.aif.  Raven comes with 
these parameters saved as the BlackCappedVireo.energy preset.  Figure 
10.17 shows the Band Limited Energy Detector configuration dialog with 
this preset loaded.

High Band Frequency Ceiling of Frequency Band Select frequen‐
cies as narrow 
as possible.

Select broader 
frequencies.

Maximum Duration 
(sec/msec/samples)

Maximum duration over 
which signal could occur

Keep the dura‐
tion as short as 
possible.

Increase the 
duration.

Minimum Duration 
(sec/msec/samples)

Minimum duration over 
which signal could occur

Keep the dura‐
tion as long as 
possible.

Decrease the 
duration.

Minimum Separation 
(sec/msec/samples)

Minimum separation 
between signals

Keep the dura‐
tion as long as 
possible.

Decrease the 
duration.

Noise Block Size 
(sec/msec/samples)

Duration of noise block 
used to calculate the back‐
ground noise

Use a shorter 
duration.

Increase the 
duration, but 
not enough to 
include adja‐
cent signals.

Noise Hop Size (sec/
msec/samples)

Amount of time the noise 
block skips between back‐
ground noise calculations

? ?

Noise Percentile (%) The percentage of the 
ranked noise that is 
counted as background 
noise

Decrease. Increase.

Minimum Occupancy 
(coefficient)

Percentage of samples 
within a selection where 
the signal must exceed the 
background noise by a 
given amount

Increase. Decrease.

Event Threshold (dB) The level above back‐
ground noise that the sam‐
ple must exceed.

Increase. Decrease.

Table 10.1. Parameter settings for the Energy Detector

Parameter Function Strict Setting Lenient Setting
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Figure 10.17

Figure 10.17.  The Band Limited Energy Detector configuration dialog 
with the BlackCappedVireo.energy preset loaded.

Choosing the minimum and maximum frequencies is very straightfor‐
ward: choose an example of a typical event you wish to detect.  Make a 
selection which encompasses a significant fraction of the energy of this 
event, and read the Low Freq and High Freq measurements from the 
selection table.  In the case of the Black‐capped Vireo sound, the goal is to 
detect several different types of events in one detector run.  To achieve 
this, draw selections around each of the event types you wish to detect, 
and set the minimum frequency equal to the lowest Low Freq measure‐
ment obtained, and the maximum frequency equal to the highest High 
Freq measurement obtained.  See Figure 10.18.
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Figure 10.18

Figure 10.18.  Finding the minimum and maximum frequencies.  Note 
that the least Low Freq measurement is around 1500 Hz and the great-
est High Freq measurement is around 10000 Hz.  These correspond to 
the preset’s minimum and maximum frequency values.

To choose values for the minimum and maximum duration parameters, 
add the Delta Time measurement to your selection table.  Find the shortest 
duration event you wish to detect and draw a selection around it.  Read 
the Delta Time measurement from the selection table, and use this value 
for the minimum duration (for an example, see Figure 10.19).  To obtain 
the maximum duration parameter, repeat the procedure with the longest 
duration event you wish to detect.
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Figure 10.19

Figure 10.19.  Finding the minimum duration.  Note the minimum Delta 
Time measurement of 0.101 seconds.

To choose a value for the minimum separation parameter, find the two 
closest distinct events and draw a selection between them.  Read the Delta 
Time measurement from the selection table, and use this value for the 
minimum separation.
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Figure 10.20

Figure 10.20.  Finding the minimum separation.

Skip over the minimum occupancy and SNR threshold parameters for 
now, and set the Noise Power Estimation parameters.  Pick a block size 
that is longer than the maximum duration by at least a factor of 3, and 
longer if the events cluster together.  The goal is to have a long enough 
block size that the data being used for noise estimation is guaranteed to 
always include noise.  If you make the noice block too short, it may result 
in noise estimates based primarily on only signal, rather than signal and 
noise together.  In the BlackCappedVireo.energy preset, the block size is 
about three times the maximum duration.

The hop size parameter determines how much smoothing is performed in 
the noise estimation computation.  Choose a hop size value roughly 
between the maximum duration and the noise block size.  The Black‐
CappedVireo.energy preset has the hop size set to 0.499 seconds, slightly 
less than the maximum duration of 0.597 seconds.

An appropriate value for the noise percentile parameter depends on the 
characteristics of the noise and clutter in your data.  A higher percentile 
will result in a higher noise estimate.  For the BlackCappedVireo.energy 
preset, the default 20th percentile was used, and appears to give a reason‐
able noise estimate.  You may wish to play with higher and lower values to 
see which gives the best result for your data.

Once the Noise Power Estimation parameters have been determined, go 
back to the SNR threshold parameter.  For an approximation of this 
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parameter, you can measure the average power of a typical noise block. 
Figure 10.21 shows a typical detection and a typical noise block.  The dif‐
ference in average power is 10.5 dB.  The BlackCappedVireo.energy preset 
rounds this to 10 dB.

Note that the noise block in Figure 10.21 actually contains a large amount 
of signal.  This is why the SNR threshold as computed here is so low.  The 
actual SNR of the recording is much higher than 10 dB.

Figure 10.21

Figure 10.21.  Measuring the estimated signal-to-noise ratio.  Selection 
1 contains only signal.  Selection 2 represents a typical block of data 
used to estimate the noise power.

Accept the default minimum occupancy, and check the Return Occupancy 
checkbox.  Then run the detector.  Examine the detections and determine if 
the performance was satisfactory; if not, adjust the minimum occupancy 
downward and run the detector again.  Sorting the selection table by occu‐
pancy can serve as a guide to setting the minimum occupancy parameter.  
Note that the BlackCappedVireo.energy preset has a minimum occupancy 
of 40%, yet it yields detections with occupancies no lower than 72.97%.  
The preset’s minimum occupancy could have been set as high as 72% and 
returned the same results.

When citing use of Raven’s Band Limited Energy detector in scientific 
publications, please refer to it as follows:
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Mills, H. G. 2000

Geographically distributed acoustical monitoring of migrating birds.  Jour‐
nal of the Acoustical Society of America, 108(5, part 2): 2582.

Amplitude Activity
Detector

The Amplitude Detector detects regions of a signal where the magnitude 
of the waveformʹs envelope exceeds a threshold value.  To approximate 
the envelope, the detector computes the absolute value of the waveform 
and passes it through a lowpass filter.  The envelope signal is then tested 
against the threshold.  Raven does not display the actual envelope data.

To configure the detector, first choose the amplitude threshold based on 
the waveform amplitude.  Then set the smoothing time constant equal to 
the most rapid rise or fall of the waveform that you would like the enve‐
lope detector to follow (see Figure 10.22).

Figure 10.22 configure detector dialog

Figure 10.22. The dialog box to configure an amplitude detector. 

To demonstrate the use of the amplitude detector, we will walk through an 
example. First, open the ChestnutSidedWarbler.aif file (included in the 
Raven Examples folder). Next, we will choose the amplitude threshold by 
moving the vertical position marker until it intersects a set of events typi‐
cal of those which you would like to detect, but above the noise and clutter 
you would like to reject. Then, read off the amplitude threshold value 
from the y‐axis on the left. In this example, the reading is 5.015 kUnits (or 
5015 Units). See Figure 10.23.
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Figure 10.23 the amplitude threshold

Figure 10.23. The ChestnutSidedWarbler.aif sound window with the 
vertical position parker (in the waveform view) positioned at 5015 Units. 
This reading will become the amplitude threshold for our detector.

Next, make a selection which encloses the most rapid rise or fall of the 
waveform that you would like the envelope detector to follow. Ideally, the 
rise should be from zero to the maximum value of the waveform. In this 
example, we’ve used the Delta Time measurement to compute the width 
of the selection for us. The time width, τ, is .09575 s which we will use as 
the value of the smoothing time constant. See Figure 10.24.
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Figure 10.24 calculating the time width

Figure 10.24. After selecting the most rapid rise/fall of the waveform 
(selection 1, in red) we use the Delta Time measurement (highlighted in 
purple in the selection table) to gain a value for the smoothing time con-
stant.

After running the amplitude detector on ChestnutSidedWarbler.aif with 
the previously determined settings (amplitude threshold of 5015 Units, 
smoothing .09575) you should get something similar to Figure 10.25.
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Figure 10.25 detections

Figure 10.25. The selections made by the amplitude detector. There 
are a few transients, but not bad overall.

If we run the detector with a smaller lowpass frequency, we will see how 
the selections can start to be shifted slightly to the right from where you 
might intuitively place them. Again, this is because the detector is detect‐
ing on the envelope signal, which lags the waveform slightly (see Figure 
10.26).

There can be significant time lag between the input of the 
lowpass filter and its output, the envelope. Since the selec‐
tions are computed using the envelope, the selections can 
appear to lag the waveform when they are drawn in Raven. 
This effect becomes more pronounced as the lowpass fre‐
quency is reduced.
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Figure 10.26 lowpass lag

Figure 10.26. The detector run with a smaller lowpass filter value, 
showing the lag that can occur.
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Chapter 11  Customizing Raven:  
Preferences, Presets & Memory

About this chapter

This chapter explains how to use Raven preferences to configure many 
aspects of Raven’s default appearance and behavior. We discuss general 
Raven preferences and specific information on the following topics:

•editing Raven color schemes
•default Raven presets
•the preset manager
•power spectra calculation method
•default workspace, directories, measurement precision
•overwrite behavior for records
•the memory manager
•Raven program and documentation updates
•how to troubleshoot Raven and make it run faster
•and contacting the Raven development and support team.

Editing color schemes

It is possible to customize the color scheme used in Raven. Figure 11.1 
shows an example of two color schemes that differ in spectrogram color 
map, background color, axis color, and waveform line color. 
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Figure 11.1.  Varied color schemes

Figure 11.1.  The same sound window displayed with two different 
color schemes.
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By using the Color Scheme Editor, you can change any of the color scheme 
elements listed in Table 11.1.

To open the Color Scheme Editor (Figure 11.2), choose Color Scheme > 
Edit... from the View menu or from the contextual menu for any view. 

Table 11.1. Editable elements of a color scheme.

active point selection

active selection border

active selection fill

axis

background

gram slice line

inactive point selection

inactive selection border

inactive selection fill

line title

no data

playback cursor

position marker

waveform dot

waveform line

The inactive selection colors in the color scheme set the col-
ors for the default selection table. For other tables, the colors 
are determined by the color set for the table. All three colors 
are set to the table color, and the opacity is set to the opacity 
of the inactive selection fill from the color scheme. See 
“Opacity” on page 248.
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Figure 11.2.  Color scheme editor

Figure 11.2.  The Color Scheme Editor dialog. The Swatches color 
chooser is displayed by default when the Color Scheme Editor is first 
opened.

Choosing a color
scheme element to

edit

To change the color of a particular element of a color scheme, choose the 
name of that element from the Color drop‐down menu, and then set its 
color using one of the three color choosers that appear on the tabs in the 
middle of the dialog box. 

Choosing colors Raven’s color choosers provide three different ways of specifying colors, 
as described below. For all color choosers, a sample of the color chosen is 
shown in the Preview panel in the lower third of the dialog box.

Swatches color chooser
When you first open the Color Scheme Editor dialog box, the Swatches 
tab is displayed by default (Figure 11.2). To change the color of the 
selected color scheme element, click on one of the small color swatches in 
the rectangular color palette. Each time you click on a swatch, a swatch of 
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that color is added to the small Recent palette to the right of the main pal‐
ette. You can choose any color that you have used recently either from the 
Recent palette or from the main color palette.

HSB color chooser
The HSB color chooser (Figure 11.3) allows you to choose colors for each 
element in a color scheme by specifying the element’s hue, saturation, and 
brightness. You can set the hue, saturation, and brightness either by typing 
numerical values into the H, S, and B text fields, or by using the graphical 
controls.

Figure 11.3.  Color scheme editor‐HSB

Figure 11.3.  The HSB (hue, saturation, brightness) color chooser in 
the Color Scheme Editor dialog.

Hue:  Values for hue (H) must be between 0 and 359. The current hue is 
indicated by the position of the slider control to the left of the vertical color 
bar. To change the hue, move the slider up or down, or type a new value in 
the H field and press <Enter>.

Saturation and Brightness:  Values for saturation (S) and brightness (B) 
must be between 0 and 100. The large square panel to the left of the hue 
slider represents possible combinations of saturation and brightness. The 
horizontal axis of the square represents color saturation ranging from 100 
at the left edge to 0 at the right edge. The vertical axis of the square repre‐
sents brightness ranging from 100 at the top edge to 0 at the bottom edge. 
To set the saturation and brightness of the selected color scheme element, 
click on the point within the square that corresponds to the desired satura‐
tion and brightness. You can also drag the small white circle that indicates 
the current saturation and brightness within the saturation‐brightness 
square, or type new values in the S and B fields, and press <Enter> for 
each one.
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RGB color chooser
The RGB color chooser (Figure 11.4) allows you to choose colors for each 
element in a color scheme by specifying the relative amount of red, green, 
and blue that are added together to yield the element’s color. Values for 
red, green, and blue range between 0 and 255. You can specify RGB values 
by typing them into their respective fields in the dialog, or by sliding the 
corresponding controls left or right.

Figure 11.4. Color scheme editor‐RGB

Figure 11.4.  The RGB (red, green, blue) color chooser in the Color 
Scheme Editor dialog box.

Opacity There is an ordering relationship among the various elements that are dis‐
played in a view such that any one element is either in front of or behind 
any other element. Each element in a view has an opacity associated with 
it, that can vary between 0 and 255. An element that has an opacity of 255 
is completely opaque— it completely hides whatever elements are behind 
it. An element with an opacity of 0 is completely transparent, hence invisi‐
ble. An element with an intermediate opacity allows elements behind it to 
be seen, but tinted with the front element’s color (Figure 11.5). By default, 
Active Selection Fill and Inactive Selection Fill have opacity values of 15; 
all other elements are completely opaque (opacity = 255). You can set the 
opacity of the selected view element by moving the horizontal Opacity 
slider.

Selection tables other than the default (first) table will get their 
color from the selection table color and will inherit their inac-
tive selection fill opacity from the inactive selection fill color 
opacity in the color scheme.
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Figure 11.5.  Opacity comparison

Figure 11.5.  Two spectrogram views showing the effect of varying 
opacity of the Active Selection Fill color. In the upper view, the opacity is 
set to 15 (the default value); in the lower view it is set to 80.

Color scheme
presets

You can save the current color scheme as a color scheme preset, which you 
can then apply later to any sound window, without having to specify the 
colors of all of the elements in the color scheme individually. Commands 
for saving and applying color scheme presets are in the color scheme Pre-
set menu, which is accessible from the View menu, from the contextual 
menu for any view, and from within the Color Scheme Editor dialog box.  
To save the current color scheme as a preset, choose Preset > Save As... . 
To apply an existing color scheme preset, choose the name of that preset 
from the color scheme Preset menu. When the Save Color Scheme Preset 
dialog box appears, enter a name for the preset, and click OK. 

Auto-Apply, Apply,
Reset, OK, and

Close

If the Auto-apply checkbox is checked (the default), Raven immediately 
applies any change you make to an element’s color or opacity, without you 
needing to click the Apply button. For parameters that you enter by typing 
in a field (e.g., Red, Green, or Blue values in the RGB color chooser), the 
change is applied when you complete an entry by pressing the <Enter> or 
<Tab> key, or by clicking in another field.

Color scheme presets must be saved in the folder Presets/
Color Scheme/ within the Raven program folder. You can 
also create additional folders within the Color Scheme 
folder by clicking on the New Folder icon within the Save 
Color Scheme Preset dialog. These folders will appear as 
submenus in the color scheme Preset menu, with each sub-
menu listing the presets in the corresponding folder.
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If the Auto-apply checkbox is unchecked, changes that you make in the 
Color Scheme Editor are not applied until you click the Apply or OK but‐
ton. Clicking the OK button applies the changes and closes the dialog. 
Clicking the Apply button applies the changes but leaves the dialog open. 
Clicking the Close button closes the dialog without applying changes. 

If you click the Reset button before applying changes, the color and opac‐
ity settings revert to their previous values.

The Preset Manager

Table 11.2 lists all of the types of presets available in Raven. You create 
presets by choosing Preset > Save As... in any dialog box that supports 
presets.

If Auto-apply is checked, the Reset button will not restore the 
color and opacity settings in effect before you made changes.
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You can use the Preset Manager (Figure 11.6) to delete or rename presets, 
to create, rename or delete folders within preset folders, and to move pre‐
sets from one folder to another. To open the Preset Manager window, do 
one of the following:
• choose Window> Preset Manager from the Raven menu bar
• choose Window Preset > Manage Presets from the View menu or the 
contextual menu for any view

• choose Preset > Manage Presets from the menu bar in any dialog box 
that supports presets.

Table 11.2.  Types of presets available in Raven.

Audio File Format

Audio File Names

Audio Recorder

Audio Recorder Display

Audio Recorder Input

Audio Recorder Schedule

Clip File Format

Clip File Names

Color Scheme

Detector

Measurement List

Sample Rate Conversion

Selection Labels

Sound Window

Spectrogram Parameters
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Figure 11.6 Preset manager

Figure 11.6.  The Preset Manager dialog box, showing the Spectro-
gram Parameters preset selection.

If you access the Preset Manager from a Preset menu in a dialog box, it 
will initially display presets of the appropriate type for the dialog box 
from which you invoked it. To choose a different preset type to manage, 
use the Preset Type drop‐down list. The list box will show the names of all 
of the presets and folders presently defined for the selected preset type. To 
rename or delete a preset, click on its name in the list, then click the appro‐
priate button. To create a folder within the currently selected preset type, 
click New Folder... . To move a preset or folder into or out of a folder, sim‐
ply drag its entry within the list.

About Raven preferences

You can control the default appearance and behavior of many parts of 
Raven by setting preferences. You set preferences by editing the Raven pref‐
erence file with a text editing program or word processor. 

Raven allows you to specify preferences for the following: 
• Default presets for spectrogram parameters, recorder parameters, win‐
dow layout, view color scheme, and measurement list.

• Power spectra calculation method that Raven will use.
• Default workspace to open when Raven is launched. 
• Default directories that Raven will use for opening and saving files.
• Default precision for measurements displayed in the selection table.    
• Behavior of audio recorders when creating files. If a file created by an 
audio recorder has the same name as an existing file, the new file can 
252 Raven Pro 1.3 User’s Manual



Chapter 11:  Customizing Raven
either overwrite the old one, or be placed in a new directory in order to 
preserve the old file, depending on the preference you specify.    

• Return email address to use when sending feedback to the Raven 
development team.

The Raven
preference file

Raven preferences are specified in a text file named RavenPrefer-
ences.txt, which is placed in the Raven program directory when Raven 
is installed. Each time Raven is launched, it loads the preference file. To 
change preference settings, you must edit this file. If Raven is running 
when you edit the preference file, you will need to quit and restart Raven 
for your changes to take effect.

To edit the file, double‐click on its icon, and the file should open in your 
computer’s default text editing program. Alternatively, you can open the 
preference file from within any text editing program that can work with 
plain text files (sometimes called text only or ASCII files).

Each particular preference is specified by an entry in the preference file of 
the general form

raven.prefName=prefValue

where prefName is replaced by the name of the particular preference and 
prefValue is replaced by a valid value for that particular preference. For 
example, the entry

raven.preset.colorScheme.defaultPreset=Default

specifies that Raven should by default apply the color scheme preset 
named Default to new views.

The character ‘#’ is considered the comment character in the preference 
file— any text that follows this character up until the end of the line is dis‐
regarded by Raven. You can thus add comments to a preference file to 
make it more intelligible to a human, by preceding each comment line 
with ‘#’. The preference file that is supplied as part of the standard Raven 
installation contains comments that explain the meaning of each prefer‐

Before editing the preference file, it’s a good idea to make a 
backup copy of the file, in case you inadvertently damage or 
delete the file you’re editing.

When you edit the preference file, make sure that the revised 
file is still named RavenPreferences.txt and that it is 
saved as a plain text file. If your word processing program 
asks you if you want to save the file in the program’s own 
native file format instead, you should always choose plain 
text (or “text only”). 
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ence line. You can also “comment out” an entry and cause Raven to ignore 
it by inserting ‘#’ at the beginning of the line. 

The sections below describe each category of preference in detail. 

Default presets

Presets provide a mechanism for saving sets of related configuration 
parameters for Raven sound windows and views. Presets simplify config‐
uring windows and views by enabling you to set multiple parameters in 
one step. For example, a color scheme contains color specifications for the 
spectrogram color map and for fifteen other display elements, such as 
point selections, border and fill for range selections, position markers, and 
so on. You can alter any of the predefined colors that Raven provides, and 
then save the entire set of colors as a color scheme preset that can be 
retrieved later with a single mouse click.

The sections below briefly describe each type of preset, provide cross‐ref‐
erences to further discussions elsewhere in this manual, and explain how 
to specify a preference for the default preset.

Spectrogram
presets

A spectrogram preset saves the state of all of the parameters and controls 
in the Configure Spectrogram dialog under a single preset name. You can 
retrieve a saved spectrogram preset from the Preset menu within the Con‐
figure Spectrogram dialog. Spectrogram presets are discussed further in 
“Spectrogram presets” in Chapter 5 (page 115).

Raven is installed with a spectrogram preset named Default, which is 
initially specified as the default by the following entry in the preference 
file:  

raven.preset.spectrogramParameters.defaultPreset 
=Default

To change the default to a different spectrogram preset, edit this entry. For 
example, to use a spectrogram preset called MySpectrogram by default, 
change the default spectrogram preset entry to 

raven.preset.spectrogramParameters.defaultPreset 
=MySpectrogram

Although some preference entries are shown in this manual 
across two lines of text, each entry in the actual preference 
file must be on a single line.

Spectrogram views that are created by applying a window 
preset will use the spectrogram parameters specified by the 
window preset, not those in the default spectrogram preset.
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Recorder presets A recorder preset saves the state of all parameters and controls on one or 
all of the tabs in the Configure Recorder dialog under a single preset 
name. You can retrieve a saved recorder preset from the Preset menu 
within the Configure Recorder dialog. Recorder presets are discussed fur‐
ther in “Note that if you configure the name of your list file with relative 
times in the name of its sub‐folder, Raven will generate a new list file 
whenever the relative times you used are changed. For example, look at 
the following list file name templates:” in Chapter 4 (page 83).

When Raven is first installed, there is no default recorder preset defined. 
This is because a recorder preset includes the name of the default audio 
input device, which varies among computers, and thus cannot be included 
in a predefined recorder preset. To specify a default recorder preset, you 
must first configure a recorder with the parameters that you will use most 
commonly, and save that configuration as a recorder preset named 
Default, as described in “Note that if you configure the name of your list 
file with relative times in the name of its sub‐folder, Raven will generate a 
new list file whenever the relative times you used are changed. For exam‐
ple, look at the following list file name templates:” in Chapter 4 (page 83). 
Then uncomment the following entry in the preference file by deleting the 
‘#’:     

# raven.preset.audioRecorder.defaultPreset=Default

Measurement
presets

A measurement preset saves a list of measurements to be displayed in a 
selection table, along with their respective formats and precisions. You can 
retrieve a saved measurement preset from the Preset menu within the 
Measurement Chooser dialog. Measurement presets are discussed further 
in “Using measurement presets” in Chapter 6 (page 151).

Raven is installed with a measurement preset named Default, which is 
initially specified as the default by the following entry in the preference 
file:

raven.preset.measurementList.defaultPreset=Default

To change the default to a different measurement preset, edit this entry. 
For example, to use a measurement preset called MyMeasurements by 
default, change the default measurement preset entry to 

raven.preset.measurementList.defaultPreset
=MyMeasurements

Sound window
presets

A sound window preset saves information about the layout of a sound 
window, such as window size, what views are displayed, their sizes, color 

When a window preset is applied to a sound window, the 
measurements specified in the window preset take prece-
dence over the default measurement preset. See “Sound 
Window Presets” in Chapter 3 (page 61).
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schemes, position and scale, selection table visibility and measurements 
displayed. You can retrieve a saved window preset from the Window Pre-
set menu on the View menu or the contextual menu for any view. Sound 
window presets are discussed further in “Sound Window Presets” in 
Chapter 3 (page 61).

Raven is installed with a sound window preset named Default, which is 
initially specified as the default by the following entry in the preference 
file:

raven.preset.soundWindow.defaultPreset=Default

To change the default to a different sound window preset, edit this entry. 
For example, to use a sound window preset called MyWindow by default, 
change the default measurement preset entry to 

raven.preset.soundWindow.defaultPreset=MyWindow

Color scheme
presets

A color scheme preset saves the colors of all elements in a color scheme 
(the spectrogram color map, and colors of view elements such as position 
markers, selection borders and fills, and background) under a single pre‐
set name. You can retrieve a saved color scheme preset from the Color 
Scheme > Preset menu on the View menu or the contextual menu for any 
view.

Raven is installed with a color scheme preset named Default, which is 
initially specified as the default by the following entry in the preference 
file:

raven.preset.colorScheme.defaultPreset=Default

To change the default to a different color scheme preset, edit this entry. For 
example, to use a sound window preset called MyColors by default, 
change the default measurement preset entry to 

raven.preset.colorScheme.defaultPreset=MyColors

Selectable look and
feel, desktop

background color,
tooltip color

You can now choose between several predesigned “look and feel” 
schemes. On Windows the list includes Metal, CDE/Motif, Windows, or 
Windows Classic.  On Mac OS, the list includes Metal, CDE/Motif, or Mac 
OS X (sometimes known as Aqua). Raven 1.3’s standard appearance is 
Metal on Windows and Mac OS X on Mac OS, but you can adjust the cur‐
rent scheme at any time by choosing Window > Look and Feel.

You can also change the background color of the desktop by choosing Win-
dow > Background Color... which will open the Background Color Editor 

When a window preset is applied to a sound window, the 
color scheme(s) specified in the window preset take prece-
dence over the default color scheme preset. See “Sound 
Window Presets” in Chapter 3 (page 61).
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panel.  You can set the color of the main Raven screen this way. Raven will 
save the color in the preferences file so that it can be applied on subse‐
quent invocations of Raven.

You can also change the color of Raven’s tooltips, the helpful signs that 
pop up when you hover the mouse cursor over a button or box.  To choose 
a tooltip color, choose Window > Tooltip Color... which will open the Tool‐
tip Color Editor panel.  Note that tooltip color can only be changed within 
the Metal Look and Feel.

Power Spectra Calculation Method

In Raven 1.3, a new power spectra calculation method was introduced. 
The newer method includes energy in the negative frequency bins of the 
DFT, as well as normalization of the power spectrum by the number of 
points in the DFT window.  This newer method should be used in cases 
when measurements need to be consistent with those made in Canary.

To change the calculation method, edit the last line of text which should 
read as either:

raven.compatibility.computation.spectrogram=1.2

or 

raven.compatibility.computation.spectrogram=1.3

This statement indicates the power spectra computation method that 
Raven is currently using.  To use the new method, change the entry to 1.3, 
otherwise, use 1.2.
You can also compare the two calculation methods by simultaneously 
opening two instances of Raven, one with the Raven 1.3 method active and 
the other with the Raven 1.2 method active.  To do this, you must:
1. Start Raven 1.3. This instance of Raven 1.3 will continue to use the cur‐

rent method, which in most cases will be the one that was chosen the 
first time that Raven 1.3 was started.

2. Without closing the first instance of Raven 1.3, start Raven 1.3 again so 
that there are now two instances running simultaneously. This instance 
of Raven is the one for which you will alter the calculation method.

3. With the second instance of Raven 1.3 active, open (from the Windows 
menu) the Raven preferences file: Start > Programs > Raven 1.3 > Rav‐
enPreferences.txt

4. Scroll to the last line of the text which should read as either:
raven.compatibility.computation.spectrogram=1.2

or  raven.compatibility.computation.spectrogram=1.3

5. If the version is 1.3, change it to 1.2, or vice versa.  This change will 
affect only the power spectra computation method.

6. Save and close RavenPreferences.txt
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7. Leaving the first intance of Raven 1.3 open, close, then reopen the sec‐
ond instance of Raven 1.3.

8. The previous preference settings will continue to apply to the first 
instance of Raven 1.3 as long as it remains open.  So, it uses the power 
spectra computation method that was initially set, while the second 
instance uses the method that was just set.

Using the current Raven 1.3 power spectra calculation in one instance, and 
the earier Raven 1.2.x power spectra calculation in the other instance, open 
the same file in each and view them simultaneously to see the difference.

Default workspace

Workspace files are discussed in “Saving Your Workspace” in Chapter 1 
(page 13). 

You can specify a default workspace for Raven to open each time the pro‐
gram is launched by uncommenting and editing the following entry in the 
preference file

# raven.workspace.defaultWorkspace=./Workspaces/
Default.wsp

The notation “./” means that the remainder of the specified pathname is 
within the Raven program directory. If you want to use a default work‐
space that is located elsewhere, you must specify a complete path, as in 

raven.workspace.defaultWorkspace=C:/MyRavenStuff/
MyDefault.wsp

A default workspace is useful for changing the initial appearance of the 
Raven window. For example, the main Raven window is by default ini‐
tially 750 pixels wide and 550 pixels tall. If you want Raven to always start 
with a window that fills the entire screen, you can launch Raven, expand 
the window to full‐screen, and then save the workspace. Then edit the 
preference file to specify that workspace as the default. Thereafter, Raven 
will start with a full‐screen window. In addition to window size, the work‐
space will save information on the state of the side panel (visibility, size, 
which tab is selected, and so on). 

Default directories  

You can specify the default directories that Raven uses when you open 
and save sound files, selection files, or workspace files. When Raven is 

Remember that a workspace file saves the entire state of 
Raven, including all of the sound windows that are open. If 
you just want to save the size and layout of the main Raven 
window, save the workspaces when no sound windows are 
open. 
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first installed, these defaults are set respectively to directories named 
Examples, Selections, and Workspaces within the Raven program 
directory. These defaults are specified by the following three entries in the 
preference file:

raven.ui.openFileChooser.defaultDirectory=
./Examples

raven.ui.selectionFileChooser.defaultDirectory=
./Selections

raven.ui.workspaceFileChooser.defaultDirectory=
./Workspaces

The notation ‘./’ means that the specified directories are subdirectories of 
the Raven program directory. You can change any of these to any directory 
on your hard disk by editing the corresponding entry in the preference 
file. For example, the following entry tells Raven to use the directory c:/
MyStuff/SoundFiles as the default directory for sound files: 

raven.ui.openFileChooser.defaultDirectory=
c:/MyStuff/SoundFiles

Default measurement precision

By editing the appropriate entries in the preference file, you can specify 
how many digits of precision Raven should use by default for displaying 
and saving measurements in the selection table. You can always change 
the precision of a measurement displayed in a selection table, as described 
in “Measurement precision and format” in Chapter 6 (page 151).

Measurement precision entries are of the form
raven.measurement.basic.name.defaultValueFormat

=precision

You need to use the forward slash (/) character to separate 
directories and subdirectories in Raven preference entries, 
not the back slash (\). Note that this is different than entries 
in list files, for example.

If you invoke a measurement preset, either by choosing a 
preset from the Preset menu within Raven’s Measurement 
Chooser, or by specifying a default measurement preset in 
the preference file, the measurement precisions saved for 
measurements included in the preset will override precision 
preferences. Measurement precision preferences will apply 
only to measurements that are not specifically included in the 
the preset, when and if these are added to the selection table    
via the Measurement Chooser.
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where name is replaced by the name of a measurement type or of a spe‐
cific measurement, and precision is replaced by a string such as 
0.000. The number of zeros to the right of the decimal point indicates 
the desired precision. 

Raven provides measurements of four types of quantities: time, frequency, 
amplitude, and power. For each type of measurement, you can specify a 
default display precision. You can also specify a different precision for 
specific measurements within each type, which will override the default 
for the type. For example, if you were to specify a default precision of 
0.000 for time measurements, and a specific precision of 0.00 for the 
Delta Time measurement, Raven would display two digits to the right 
of the decimal point for Delta Time values, and three digits for all other 
time values.

Time To specify the default measurement precision for time measurements, 
uncomment and edit the following entry:

# raven.measurement.basic.time.defaultValueFormat
=0.000

To override the default measurement precision for time measurements 
and specify a different precision for Begin Time, End Time, Delta 
Time, Max Time, Min Time, or Peak Time, uncomment and edit the 
appropriate one of the following entries:

# raven.measurement.basic.beginTime.defaultValue-
Format=0.000

# raven.measurement.basic.endTime.defaultValueFor-
mat=0.000

# raven.measurement.basic.deltaTime.defaultValue-
Format=0.000

# raven.measurement.basic.maxTime.defaultValueFor-
mat=0.000

# raven.measurement.basic.minTime.defaultValueFor-
mat=0.000

# raven.measurement.basic.peakTime.defaultValueFor-
mat=0.000

Frequency To specify the default measurement display precision for frequency mea‐
surements, uncomment and edit the following entry:

# raven.measurement.basic.frequency.defaultValue-
Format=0.0000

To override the default measurement precision for frequency measure‐
ments and specify a different precision for Low Frequency, High Fre-
quency, Delta Frequency, or Max Frequency, uncomment and edit 
the appropriate one of the following entries:

# raven.measurement.basic.lowFrequency.default-
ValueFormat=0.000
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# raven.measurement.basic.highFrequency.default-
ValueFormat=0.000

# raven.measurement.basic.deltaFrequency.default-
ValueFormat=0.000

# raven.measurement.basic.maxFrequency.default-
ValueFormat=0.000

Amplitude To specify the default measurement display precision for amplitude mea‐
surements, uncomment and edit the following entry:

# raven.measurement.basic.amplitude.default-
ValueFormat=0.000

To override the default measurement precision for amplitude measure‐
ments and specify a different precision for Min Amplitude, Max 
Amplitude, Peak Amplitude, or RMS Amplitude, uncomment and 
edit the appropriate one of the following entries:

# raven.measurement.basic.minAmplitude.default-
ValueFormat=0.000

# raven.measurement.basic.maxAmplitude.default-
ValueFormat=0.000

# raven.measurement.basic.peakAmplitude.default-
ValueFormat=0.000

# raven.measurement.basic.rmsAmplitude.default-
ValueFormat=0.000

Power To specify the default measurement display precision for power measure‐
ments, uncomment and edit the following entry:

# raven.measurement.basic.power.defaultValue-
Format=0.000

Overwrite behavior for recorders

You can specify a preference for what Raven should do when recording to 
files if a new sound file has the same name as an existing file in the 
selected recording directory, by editing the following entry:  

raven.ui.audioRecorder.overwriteExistingFiles=false

When this preference is set to false (the default when Raven is installed), 
Raven will create a new directory for the new file, rather than overwriting 
the existing file as described in “File name collisions” in Chapter 4 (page 
81). If you change the preference to true, the new file will replace the old 
file without any warning.

The Memory Manager

You can use Raven’s Memory Manager window (Figure 11.7) to see how 
much memory is used for each view of each file that is open, and to release 
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memory by deleting selected views or sound windows. You can open the 
Memory Manager at any time by choosing Window > Memory Manager.

Figure 11.7. Memory manager

Figure 11.7.  The Memory Manager window. When the window is first 
opened, the tree view shown is fully collapsed. In this example, the win-
dow would initially display only Sound 1. To expand or collapse an item 
in the view, click on the opener icon to its left or double-click the item’s 
name.

About Raven
memory allocation

Raven runs within a simulated computer called the Java Virtual Machine 
(JVM). At any given time when Raven is running, a certain amount of your 
computer’s memory, known as the heap, is allocated by the JVM for use by 
Raven.1 The heap represents the memory that is available for Raven’s use; 
the amount of memory that Raven is actually using at any given moment 
may be less than the heap size. The heap can grow or shrink as Raven’s 
memory needs change. Initially, when you first launch Raven, the JVM 
allocates a relatively small heap, enough to display the Raven window 
with no files open. As you open files, create views, and perform other 
operations that require memory, more memory is allocated to the heap as 
needed by the JVM. When you delete views or close sound windows, the 
memory that was used for those objects becomes available to Raven for re‐
use. 

1. The actual amount of memory available to Raven is slightly less than the heap 
size, since part of the heap is used by the JVM itself.
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By default, the maximum heap size that the JVM can allocate is 256 mega‐
bytes. If Raven requests additional memory (e.g., to open another sound 
file or to add a view to an existing sound window) when the heap has 
already grown to its maximum size, an out‐of‐memory error will occur. 
An out‐of‐memory error can also occur with a smaller heap size, if there is 
not enough memory available in your computer for the JVM to allocate the 
maximum heap size. This can happen if your computer does not have 
enough physical memory installed, or if large amounts of the installed 
memory are in use by other programs. When an out‐of‐memory error 
occurs, Raven will ask if you want to use the Memory Manager to release 
some memory.

The Memory
Manager window

Memory usage summary
The top portion of the Memory Manager window (Figure 11.7) displays 
summary information about Raven’s current memory usage.

• Maximum Heap Size is the largest amount of memory that the JVM will 
attempt to allocate to the heap.

• Current Heap Size is the current size of the heap that has been allocated 
by the JVM to Raven. Each time Raven needs more memory than it has 
available, the Current Heap Size increases, as the JVM allocates succes‐
sive increments of memory to the heap.

• Memory Used is the amount of the current heap that Raven is actually 
using. 

• Memory Available is the amount of Raven’s current heap that is not 
presently in use. Memory Available is equal to Current Heap Size minus 
Memory Used.

Configuring Maximum Heap Size
You can change the maximum heap size by clicking the Configure... button 
in the Memory Manager window (Figure 11.7), and entering a new maxi‐
mum heap size in the Configure Maximum Heap Size dialog box that 
appears. In order for the new maximum heap size to take effect, you must 
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restart Raven. If you do not restart immediately, the change will take effect 
the next time you start Raven.

The memory usage list
The bottom portion of the Memory Manager window (Figure 11.7) dis‐
plays a list of all of the sound files presently open, and the size of each one 
in megabytes (1 megabyte (Mbyte) = 1024 kilobytes; 1 kilobyte (Kbyte) = 
1024 bytes). To the left of the name of each sound (e.g., “Sound 1”, “Sound 
2”, etc.) is an opener icon; the shape of the opener icon depends on the oper‐
ating system under which you’re running Raven. Clicking on the opener 
icon or double‐clicking on the entry name expands the entry for the 
sound. The expanded entry contains an entry for the sound samples that 
constitute the signal, and one entry for each view that exists for that sound 
(e.g., “Waveform 1”, “Spectrogram 1”, etc.). Each view entry again has an 
associated opener icon. Clicking the opener icon or double‐clicking the 
entry name for a view expands the view’s entry to show an entry for the 
view’s rendering data, and in the case of spectrogram and spectrogram slice 
views, the spectrogram data. Rendering data represent the graphic image 
displayed in a view’s pane within the signal window, and thus depend in 
part on the size of a view’s pane. Changing the size of a view pane or the 
entire window will change the size of the associated rendering data, even 
though the sizes of the sound samples and spectrograms do not change.

The memory usage list only tracks the typically large memory allocations 
associated with sound windows and views. During the course of normal 
operations, Raven uses memory for many other (relatively small) internal 
data objects as well. Consequently, the Memory Used value is always 
somewhat greater than the sum of the sizes shown in the list. Spectrogram 
caching may further contribute to a discrepancy between the Memory 
Used value and the sum of the items in the memory usage list. Spectro‐
gram caching occurs when you have requested multiple spectrograms 
with identical parameters (e.g., for a spectrogram view and a spectrogram 
slice view or for two spectrogram views that you view at different scales). 
In these cases, Raven saves time and memory by computing and storing 

The Maximum Heap Size shown in the Memory Manager is 
the largest value that the JVM will attempt to allocate to the 
heap. The largest heap size that actually can be allocated 
may be less than the Maximum Heap Size shown if there is 
not enough memory available that is not being used by other 
programs (including the operating system), or if there is insuf-
ficient physical memory installed in the computer.

Take care to set the maximum heap size to a realistic value. If 
the value is set beyond the range of the computer’s physical 
memory, Raven may fail to start. If this happens, you need to 
contact Raven support to correct the problem.
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the spectrogram data only once. Even though there is only one copy of the 
cached spectrogram, the Memory Manager will show a duplicate size 
entry for each view that uses the cached data.

You can delete a view or close a sound window by selecting its entry in the 
Memory Manager list, then clicking Remove. 

Reclaiming unused memory
When you delete a view or close a window, the memory that was used for 
that object eventually becomes available for re‐use (i.e., it is removed from 
the Memory Used Category and added to Memory Available). This occurs 
eventually rather than immediately because Raven only reclaims unused 
memory when it needs to. You can force Raven to reclaim unused memory 
at any time by clicking the Reclaim button in the Memory Manager win‐
dow. Clicking Reclaim will force Raven to display the most up‐to‐date 
possible data on memory usage.

Raven program and documentation updates

Automatic updates From time to time, the Raven development team releases software and 
documentation updates that fix errors in Raven or the Raven User’s Man‐
ual. By default, Raven will automatically attempt to contact the Raven 
update server via the Internet to see if any new update files are available 
each time you start the program. To disable this behavior, edit the follow‐
ing entry, changing its value to false:

raven.updates.automatic=true

Installing updates If updates are found, Raven will display a dialog showing how many 
update files are available, and their total size (Figure 11.8). You can then 
choose whether or not to download the updates. Separate dialogs are 
shown for program files and documentation files. If you choose not to 
download update files, you can always download them later. You can 
check for updates at any time by choosing Help > Check for Updates.
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Figure 11.8. Update dialog

Figure 11.8.  The download update files dialog.

There is no separate installation procedure required once the update files 
have been downloaded, but you need to restart Raven for the updates to 
take effect. If you do not restart immediately, the updates take effect the 
next time you start Raven.

Troubleshooting Raven

Online resources Several online resources can help you if you run into a problem with 
Raven.  The first place to check is the Raven Pro FAQ, which lists common 
problems and how to solve them.  It can be found at http://help.Raven‐
SoundSoftware.com/forum/faq.php.

Another helpful place to look is the Raven Help Forum, where you can see 
if other users have encountered your problem, and ask the Raven support 
team for help.  The forum also contains a list of How To’s for common 
Raven tasks.  It can be found at http://help.RavenSoundSoftware.com/
forum.

Finally, you can contact the Raven Team directly from Raven, by choosing 
Help > Email Feedback.  For more information, see “Contacting the Raven 
development and support team” on page 267.

Reporting a bug If you find a bug in Raven, we’d like to hear about it.  If possible, send your 
bug report directly from Raven (Help > Email Feedback), because the pro‐
gram will then send us additional information that may be helpful in 
determining how to fix the bug.

WINDOWS On Windows computers, after updates are successfully 
downloaded, Raven will ask if you want to restart 
Raven immediately. If you click Yes, Raven automati-
cally quits and restarts itself. 
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If you are running Raven on Windows, you can get additional information 
about your bug by running the Raven Console.  In your Raven folder, dou‐
ble‐click on the icon labeled RavenConsole.  Raven will launch normally, 
with the addition of a text window called the console.  If you can repro‐
duce your bug while running the console, additional error messages may 
be displayed in the console window.  Please send us these messages along 
with your bug report.

If you are running Raven on a Mac, you can access the Raven Console by 
opening /Applications/Utilities/Console.  Please copy the contents of that 
file to your bug report.

Performance tips If Raven is running slowly or stalling when you perform large operations, 
there are several ways to speed it up.  First, it is important to run Raven 
with sufficient memory.  By default, Raven runs with a maximum memory 
allocation size of 256 megabytes.  If your computer has more RAM than 
this, you may wish to increase the amount Raven can use.  To do this, open 
the Memory Manager (Window > Memory Manager), then click on the 
Configure button.  From there, you can increase your maximum memory 
allocation from 256 megabytes to a larger value, such as 512 megabytes.  
The next time Raven is launched, it will use the new value for the maxi‐
mum memory allocation size

Real‐time signal displays can tax a computer’s CPU, especially on slower 
computers.  If necessary, you can reduce the load placed on your CPU by 
these displays by making them smaller and/or hiding their axes.

If you’re working with a large number of selections, creating or manipulat‐
ing a selection can make Raven run slowly.  You can fix that by adding the 
following line to RavenPreferences.txt:

raven.ui.selections.drawOnlyActiveWhileModifyingWithMouse=true

This will make Raven run faster by making your other selections disap‐
pear momentarily whenever a selection is created or modified.  They will 
reappear when you release your mouse button.

Another way to make Raven run faster while working with selections is to 
turn off the “Selection Fill” checkbox in the Layout tab of the side panel.  
This will remove the shading that fills selections, which will reduce the 
load on your CPU.

Contacting the Raven development and support team

Raven has an online help and discussion forum where users can address 
each other or the Raven team by asking questions, answering posted ques‐
tions, reporting bugs, or submitting feature requests. Visit us at http://
help.RavenSoundSoftware.com/ to view the forum.

Setting your return
address

The Raven developers want to hear from you. You can report a bug, 
request support, or suggest a feature by choosing File > Email Feedback, 
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and sending email from within Raven (Figure 11.9). Before clicking Send, 
be sure to check that your correct email address appears in the From field, 
so we can get back to you.1  

Bug reporting Although you can of course use your usual email program to contact us (at 
raven_bugs@cornell.edu for bugs and feature requests, or 
raven_support@cornell.edu for support or other comments), there is 
one situation in which you should use Raven’s email feedback feature, and 
not another program. If Raven encounters an unrecoverable error, it will 
ask if you want to submit a bug report. If you report the bug using Raven’s 
email feedback form, Raven will include information along with your 
message that can help us find the cause of the problem, and correct it in 
future versions. (You can see the additional information that Raven 
includes if you look in the Context tab.) If you send your message from 
another program, this information will not be included.

1. To configure Raven to fill in your email address automatically, open the Rav‐
enPreference.txt file using any text editor, and fill in your email address in the 
line 
   raven.feedback.fromAddress=yourEmailAddress@yourISP
Save the edited file as plain text. The next time you launch Raven and use the 
email feedback form, your address will be supplied automatically in the From 
field.
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Figure 11.9.  Feedback form.

Figure 11.9. The Raven email feedback dialog.

Outgoing mail
server

Depending on how your computer is configured, you may need to supply 
Raven with the address of your outgoing mail server, known as an SMTP 
(Simple Mail Transfer Protocol) server. If you have trouble sending email 
feedback from within Raven, remove the ‘#’ from the line  

# raven.feedback.smtpServer=

and fill in the address of your SMTP server at the end of the line. If you 
don’t know the address of your SMTP server, you may be able to find it in 
a configuration or settings dialog of your usual email program, or you can 
obtain it from your network administrator or internet service provider.

Problems sending
feedback

If for some reason you are unable to send feedback when you want to do 
so (for example, because your computer is not connected to the Internet at 
the time, or there is an unexpected problem transmitting the message), 
you can choose File > Save As... to save a feedback file to be sent later. To 
send the feedback file later, do one of the following:

•Choose File > Open in the Raven Email Feedback dialog box to open the 
saved feedback file, then click Send.
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•Send a message from your regular email program to 
raven_bugs@cornell.edu or raven_support@cornell.edu, and 
include the saved feedback file as an attachment..

Again, if you have problems sending email feedback with 
Raven that you cannot resolve, contact us with your own 
email program or visit our help and discussion forum online at 
http://help.RavenSoundSoftware.com/  If you do visit our 
forum, please attach the feedback file to your post.
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Appendix A  Digital Representation of Sound

About this appendix

This appendix provides a brief explanation of how sound is represented 
digitally. An understanding of the basic principles introduced here will be 
helpful in using Raven.

Digital sampling

Before a continuous, time‐varying signal such as sound can be manipu‐
lated or analyzed with a digital computer, the signal must be acquired or 
digitized by a hardware device called an analog‐to‐digital (A/D) converter, 
or digitizer. The digitizer repeatedly measures or samples the instantaneous 
voltage amplitude of a continuously varying (analog) input signal at a 
particular sampling rate, typically thousands or tens of thousands of times 
per second (Figure A.1). In the case of an audio signal, this time‐varying 
voltage is proportional to the sound pressure at a device such as a micro‐
phone. The digital representation of a signal created by the digitizer thus 
consists of a sequence of numeric values representing the amplitude of the 
original waveform at discrete, evenly spaced points in time.
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Figure A.1.  Digital sampling

Figure A.1.  Sampling to create digital representation of a pure tone 
signal. The blue sinusoidal curve represents the continuous analog 
waveform being sampled. Measurements of the instantaneous ampli-
tude of the signal are taken at a sampling rate of 1/Δt. The resulting 
sequence of amplitude values is the digitized signal.

The precision with which the digitized signal represents the continuous 
signal depends on two parameters of the digitizing process: the rate at 
which amplitude measurements are made (the sampling rate or sampling 
frequency), and the number of bits used to represent each amplitude mea‐
surement (the sample size or bit depth). 

Sampling rate

Raven’s Configure Recorder dialog box enables you to choose the sam‐
pling rate at which a signal is to be digitized. The choices available are 
determined by the digitizer hardware and the program (called an audio 
input plug‐in in Raven) that controls the digitizer; most digitizers have two 
or more sampling rates available. Commercial digital audio applications 
use sampling rates of 44.1 kHz (for audio compact discs) or 48 kHz (for 
digital audio tape). Once a signal is digitized, its sampling rate is fixed. 

In order to interpret a sequence of numbers as representing a time‐varying 
signal, one needs to know the sampling rate. Thus, when a digitized signal 
is saved in a file format that is designed for saving sound information 
(such as AIFF or WAVE), information about the sampling rate is saved 
along with the actual data points comprising the signal. 

Aliasing and the
Nyquist frequency

The more frequently a signal is sampled, the more precisely the digitized 
signal represents temporal changes in the amplitude of the original signal. 
The sampling rate that is required to make an acceptable representation of 
a waveform depends on the signal’s frequency. More specifically, the sam‐
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pling rate must be more than twice as high as the highest frequency con‐
tained in the signal. Otherwise, the digitized signal will have frequencies 
represented in it that were not actually present in the original at all. This 
appearance of phantom frequencies as an artifact of inadequate sampling 
rate is called aliasing (Figure A.2). 

Figure A.2.  Aliasing (sampled waveform)

Figure A.2.  Aliasing as a result of inadequate sampling rate. Vertical 
lines indicate times at which samples are taken. (a) A 500 Hz pure tone 
sampled at 8000 Hz. The blue sinusoidal curve represents the continu-
ous analog waveform being sampled. There are 16 sample points (= 
8000/500) in each cycle of the waveform. If the same analog signal 
were sampled at 800 Hz (red sample points), there would be fewer than 
two points per cycle, and aliasing would result. (b) The aliased wave-
form that would be represented by sampling  the 500 Hz signal at a 
sampling rate of 800 Hz (Nyquist frequency = 400 Hz). Since the origi-
nal waveform was 100 Hz higher than the Nyquist frequency, the 
aliased signal is 100 Hz below the Nyquist frequency, or 300 Hz.

The highest frequency that can be represented in a digitized signal with‐
out aliasing is called the Nyquist frequency, and is equal to half the fre‐
quency at which the signal was digitized. The highest frequency shown in 
a spectrogram or spectrum calculated by Raven is always the Nyquist fre‐
quency of the digitized signal. If the only energy above the Nyquist fre‐
quency in the analog signal is in the form of low‐level, broadband noise, 
the effect of aliasing is to increase the noise in the digitized signal. How‐
ever, if the spectrum of the analog signal contains any peaks above the 
Nyquist frequency, the spectrum of the digitized signal will contain spuri‐
ous peaks below the Nyquist frequency as a result of aliasing. In spectro‐
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grams, aliasing is recognizable by the appearance of one or more inverted 
replicates of the real signal, offset in frequency from the original (Figure 
A.3).

Figure A.3.  Spectrogram of aliased signal.

Figure A.3.  Appearance of aliasing in spectrogram views. (a) Spectro-
gram of a bearded seal song signal digitized at 11025 Hz. All of the 
energy in the signal is below the Nyquist frequency (5512.5 Hz); only 
the lowest 2300 Hz is shown. The red line is at 1103 Hz, one-fifth of the 
Nyquist frequency. (b) The same signal sampled at 2205 Hz (one-fifth 
of the original rate; Nyquist frequency, 1102.5 Hz) without an anti-alias-
ing filter. The frequency downsweep in the first ten seconds of the orig-
inal signal appears in inverted form in this undersampled signal, due to 
aliasing. (c) The same signal as in (b), but this time passed through a 
low-pass (anti-aliasing) filter with a cutoff of 1100 Hz before being digi-
tized. The downsweep in the first ten seconds of the original signal, 
which exceeds the Nyquist frequency, does not appear because it was 
blocked by the filter.

The usual way to prevent aliasing is to pass the analog signal through a 
low‐pass filter (called an anti‐aliasing filter) before digitizing it, to remove 
any energy at frequencies greater than the Nyquist frequency. (If the origi‐
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nal signal contains no energy at frequencies above the Nyquist frequency 
or if it contains only low‐level broadband noise, this step is unnecessary.)

Sample size (amplitude resolution)

The precision with which a sample represents the actual amplitude of the 
waveform at the instant the sample is taken depends on the sample size or 
number of bits (also called bit depth) used in the binary representation of 
the amplitude value. Some digitizers can take samples of one size only; 
others allow you to choose (usually through software) between two or 
more sample sizes. Raven’s default audio input device plug‐in allows you 
to choose between 8‐bit and 16‐bit samples. An 8‐bit sample can resolve 
256 (=28) different amplitude values; a 16‐bit converter can resolve 65,536 
(=216) values. Sound recorded on audio CDs is stored as 16‐bit samples. 
When a sample is taken, the actual value is rounded to the nearest value 
that can be represented by the number of bits in a sample.

Since the actual analog value of signal amplitude at the time of a sample is 
usually not precisely equal to one of the discrete values that can be repre‐
sented exactly by a sample, there is some digitizing error inherent in the 
acquisition process (Figure A.4), which results in quantization noise in the 
digitized signal. The more bits used for each sample, the less quantization 
noise is contained in the digitized signal. If you listen to a signal digitized 
with 8‐bit samples using high‐quality headphones, you can hear the quan‐
tization noise as a low‐amplitude broadband hiss throughout the record‐
ing. Signals digitized with 16‐bit samples typically have no detectable hiss. 
The ratio between the value of the highest amplitude sample that can be 
represented with a given sample size and the lowest non‐zero amplitude 
is called the dynamic range of the signal, and is usually expressed in deci‐
bels (dB). The dynamic range corresponds to the ratio in amplitude 
between the loudest sound that can be recorded and the quantization 
noise. The dynamic range of a digitized sound is 6 dB/bit.1

1. The dynamic range of a signal in decibels is equal to 20 log(Amax/Amin), 
where Amax  and Amin  are the maximum and minimum amplitude  values 
in the signal. For a digitized signal, Amax/Amin = 2n, where n is the number 
of bits per sample. Since log(2n) = 0.3n, the dynamic range of a signal is 6 
dB/bit.
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Figure A.4.  Digitizing error

Figure A.4.  Digitizing error with a hypothetical 2-bit sample size. 2-bit 
samples can represent only four different amplitude levels. The blue 
sinusoidal curve represents the continuous analog waveform being 
sampled. At each sample time (vertical lines), the actual amplitude lev-
els are rounded to the nearest value that can be represented by a 2-bit 
sample (horizontal lines). The amplitude values stored for most sam-
ples (dots) are slightly different from the true amplitude level of the sig-
nal at the time the sample was taken.

Specifying sample
sizes when

acquiring and
saving signals

Raven lets you specify the sample size for a signal when you first acquire 
it, and again when you save the signal to a file. The set of sample sizes that 
are available during acquisition is determined by the sound input plug‐in 
that you select (sound acquisition is discussed in Chapter 4, “Signal 
Acquisition (Recording)”). While Raven is actually working with a signal, 
samples are always represented by 32‐bit floating‐point values. When you 
save a signal with a sample size other than the sample size that the signal 
had when it was acquired or opened, Raven scales the values to the sam‐
ple size that you select when you specify the format of the file (saving files 
is discussed in Chapter 1, “Getting Started”). For example, if you open a 
file containing 8‐bit samples, and then save the signal with 16‐bit samples, 
each sample value will be multiplied by 28. This scaling ensures that a full‐
scale value in the original signal is still a full‐scale value in the saved sig‐
nal, even if the sample size differ. 

Although you can acquire a signal with 8 bits and then save it 
with a larger sample size, the saved signal will retain the 
smaller dynamic range (and audible quantization hiss) of the 
8-bit signal. This is because the quantization noise is scaled 
along with the desired signal when 8-bit signals are scaled to 
the larger sample size.
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 Storage requirements

The increased frequency bandwidth obtainable with higher sampling 
rates and the increased dynamic range obtainable with larger samples 
both come at the expense of the amount of memory required to store a dig‐
itized signal. The minimum amount of storage (in bytes) required for a 
digitized signal is the product of the sample rate (in samples/sec), the sam‐
ple size (in bytes; one byte equals 8 bits), and the signal duration (sec‐
onds). Thus, a 10‐second signal sampled at 44.1 kHz with 16‐bit (2‐byte) 
precision requires 882,000 bytes (= 10 sec x 44,100 samples/sec x 2 bytes/
sample), or about about 861 Kbytes of storage (1 Kbyte = 1024 bytes). The 
actual amount of storage required for a signal may exceed this minimum, 
depending on the format in which the samples are stored.

The amount of time that it takes Raven to calculate a spectrogram of a sig‐
nal depends directly on the number of samples in that signal. Thus, spec‐
trograms take longer to calculate for signals digitized at higher rates. 
However, the sample size at which a signal is acquired or saved does not 
affect the speed of spectrogram calculation, because Raven always con‐
verts signals to a 16‐bit representation for internal operations, even if the 
signal was initially acquired or saved with a different sample size.
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Appendix B   A Biologist’s Introduction to
Spectrum Analysis

About this appendix

This appendix provides some conceptual background for making and 
interpreting spectrogram and spectrogram slice views with Raven. It 
introduces the short‐time Fourier transform (STFT), the mathematical 
technique used by Raven for making spectrograms. We do not discuss the 
mathematics of the STFT, but instead treat it here as a black box. This 
black box has controls on its outside that affect its operation in important 
ways. One aim of this appendix is to convey enough qualitative under‐
standing of the behavior of this box to allow intelligent use of its controls, 
without delving into the box’s internal mechanism. Specific details of the 
controls are covered in Chapter 3, “Spectrographic Analysis”. A second 
aim of this appendix is to explain some of the limitations and tradeoffs 
intrinsic to spectrum analysis of time‐varying signals. More rigorous 
mathematical treatments of spectral analysis, at several levels of sophisti‐
cation, can be found in the references listed at the end of the appendix.

Several approaches can be taken to explaining the fundamentals of digital 
spectrum analysis. The approach taken in this appendix is geared specifi‐
cally to spectrum analysis with Raven; thus some of the terms and con‐
cepts used here may not appear in other, more general discussions of 
spectrum analysis, such as those listed at the end of the appendix.

The discussions in this appendix assume a basic understanding of how 
sound is recorded and represented digitally. If you are not already 
acquainted with concepts such as sampling rate and sample size, you 
should read Appendix A, “Digital Representation of Sound” before pro‐
ceeding.

What sound is

Sound consists of traveling waves of alternating compression and rarefac‐
tion in an elastic medium (such as air or water), generated by some vibrat‐
ing object (a sound source). 

Sound pressure is the (usually small) alternating incremental change in 
pressure from ambient pressure that results from a sound. When no sound 
is present in a medium (i.e., there is no propagating pressure change), we 
say that sound pressure is zero, even though the medium does exert some 
static ambient pressure. The dimensions of pressure are force per unit 
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area. The usual unit of sound pressure is the pascal (abbreviated Pa); one 
pascal equals one newton per square meter.  Since the smallest audible 
sound pressures in air are on the order of 10‐6 Pa, sound pressures are usu‐
ally expressed in μPa.

To measure or record sound at a particular location in space, we use a 
device such as a microphone that responds to sound pressure. A micro‐
phone produces a time‐varying electrical voltage that is proportional to 
the increase or decrease in local pressure that constitutes sound. This con‐
tinuous time‐varying voltage is an electric analog of the acoustic signal. 
The continuous electric signal can be converted to a digital representation 
suitable for manipulation by a computer as discussed in Appendix A, 
“Digital Representation of Sound”.

Time domain and frequency domain representations of sound

Any acoustic signal can be graphically or mathematically depicted in 
either of two forms, called the time domain and frequency domain represen‐
tations. In the time domain, instantaneous pressure is represented as a 
function of time. Figure B.1a shows the time domain representation of the 
simplest type of acoustic signal, a pure tone. Such a signal is called a sinu‐
soid because its amplitude is a sine function of time, characterized by some 
frequency, which is measured in cycles per second, or Hertz (Hz). The fre‐
quency of a sinusoid is most easily determined by measuring the length of 
one period, which is the reciprocal of the frequency. The amplitude of the 
signal in the time domain is measured in pressure units. (Once an acoustic 
signal has been converted by a microphone into an electrical signal, ampli‐
tude is measured as voltage, which is directly proportional to the sound 
pressure.) In the frequency domain, the amplitude of a signal is repre‐
sented as a function of frequency. The frequency domain representation of 
a pure tone is a vertical line (Figure B.1b).
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Figure B.1.  Time and freq domain

Figure B.1.  Time domain and frequency domain representations of an 
infinitely long pure sinusoidal signal. (a) Time domain. t is the period of 
the sinusoid. (b) Frequency domain. f is the frequency of the sinusoid. 

Any sound, no matter how complex, can be represented as the sum of a 
series of pure tones (sinusoidal components). Each tone in the series has a 
particular amplitude, and a particular phase relationship (i.e., it may be 
shifted in time) relative to the others. The frequency composition of com‐
plex signals is usually not apparent from inspection of the time domain 
representation. Spectrum analysis is the process of converting the time 
domain representation of a signal to a frequency domain representation 
that shows how different frequency components contribute to the sound. 
Frequency domain representations of sounds are often more intuitively 
interpretable because the mammalian auditory system (specifically the 
cochlea) performs a type of spectrum analysis in converting vibrations of 
the eardrum into neural impulses. Our auditory perception is thus based 
on a frequency domain representation of sounds. 

The complete frequency domain representation of a signal consists of two 
parts. The magnitude spectrum (Figure B.2b) contains information about the 
relative magnitude of each frequency component in the entire signal. The 
phase spectrum (Figure B.2c) contains information about the relative phase 
or timing relationships among the frequency components. Since the phase 
spectrum is rarely of practical use in most bioacoustic work and is not pro‐
vided by Raven, it is not discussed further here. Henceforth, unless other‐
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wise noted, we use the term “spectrum” to refer to the magnitude 
spectrum alone.

Figure B.2.  Time, freq domains‐‐ 2 tones

Figure B.2.  Time domain and frequency domain representations of an 
infinitely long sound consisting of two tones, with frequencies of 490 Hz 
and 800 Hz. (a) Time domain. (b) Magnitude spectrum in frequency 
domain. (c) Phase spectrum in frequency domain. The phase of the fre-
quency component at 500 Hz is arbitrarily taken as a reference and 
assigned a phase value of 0.

The Fourier transform is a mathematical function that converts the time 
domain form of a signal (which is the representation directly produced by 
most measuring and recording devices) to a frequency domain representa‐
tion, or spectrum. When the signal and spectrum are represented as a 
sequence of discrete digital values, a version of the Fourier transform 
called the discrete Fourier transform (DFT) is used. The input to the DFT is a 
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finite sequence of values— the amplitude values of the signal— sampled 
(digitized) at regular intervals. The output is a sequence of values specify‐
ing the amplitudes of a sequence of discrete frequency components, 
evenly spaced from 0 Hz to half the sampling frequency (Figure B.3). 
Raven implements the DFT using an algorithm known as the fast Fourier 
transform (FFT).

Figure B.3.  DFT schematic

Figure B.3.  Schematic representation of the discrete Fourier transform 
(DFT) as a black box. The input to the DFT is a sequence of digitized 
amplitude values (x0, x1, x2, ... xN‐1) at N discrete points in time. The 
number of input values N is called the DFT size. The output is a 
sequence of amplitude values (A0, A1, A2, ... A(N/2)) at N/2 discrete fre-
quencies. The highest frequency, f(N/2)‐1, is equal to half the sampling 
rate (= 1/(2T), where T is the sampling period, as shown in the figure). 
The output can be plotted as a magnitude spectrum.

In practice, a spectrum is always made over some finite time interval. This 
interval may encompass the full length of a signal, or it may consist of 
some shorter part of a signal.

Spectral analysis of time-varying signals: spectrograms and STFT analysis

Most signals of biological interest change over time in frequency (spectral) 
composition. Indeed the changes in spectrum over time are often among 
the most interesting aspects of such signals. But in order to create a spec‐
trum, we must examine an interval of time— there is no way to measure a 
signal’s “instantaneous” spectrum. An individual magnitude spectrum of 
a signal provides no information about temporal changes in frequency 
composition during the interval over which the spectrum is made. If we 
were to make a single magnitude spectrum over the entire duration of a 
spectrally varying signal such as a typical bird song, we would have a rep‐
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resentation of the relative intensities of the various frequency components 
of the signal, but we would have no information about how the intensities 
of different frequencies varied over time during the signal.  

To see how the frequency composition of a signal changes over time, we 
can examine a sound spectrogram.1 The spectrograms produced by Raven 
plot frequency on the vertical axis versus time on the horizontal; the 
amplitude of a given frequency component at a given time is represented 
by a color (by default, grayscale) value (Figure B.4).

Figure B.4. Spectrogram example.

Figure B.4.  Smoothed sound spectrogram of part of a song of a chest-
nut-sided warbler, digitized at 44.1 kHz.

Spectrograms are produced by a procedure known as the short‐time Fourier 
transform (STFT). The STFT divides the entire signal into a series of succes‐
sive short time segments, called records (or frames). Each record is used as 
the input to a DFT, generating a series of spectra (one for each record). To 
display a spectrogram, the spectra of successive records are plotted side 
by side with frequency running vertically and amplitude at each fre‐
quency represented by  a color (by default, grayscale) value. Raven’s spec‐
trogram slice view displays the spectrum of one record at a time as a line 
graph, with frequency on the horizontal axis, and amplitude on the verti‐
cal axis. A spectrogram can be characterized by its DFT size, expressed as 
the number of digitized amplitude samples that are processed to create 
each individual spectrum.

The STFT can be considered as equivalent in function to a bank of N/2 + 1 
bandpass filters, where N is the DFT size. Each filter is centered at a 
slightly different analysis frequency. The output amplitude of each filter is 
proportional to the amplitude of the signal in a discrete frequency band or 
bin, centered on the analysis frequency of the filter. In this “filterbank” 
model of STFT analysis, the spectrogram is considered as representing the  
time‐varying output amplitudes of filters at successive analysis frequen‐

1. Sound spectrograms are sometimes called sonagrams. Strictly speaking, how‐
ever, the term sonagram is a trademark for a sound spectrogram produced by 
a particular type of spectrum analysis machine called a Sonagraph, produced 
by the Kay Elemetrics Co.
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cies plotted above each other, with amplitude again represented by color 
(by default, grayscale) values. A spectrogram can be characterized by its 
bandwidth, the range of input frequencies around the central analysis fre‐
quency that are passed by each filter. All of the filters in a spectrogram 
have the same bandwidth, irrespective of analysis frequency.

Record length, bandwidth, and the time-frequency uncertainty principle

The record length of a STFT determines the time analysis resolution (Δt) of 
the spectrogram. Changes in the signal that occur within one record (e.g., 
the end of one sound and the beginning of another, or changes in fre‐
quency) cannot be resolved as separate events. Thus, shorter record 
lengths allow better time analysis resolution.

Similarly, the bandwidth of a STFT determines the frequency analysis resolu‐
tion (Δf) of the spectrogram: frequency components that differ by less than 
one filter‐bandwidth cannot be distinguished from each other in the out‐
put of the filterbank. Thus a STFT with a relatively wide bandwidth will 
have poorer frequency analysis resolution than one with a narrower band‐
width.

Ideally we might like to have very fine time and frequency analysis resolu‐
tion in a spectrogram. These two demands are intrinsically incompatible, 
however: the record length and filter bandwidth of a STFT are inversely 
proportional to each other, and cannot be varied independently. Although 
a short record length yields a spectrogram with finer time analysis resolu‐
tion, it also results in wide bandwidth filters and correspondingly poor 
frequency analysis resolution. Thus a tradeoff exists between how pre‐
cisely a spectrogram can specify the spectral (frequency) composition of a 
signal and how precisely it can specify the time at which the signal exhib‐
ited that particular spectrum.

The relationship between record length and filter bandwidth applies to 
each of the individual spectra that collectively constitute a spectrogram. 
Figure B.5 illustrates the relationship between record length and filter 
bandwidth in individual spectra. The two spectra, of a 2000 Hz pure tone 
digitized at 22.05 kHz, were made with different record lengths and thus 
different bandwidths. Spectrum (a), with a record length of 1024 points 
(46.0 mS) , shows a fairly sharp peak at 2000 Hz because of its relatively 
narrow bandwidth (35.3 Hz) filter; spectrum (b), with a record length of 
256 points (11.5 mS), corresponding to a wider bandwidth (141 Hz) filter, 
has poorer frequency resolution.
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Figure B.5. Window length ‐ bandwidth relationship

Figure B.5.  Relationship between record length and 3 dB bandwidth.  
Each view is of a single spectrum of a 2000 Hz tone, digitized at 22.05 
kHz. In both spectra, window function = Blackman. The highlighted 
band in each spectrum shows the 3 dB bandwidth.
(a) Window size = 1024 points = 46.0 mS; 3 dB bandwidth = 35.3 Hz.
(b) Window size = 256 points = 11.5 mS; 3 dB bandwidth = 141 Hz.

Making spectrograms

A spectrogram produced by Raven is a two‐dimensional grid of discrete 
data points on a plane in which the axes are time and frequency. Ordi‐
narily, this grid is not apparent because by default Raven smooths the 
spectrogram display, interpolating color values for pixels that are between 
the gridpoints where values were calculated by the STFT algorithm. If you 
turn off spectrogram smoothing and stretch the time and frequency scales 
adequately, the discrete nature of the spectrogram becomes evident (Fig‐
ure B.6). In a spectrogram displayed with smoothing turned off, the color 
of each box represents an estimate of the logarithm of the relative sound 
power (in decibels) in a particular frequency band over a particular time 
interval. The center point of the box is at the center of the corresponding 
frequency band and time interval. 
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Figure B.6.  Boxy spectrogram

Figure B.6.  Same spectrogram as in Figure B.4, with smoothing 
turned off. The grayscale value in each box represents an estimate of 
the relative power in the corresponding frequency band and time inter-
val. Filter bandwidth = 124 Hz, window size (record length) = 512 sam-
ples (= 11.6 mS). Grid spacing = 5.8 mS x 86.1 Hz.

Raven lets you specify the spacing between gridpoints in the time dimen‐
sion and thus the width of the boxes in an unsmoothed spectrogram. In 
Raven’s Configure Spectrogram dialog, you can specify the time grid 
spacing (also called hop size) directly, or indirectly by specifying the 
amount of overlap between successive records. (You specify the record 
length of a spectrogram in Raven by entering the size of a window function. 
Window functions are discussed in “Window functions” on page 294.) 
The spacing between gridpoints in the frequency dimension is determined 
by the DFT size. Raven chooses DFT size automatically, using the smallest 
power of 2 which is greater than or equal to the window size (in samples).

The relationships between time grid spacing and record overlap, and 
between frequency grid spacing and DFT size are discussed below. See 
Chapter 5, “Spectrographic Analysis”, for a detailed discussion of how to 
control these parameters in Raven.

Grid spacing should not be confused with analysis resolution. Analysis res‐
olution for time and frequency are determined by the record length and 
bandwidth of a STFT, respectively. Analysis resolution describes the 
amount of smearing or blurring of temporal and frequency structure at 
each point on the grid, irrespective of the spacing between these points. 
The following sections seek to clarify the concepts of analysis resolution 
and grid spacing by showing examples of spectrograms that illustrate the 
difference between the two. 

Analysis resolution
and the time-

frequency
uncertainty

principle

At each point on the spectrogram grid, the tradeoff between time and fre‐
quency analysis resolution is determined by the relationship between 
record length and bandwidth, as discussed above. According to the uncer‐
tainty principle, a spectrogram can never have extremely fine analysis res‐
olution in both the frequency and time dimensions.

For example, Figure B.7 shows two spectrograms of the same signal that 
differ in record length and hence, bandwidth. In spectrogram (a), with a 
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record length of 64 points (= 2.9 mS; bandwidth = 496 Hz), the beginning 
and end of each tone can be clearly distinguished and are well‐aligned 
with the corresponding features of the waveform. However, the frequency 
analysis resolution is poor: each tone appears as a bar that is nearly 1200 
Hz in thickness. In spectrogram (c), the record length is 512 points, or 23 
mS (filter bandwidth = 61.9 Hz), or about as long as each tone in the signal. 
Most of the records therefore span more than one tone, in some cases 
including a tone and a silent interval, in other cases including two tones 
and an interval. The result is poor time resolution: the beginning and end 
of the bars representing the tones are fuzzy and poorly aligned with fea‐
tures of the waveform (compare, for example, the beginning time of the 
first pulse in the waveform with the corresponding bar in the spectro‐
gram). However, this spectrogram has much better frequency resolution 
than spectrogram (a): the bar representing each tone is only about 100 Hz 
in thickness.
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Figure B.7. Time vs freq resolution.  

Figure B.7.  Effect of record length and filter bandwidth on time and fre-
quency resolution. The signal consists of a sequence of four tones with 
frequencies of 1, 2, 3, and 4 kHz, at a sampling rate of 22.05 kHz. Each 
tone is 20 mS in duration. The interval between tones is 10 mS. Both 
spectrograms have the same time grid spacing = 1.45 mS, and window 
function = Hann. The selection boundaries show the start and end of 
the second tone.
(a) Wide-band spectrogram: record length = 64 points ( = 2.90 mS), 3 
dB bandwidth = 496 Hz.
(b) Waveform, showing timing of the tones.
(c) Narrow-band spectrogram: record length = 512 points ( =  23.2 mS), 
3 dB bandwidth = 61.9 Hz.
The waveform between the spectrograms shows the timing of the 
pulses.

What is the “best” window size to choose? The answer depends on how 
rapidly the signal’s frequency spectrum changes, and on what type of 
information is most important to show in the spectrogram, given your 
particular application. For many applications, Raven’s default window 
size (512 samples) provides a reasonable balance between time and fre‐
quency resolution. If you need to observe very short events or rapid 
changes in the signal, a shorter window may be better; if precise frequency 
representation is more important, a longer window may be better1. If you 
need better time and frequency resolution than you can achieve in one 

1.  If the features that you’re interested in are distinguishable in the waveform 
(e.g., the beginning or end of a sound, or some other rapid change in ampli‐
tude), you’ll achieve better precision and accuracy by making time measure‐
ments on the waveform rather than the spectrogram.
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spectrogram, you may need to make two spectrograms: a wide‐band spec‐
trogram with a small window for making precise time measurements, and 
a narrow‐band spectrogram with a larger window for precise frequency 
measurements. 

Time grid spacing
and window overlap

Time grid spacing (also called hop size) is the time between the beginnings 
of successive records. In an unsmoothed spectrogram, this interval is visi‐
ble as the width of the individual boxes (Figure B.6). Successive records 
that are analyzed may be overlapping (positive overlap), contiguous (zero 
overlap), or discontiguous (negative overlap). Overlap between records is 
usually expressed as a percentage of the record length.

Figure B.8 illustrates the different effects of changes to record length and 
time grid spacing. The signal is a frequency‐modulated tone that sweeps 
upward in frequency from 4 to 6 kHz, sampled at 22.05 kHz. Spectrograms 
(a) and (c) both have a record length of 512 points (= 23.2 mS; 3 dB band‐
width = 61.9 Hz). (a) was made with 0% overlap (time grid spacing = 23.2 
mS), whereas (c) was made with an overlap of 93.8% (time grid spacing = 
1.45 mS). In the low‐resolution spectrogram (a), each box is as wide as one 
data record, which in turn is one quarter of the length of the tone. The 
result is a spectrogram that gives an extremely misleading picture of the 
signal. Spectrogram (c), with a greater record overlap, is much “smoother” 
than the one with less overlap, and it more accurately portrays the contin‐
uous frequency modulation of the signal. It still provides poor time analy‐
sis resolution, however, because of its large record length— notice the 
fuzzy beginning and end of the spectrogram image of the tone and the 
poor alignment with the beginning and end of the tone in the waveform. 
Comparison of the spectrograms in Figure B.8 demonstrates that 
improved time grid spacing is not a substitute for finer time analysis reso‐
lution, which can be obtained only by using a shorter record.
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Figure B.8. Window size window size ‐ overlap

Figure B.8.  Different effects on spectrograms of changing record 
length (= window size, or time analysis resolution) and time grid spac-
ing. The signal is a frequency-modulated tone, 100 mS long, sampled 
at 22.05 kHz. The tone sweeps upward in frequency from 4 to 6 kHz. 
Spectrograms (a) and (c) have the same window size, but (c) has finer 
time grid spacing (higher record overlap). (c) and (d) have the same 
time grid spacing, but (d) has a shorter record length (finer time analy-
sis resolution).
(a) Record length = 512 points = 23.2 mS (3 dB bandwidth = 61.9 Hz);
Time grid spacing = 23.2 mS (overlap = 0%).
(b) Waveform view, with duration of tone highlighted. 
(c) Record length = 512 points = 23.2 mS (3 dB bandwidth = 61.9 Hz);
Time grid spacing = 1.45 mS (overlap = 93.8%).
(d) Record length = 64 points = 2.9 mS (3 dB bandwidth = 448 Hz);
Time grid spacing = 1.45 mS (overlap = 50%).

Frequency grid
spacing and DFT

size

Frequency grid spacing is the difference (in Hz) between the central analy‐
sis frequencies of adjacent filters in the filterbank modeled by a STFT, and 
thus the size of the frequency bins in a spectrogram. In an unsmoothed 
spectrogram, this spacing is visible as the height of the individual boxes 
(Figure B.6). Frequency grid spacing depends on the sample rate (which is 
fixed for a given digitized signal) and DFT size. The relationship is 

frequency grid spacing = (sample rate) / DFT size
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where frequency grid spacing and sample rate are measured in Hz, and 
DFT size is measured in samples.  Thus a larger DFT size draws the spec‐
trogram on a grid with finer frequency resolution (smaller frequency bins, 
vertically smaller boxes). The number of frequency bins in a spectrogram 
or spectrum is half the DFT size, plus one.

Recall that the DFT size is the number of samples processed to calculate 
the spectrum of a record. Thus the DFT size would ordinarily be equal to 
the record length. However, Raven’s DFT algorithm requires that the size 
of the DFT be a power of 2. Therefore Raven automatically chooses the 
smallest DFT size that is a power of 2 greater than or equal to the record 
size. The sample data in each record are then filled out with zeros (“zero‐
padded”) to make the record length the same as the chosen DFT size. Zero 
padding provides the right number of samples to match the chosen DFT 
size without altering the spectrum of the data.

Spectral smearing
and sidelobes

The spectra that constitute a spectrogram produced by a STFT are “imper‐
fect” in several respects. First, as discussed above, each filter simulated by 
the STFT has a finite band of frequencies to which it responds; the filter is 
unable to discriminate different frequencies within this band. According 
to the uncertainty principle, the filter bandwidth can be reduced— thus 
improving frequency resolution— only by analyzing a longer record, 
which reduces temporal resolution.

Second, the passbands of adjacent filters overlap in frequency, so that 
some frequencies are passed (though partially attenuated) by more than 
one filter (Figure B.9). Consequently, when a spectrum or spectrogram is 
constructed by plotting the output of all of the filters, a signal consisting of 
a pure tone becomes “smeared” in frequency (Figure B.9d).
292 Raven Pro 1.3 User’s Manual 



Appendix B:  A Biologist’s Introduction to Spectrum Analysis
Figure B.9.  Spectral smearing‐‐ overlapping filters

Figure B.9.  Spectral smearing resulting from overlapping bandpass fil-
ters.  (a) A single hypothetical bandpass filter centered at frequency f0. 
When the input to the filter is a pure tone at frequency f0, the output 
amplitude is A0. For clarity of illustration, sidelobes to the main pass-
band are not shown (see text and Figure B.10).  (b) Two overlapping fil-
ters, centered at frequencies f0 and f1. When the filter centered at f1 is 
presented with the same input as in (a), its output amplitude is A1.  (c) A 
bank of overlapping filters simulated by a STFT. Frequency f0 falls 
within the passbands of the filter centered at f0, and of two filters (blue 
and green) on either side.  (d) Spectrum of a pure tone signal of fre-
quency f0 produced by the filterbank shown in (c). The spectrum con-
sists of one amplitude value from each filter. Because the filters 
overlap, the spectrum is smeared, showing energy at frequencies adja-
cent to f0. The shape of the resulting spectrum is the same as that of a 
single filter.
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Third, each filter does not completely block the passage of all frequencies 
outside of its nominal passband. For each filter there is an infinite series of 
diminishing sidelobes in the filter’s response to frequencies above and 
below the passband (Figure B.10). These sidelobes arise because of the 
onset and termination of the portion of the signal that appears in a single 
record. Since a spectrum of a pure tone made by passing the tone through 
a set of bandpass filters resembles the frequency response of a single filter 
(Figure B.9), a STFT spectrum of any signal (even a pure tone) contains 
sidelobes.

Figure B.10. Filter sidelobes

Figure B.10.  Frequency response of a hypothetical bandpass filter 
from a set of filters simulated by a short-time Fourier transform, show-
ing sidelobes above and below the central lobe, or passband. The mag-
nitude of the sidelobes relative to the central lobe can be reduced by 
use of a window function (see text). Note that a spectrum produced by 
passing a pure tone through a set of overlapping filters is shaped like 
the frequency response of a single one of the filters (see Figure B.9).

Window functions The magnitude of the sidelobes (relative to the magnitude of the central 
lobe) in a spectrogram or spectrum of a pure tone is related to how 
abruptly the windowed signal’s amplitude changes at the beginning and 
end of a record. A sinusoidal tone that instantly rises to its full amplitude 
at the beginning of a record, and then instantly falls to zero at the end, has 
higher sidelobes than a tone that rises and falls gradually in amplitude 
(Figure B.11).
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Figure B.11. Windowing  

Figure B.11.  Relationship between abruptness of onset and termina-
tion of signal in one record and spectral sidelobes. Each panel shows a 
signal on the left, and its spectrum on the right.
(a) A single record of an untapered sinusoidal signal has a spectrum 
that contains a band of energy around the central frequency, flanked by 
sidelobes, as if the signal had been passed through a bank of bandpass 
filters like the one shown in Figure B.10.
(b) A single record of a sinusoidal signal multiplied by a “taper” or win-
dow function, has smaller sidelobes.

The magnitude of the sidelobes in a spectrum or spectrogram can be 
reduced by multiplying the record by a window function that tapers the 
waveform as shown in Figure B.11. Tapering the waveform in the record is 
equivalent to changing the shape of the analysis filter (in particular, lower‐
ing it sidelobes). Each window function reduces the height of the highest 
sidelobe to some particular proportion of the height of the central peak; 
this reduction in sidelobe magnitude is termed the sidelobe rejection, and is 
expressed in decibels (Table B.1). Given a particular record length, the 
choice of window function thus determines the sidelobe rejection, and also 
the width of the center lobe. The width of the center lobe in the spectrum 
of a pure tone is the filter bandwidth. 

Table B.1.  Sidelobe rejection for Raven’s five window 
types. The sidelobe rejection for each type is expressed as 
the height of the highest sidelobe relative to the peak of the 
main lobe.

Window type Sidelobe rejection (dB)

Blackman ‐57

Hamming ‐41
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For further reading

The books and articles listed below can provide entry at several levels into 
the vast literature on spectrum analysis and digital signal processing.

Beecher, M. D. 1988. Spectrographic analysis of animal vocalizations: 
Implications of the “uncertainty principle.” Bioacoustics 1:(1): 187‐
207.

Includes a discussion of choosing an “optimum” filter bandwidth 
for the analysis of frequency‐modulated bioacoustic signals. 

Bradbury, J. and S. Vehrencamp. 1998. Principles of Animal Communica‐
tion. Sinauer Associates, Sunderland, MA. 882 pp.

Chapter 3 provides an excellent introduction for non‐specialist 
readers to the principles of spectrum analysis, and also discusses 
spectral properties of the basic types of animal acoustic signals.

Cohen, L.  1995.  Time‐frequency analysis. Prentice‐Hall, Englewood 
Cliffs, NJ.

Hlawatsch, F. and G.F. Boudreaux‐Bartels.  1992.  Linear and quadratic 
time‐frequency signal representations. IEEE Signal Processing 
Magazine, 9(2): 21‐67.

A technical overview and comparison of the properties of a variety 
of time‐frequency representations (including spectrograms), writ‐
ten for engineers.

Jaffe, D. A.  1987.  Spectrum analysis tutorial. Part 1: The Discrete Fourier 
Transform; Part 2: Properties and applications of the Discrete Fou‐
rier Transform. Computer Music Journal, 11(3):  9‐35.

An  excellent introduction to the foundations of digital spectrum 
analysis. These tutorials assume no mathematics beyond high 
school algebra, trigonometry, and geometry. More advanced math‐
ematical tools (e.g., vector and complex number manipulations) 
are developed as needed in these articles.

Hann ‐31

Rectangular ‐13

Triangular ‐25

Table B.1.  Sidelobe rejection for Raven’s five window 
types. The sidelobe rejection for each type is expressed as 
the height of the highest sidelobe relative to the peak of the 
main lobe.

Window type Sidelobe rejection (dB)
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Marler, P. 1969. Tonal quality of bird sounds. In: Bird Vocalizations: Their 
Relation to Current Problems in Biology and Psychology (ed. R. A. 
Hinde), pp. 5‐18. Cambridge University Press.

Includes an excellent qualitative discussion of how the time and 
frequency analysis resolution of a spectrum analyzer interact with 
signal characteristics to affect the “appearance” of a sound either 
as a spectrogram or as an acoustic sensation.

Oppenheim, A.V. and Schafer, R.W. 1975. Digital Signal Processing. Pren‐
tice‐Hall, Englewood Cliffs, NJ. xiv + 585 p.

A classic reference, written principally for engineers.

Rabiner, L.R. and Gold, B.  1975.  Theory and Application of Digital Signal 
Processing. Prentice‐Hall, Englewood Cliffs, NJ. xv + 762 p.

Another classic engineering reference.

Yost, W.A. and Nielsen, D.W.  1985.  Fundamentals of Hearing: An Intro‐
duction. 2d ed. Holt, Rinehart and Winston, New York. x + 269 p.

A good general text on human hearing that includes some discus‐
sion of the elementary physics of sound and an appendix that 
introduces basic concepts of Fourier analysis.
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Appendix C  Configuring Audio Input

About this appendix

This Appendix explains how to use controls provided by your operating 
system to select and adjust the audio device from which Raven gets its 
input when acquiring new signals.

Windows 98, 2000, and XP

Depending on which version of the Windows operating system you’re 
using, the icons and windows you see may appear slightly different from 
those shown here. However, the audio input controls function the same 
way in all versions of Windows.

To access the Windows audio input and output controls, double‐click on 
the speaker icon that is displayed in the icon tray in the Windows task bar 
(Figure C.1).

Figure C.1. Windows icon tray.

Figure C.1.  The Windows icon tray. Double-click on the speaker icon 
to display the Windows audio input and output controls. (You may see 
different icons in the tray, depending on how your system is config-
ured.)

The Volume Control dialog appears (Figure C.2), showing the volume and 
balance settings for various audio output devices. To display the controls 
for audio input devices, choose Options > Properties. In the Properties dia‐
log that appears (Figure C.3), the Mixer device drop‐down menu lists all of 
the sound cards installed in your computer, and lets you choose which one 
to use for audio input. On many computers, only a single sound card is 
installed; its name may differ from that shown in Figure C.3. Click on 
Recording, check the boxes next to all of the sound input devices that you 
may want to use on the list of volume controls at the bottom of the dialog 
box, then click OK.
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Figure C.2.  Windows playback controls.

Figure C.2.  The Windows Volume Control dialog as it’s initially dis-
played, showing Playback controls. Controls for different devices may 
be displayed, depending on system configuration.

Figure C.3. Audio control Properties dialog.

Figure C.3.  The Properties dialog for the Windows audio playback and 
recording devices. The Mixer device name on your computer may differ 
from what’s shown here.
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The Volume Control dialog will be replaced by the Recording Source dia‐
log (Figure C.4). To choose which recording source will be used, check the 
Select box for that device. To adjust the recording level, move the Volume 
slider control..

Changes that you make in this dialog box are reflected immediately in the 
signal reaching Raven. You can thus start a recorder running in Raven and 
then use the Windows audio controls to adjust the recording level. See 
Chapter 4, “Signal Acquisition (Recording)” for a discussion of how to set 
the record level properly.

Figure C.4.  Recording Source controls.

Figure C.4.  The Recording Source controls. Controls for different 
devices may be displayed, depending on system configuration.

Mac OS X

Launch the utility program called Audio MIDI Setup, located in /Applica‐
tions/Utilities. Audio MIDI Setup is supplied with Mac OS X. Click on the 
Audio Devices tab to display controls for choosing a sound input device 
and setting the input (recording) level (Figure C.5).

For Default Input, choose the sound input device that you plan to use with 
Raven. In most cases, this will be Built-in Audio. Under Audio Input (left 

To record from a CD in Windows, you must select the record‐
ing source “Wave Out Mix” that appears in the audio play‐
back Properties dialog (Figure C.3).  After clicking OK, you 
should click the Select checkbox corresponding to Wave Out 
Mix in the Recording Control dialog.
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side of window), choose the Source to use for input to the audio device.  
In most cases, this will be Line In. The choices listed for Source correspond 
to physical input jacks or ports on the computer or external audio device. 
To adjust the recording level, move the Volume slider control.

Changes that you make to the recording level in Audio MIDI Setup are 
reflected immediately in the signal reaching Raven. You can thus start a 
recorder running in Raven and then use the Audio MIDI Setup  controls to 
adjust the recording level. See Chapter 4, “Signal Acquisition (Recording)” 
for a discussion of how to set the record level properly.

Figure C.5. Audio MIDI Setup

Figure C.5.  The Audio Devices screen in the Audio MIDI Setup pro-
gram.

Do not make changes to the audio input format (sample rate, 
number of channels, and sample size) in Audio MIDI Setup 
while Raven is running. Doing so may result in corrupted 
recordings in Raven.
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See  recording a signal
acquisition

See also recording a signal
Activate Selection (selection contextual menu), 129
Activate  Selection N  (selection  contextual menu),
139

active selection, 129
active view, 41–42
active window, 67
aif filename extension, 11
AIFF file format, 11, 77
aliasing, 90, 272–274
Amplify, 24
Amplify Sound dialog box, 134
amplifying, 134
Amplitude Detector, 237
analog‐to‐digital conversion, 271
analysis frequency, 284
analysis resolution, 287–289
annotations, 153

creating, 153
deleting, 154
entering values, 154–155
Fill Down, 155
naming, 153
renaming, 153

anti‐aliasing filter, 274
audio file formats, 11
Audio Format Not Supported error, 96
audio input

configuring under Mac OS, 301
configuring under Windows, 299–301

audio input device
choosing, 16

audio input device plug‐in, 72
audio input plug‐ins, 272
Auto‐apply checkbox

in Color Scheme Editor, 249
in Configure New Spectrogram dialog box, 115
in Configure Spectrogram dialog box, 104

Averaging parameter, 113–114
axis

units, 43
visibility and window presets, 63

B
Background color

desktop, changing, 38, 256
Background Color Editor, 38
Band Limited Energy Detector, 228
Band Pass Filter, 189
bandpass filters (simulated by STFT), 284, 292–294
bandwidth, 285
Bartlett window function, 101
Beamforming, 177
Beamogram

beams, 179
configuring, 179

beams, 179
Bearing analysis, 177
bearing angles, 179
Begin Time measurement, 138, 143, 149
Beta (Kaiser window parameter), 104
Biased, 191
Biased Normalization, 191
bit depth, 275–276
Blackman window function, 101
BMP (graphics) file format, 15
brightness (spectrogram), 60, 116, 118, 247

and window presets, 63
bug reports, 267

C
Canary, opening files in Raven, 6
Cascade Windows, 68
CD

open, 23
ceiling color, 116, 118
ceiling value, 116, 118
Center Position button, 44–45
Channel Visibilities

as linkable properties, 57
channels

hiding, 171
showing, 171

Channels list (side panel), 171
check for updates, 28
Choose Measurements (View menu), 143
Clear Active Selection (View menu), 131
Clear All Selections (View menu), 131
Clear Selection N (selection contextual menu), 131
Clip exporter, 94
Clip File Format, 251
Clip File Names, 251
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clipping (during recording), 86–87
close

all files, 23
selection table, 23
sound file, 23

Collapse Selection Table button, 135
color choosers, 246

HSB, 247
RGB, 248
Swatches, 246

color scheme
spectrograms, 26

Color Scheme Editor, 245, 248
color scheme presets

default, 256
color schemes, 60–250

and window presets, 63
as linkable properties, 57
Auto‐apply checkbox, 249
brightness, 247
color choosers, 246–248
editing, 61, 245–249
elements, 245
HSB color chooser, 247
hue, 247
opacity, 248
presets, 249
RGB color chooser, 248
saturation, 247
Swatches color chooser, 246

colormap
See spectrogram colormap

colormaps, relative power, 61
Command‐backspace, 132
Command‐L, 51
Command‐O, 2, 42
Command‐R, 16
Command‐Shift‐P, 7
Command‐shift‐Z, 132
Command‐Z, 132
Components pane (side panel), 58
components, window, 58
Configure New Recorder dialog box, 16

Advanced button, 89, 92
Buffer Size parameter, 74
Channels checkboxes, 73
Device drop‐down list, 72
Directory parameter, 79
Display tab, 74–76
File Format tab, 76
File Name tab, 78
File Names tab, 78, 82
File Size parameter, 78
Input tab, 72–74

Latency parameter, 75
Rate Conversion tab, 91
recorder presets, 83
Retroactive Recording Offset parameter, 93
Sample Format drop‐down list, 73
Sample Rate drop‐down list, 73
Sample Size parameter, 77
Schedule tab, 92
Simple button, 89, 92
Sound File(s) parameter, 79
Speed tab, 89
Start Time parameter, 81
Update Rate parameter, 75
Window Preset drop‐down list, 76

Configure New Sound Window dialog box, 63, 158,
162

Configure New Spectrogram dialog box, 102–104,
106–108, 115
3 dB bandwidth, 104
Apply button, 115
Auto‐apply checkbox, 115
Averaging parameter, 113–114
DFT Size parameter, 108
Frequency (Grid Spacing) parameter, 108
Overlap parameter, 107
Preset menu, 115
Time parameter, 107
Window Size parameter, 104
Window Size slider control, 104
Window Type parameter, 101

Configure New Spectrogram Slice View dialog box,
51

Configure New Spectrogram View dialog box
Window Size parameter, 103

Configure Paging dialog box, 161
Configure Recorder dialog box

See Configure New Recorder dialog box
Configure Recorder... (contextual menu), 88
Configure Selection Spectrum dialog box, 101
Configure Spectrogram dialog box

See Configure New Spectrogram dialog box
Configure Spectrogram Slice dialog box, 101
Configure Spectrum dialog box, 101
Configure View Axes dialog box, 46
Configuring a beamogram, 179
contextual menus, 58
contrast (spectrogram), 60, 116, 118

and window presets, 63
control points

selection, 140
Control toolbar, 1
control toolbar, 1–2
Copy, 10, 24
Copy (Edit menu), 10, 132
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Copy Image Of, 24
Copy  Selected  Rows  (selection  table  contextual
menu), 142

Correlation types, 185
Correlator, 27
create a new view, 25
Ctrl‐backspace, 132
Ctrl‐G, 55
Ctrl‐L, 51
Ctrl‐N, 10
Ctrl‐O, 2, 42
Ctrl‐R, 16
Ctrl‐Shift‐P, 7
Ctrl‐shift‐Z, 132
Ctrl‐Z, 132
Current Heap Size, 263
current page

See under paged sound windows
Cut, 24
Cut (Edit menu), 132

D
date tags (in file name templates), 80
dd tag (in file name templates), 80
Deactivate Selection (View menu), 131
decimation

See also sample rate conversion
Decimation Factor parameter, 91
during signal acquisition, 90
usefulness of, 91

Decimation Factor, 91
default directories, 258–259
default measurement precision, 259–261
default presets, 254–255
Delete, 24
Delete (Edit menu), 132
Delete View (View menu), 58
deleting a view, 58
Delta Frequency measurement, 150
Detect in Batch, 27
Detection

configure, 220
detector active, 220
full, 212
interactive, 212
real‐time, 212
run full, 220

detection, 211
Detection tab (side panel), 33
Detector, 251

Clear Selections, 220
Detector Active, 220
device unavailable (for signal acquisition), 96

device unavailable error (for signal acquisition), 96
DFT (discrete Fourier transform), 282–283
DFT Size

lock icon, 109
DFT size, 108–109, 284, 287, 291–292
DFT Size parameter, 108–109
digitizing error, 275
Directory parameter (recording to file(s)), 79
discrete Fourier transform (DFT), 98, 282–283
Display tab (Configure New Recorder dialog box),
74, 76

docked, side panel, 34
Docking controls, 34
Documentation, 28
dynamic range, 275

E
Edit > Copy, 10
Edit > Paste, 10
Edit menu

Amplify..., 134
Copy, 10, 132
Copy Image Of, 15
Cut, 132
Delete, 132
Filter > Around Active Selection, 133
Filter > Around All, 133
FIlter > Out Active Selection, 133
FIlter > Out All, 133
Filter Active Selection With, 133
Filter Active Selection With > Other, 133
Filter All With, 133
Filter All With > Other, 133
Paste, 10, 132
Redo, 132
Undo, 132

email (from within Raven), 268
End Time measurement, 138, 143, 150
Energy Detector, 228
EPS (graphics) file format, 15
errors

Audio Format Not Supported, 96
device unavailable, 96
Out‐of‐memory, 263

Expand Selection Table button, 135
exporting clip files, 94
exporting images, 23
exporting samples, 23
extender point, See under  selection  control points,
128
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F
false negative, 215
false positive, 215
fast Fourier transform (FFT), 283
FFT (fast Fourier transform), 283
File > Exit, 23
file boundary markers (in file sequence views), 164
File  Format  tab  (Configure New Recorder dialog
box), 76

file formats
AIFF, 11, 77
for recording to file(s), 77
WAVE, 77

File menu
Email Feedback, 267
Export Image Of, 15
New Recorder..., 16, 72
New Sound Window, 10
Open Selections..., 138
Open Sound File Sequence..., 162
Open Sound Files..., 2
Open Workspace..., 13
Print “Sound N” > To Printer..., 15
Printer Page Setup, 15
Save “Sound N”, 12
Save “Sound N” As..., 12
Save Active Selection As..., 141
Save All Selections..., 142
Save Selection Table As..., 138
Save Workspace As..., 13

file name collisions (recording to file(s)), 81
File  Name  tab  (Configure  New  Recorder  dialog
box), 78

file name templates, 79
File Names  tab  (Configure New Recorder  dialog
box), 82

file naming (recording to file(s)), 78–80
file sequences, 161–164

choosing files individually, 163
Cut operations, 161
Delete operations, 161
Edit operations, 161
individual file selection, 163
list files, 161, 163
Paste operations, 161

Filter, 24
applying a saved preset, 133

Filter > Around (Edit menu), 133
filter bandwidth, 104
Filter Out (Edit menu), 133
filterbank (model of STFT analysis), 284
filtering, 133
Filtering (selected frequency band), 133

Filters
defining your own, 133
saving your own, 133

floor color, 116, 118
floor value, 116, 118
Format  Column...  (selection  table  contextual
menu), 151

FP, 215
frames (in short‐term Fourier transform), 284
Frequency (Grid Spacing) parameter, 108
frequency analysis resolution, 285
frequency domain, 280
frequency grid spacing, 108–109, 291–292
Full detection, 212

G
Graphics export

See  Image export, 15
gray background (in views), 43
grid spacing, 287

See also time grid spacing, frequency grid spac‐
ing

Group By Time, 65, 67
Group By View, 65–66
grouping (lines, views, channels), 65–67
Grouping options (side panel, Layout tab), 65–67

H
Hamming window function, 101
Hann window function, 101
Hanning window function, 101
heap, 262
hh tag (in file name templates), 80
hidden, side panel, 34
hide all button, 35
Hide All Channels, 171
Hide All Views, 36
Hide View (View menu), 58
hiding/showing channels, 171
High Frequency measurement, 138, 143, 150
hop size, 106–108
Hop Size parameter, 106–107
HSB color chooser, 247
hue, 247

I
Image export

to file, 15
via clipboard, 15

Information, 33
Interactive detection, 212
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J
Java Virtual Machine (JVM), 262
JPEG (graphics) file format, 15
JVM (Java Virtual Machine), 262

K
Kaiser window function, 101, 104

L
lag, 185
landscape orientation (for printing), 15
Layout tab (side panel), 33, 36, 41

Channels list, 171
Components list, 58
Grouping options, 65
hiding/showing window components, 58
Lines box, 65

line titles, 59
visibility and window presets, 63

Lines box (side panel, Layout tab), 65
linkable properties, 55, 57
linkage (of views), 44, 53–58

creating, 55
linkable properties, 55, 57
linkage groups, 55–56
linked spectrographic views, 56
restoring, 55
unlinking views, 55

linkage groups, 55
creating, 56

Linkage tab (side panel), 55, 67
list files (for file sequences), 82, 161–163
ll tag (in file name templates), 80
Lock DFT Size, 109
Lock Hop  Size  (in Configure  Spectrogram dialog
box), 108

lock  icons (in Configure New Spectrogram dialog
box), 108

Lock  Overlap  (in  Configure  Spectrogram  dialog
box), 108

lock, toolbar, 29
Look and Feel, changing, 38, 256
Low Frequency measurement, 138, 143, 150
Lowpass filter

time lag, 240

M
magnitude spectrum, 281–282
Max Frequency measurement, 146
Max Power measurement, 146
Max Time measurement, 149

maximum heap size, 263
See also memory allocation

Measurement Chooser dialog box, 143–144, 152
measurement list

and window presets, 63
measurement presets

<Italic
See also <Default para font>measurements

presets, 151
default, 255

measurements, 26, 135, 143
choosing, 143
format, 151
precision, 151
precision, default, 259–261
presets, 151

Memory allocation
out‐of‐memory errors, 263

memory allocation, 262
heap size, 262
maximum heap size, 263

Memory Manager, 261–265
Current Heap Size, 263
Memory Available, 263
memory usage list, 264
memory usage summary, 263
Memory Used, 263
Reclaim button, 265
reclaiming unused memory, 265

memory usage list, 264
memory usage summary, 263
Memory Used, 263
Menu bar, 1, 21
menu bar, 1–2, 21
Min Time measurement, 149
mm tag (in file name templates), 80
most recently used files, 23
Mouse measurement field, 37
mouse measurement field, 37
Move View Down (View menu), 58
Move View Up (View menu), 58
mp3, cannot play variable bitrate files, 6
multi‐channel sounds, 172, 175

editing, 172
hiding/showing channels, 171
selecting channels, 175

multiple‐line views, 64
grouping, 65

N
n (in file name templates), 80
new

recorder, 22
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sound window, 22
New Recorder... (File menu), 72
New Sound Window (File menu), 10
New view, creating, 50
Normalization, 190
Number of Lines

as linkable properties, 57
Nyquist frequency, 272–274

O
opacity, 248
Open

.mp3, .mp4, .aifc, .mov formats, 6
CD audio tracks, 6

open
existing sound file, 23
recent folder, 23

open from a CD, 23
Open Recent Folder, 6
Open Selections... (File menu), 138
Open Sound File Sequence dialog box, 162
Open Sound File Sequence... (File menu), 162
Open Sound Files, 3
Open Sound Files dialog box, 2–3, 165
Open Sound Files... (File menu), 2

multiple files, 165
Open, Canary files, 6
oscillogram, 7
overlap, 287
Overlap parameter, 106–107
overwriting files (during acquisition), 261

P
padlock icons (in Configure New Spectrogram dia‐
log box), 108

Page Back button, 160
Page Forward button, 160
page increment, 158, 160

reconfiguring, 161
page navigation panel

See under  paged sound windows
page setup, 23
page size, 158

reconfiguring, 161
page, See  paged sound windows
paged sound windows, 157

configuring, 158
current file indicator, 160
current page, 157
editing prohibited, 157
jump to file, 160
jump to time, 160

Page Back button, 160
Page Forward button, 160
page increment, 158, 160–161
page navigation panel, 159–160
page size, 158, 161
paging scrollbar, 160
selectins in, 160
Step Back button, 160
Step Forward button, 160
step increment, 158, 160–161

paging scrollbar, See underpaged sound windows
Paste, 10, 24
Paste (Edit menu), 10, 132
PCM (Pulse Code Modulation), 73
Peak Time measurement, 149
phase, 281
phase spectrum, 281–282
Play button, 7
play, recording, playing while recording, 86
Play, Spectrogram slice or selection spectrum, 8
playback rate, 9, 32
Playback tab (side panel), 33
playing a sound, 7
playing while recording, 86
PNG (graphics) file format, 15
point selections, 127, 130
portrait orientation (for printing), 15
position (of a view), 45

setting, 46
vs. position location, 45

position location, 45
vs. position, 45

Position markers, 8
position markers, 44, 46

visibility and window presets, 63
Power Spectra Calculation

comparing two methods, 257
New method, 100, 257

power to color correspondance in colormaps, 61
preference file, 253
preferences, 252–269

default directories, 258–259
default measurement precision, 259–261
default presets, 254–255
overwriting files (during acquisition), 261

Preset Manager, 250
Preset menu

See presets, 115
presets

Audio File Format, 251
Audio File Names, 251
Audio Recorder, 251
Audio Recorder Display, 251
Audio Recorder Input, 251
308 Raven 1.2 User’s Manual



Index
Audio Recorder Schedule, 251
Color Scheme, 251
color scheme, 249
measurement, 151
Measurement List, 251
recorder, 83
Sample Rate Conversion, 251
Selection Labels, 251
Sound Window, 251
spectrogram, 115
Spectrogram Parameters, 251
types, 251
window, 63
window, precedence over other presets, 64

print a sound file, 23
print orientation, 15
printing, 15
progress bar, 85–86
Pulse Code Modulation (PCM), 73

Q
quantization noise, 275
QuickTime installer, 28
QuickTime Installer, downloading, 6
QuickTime on Mac OS, 6
QuickTime, opening sound files, 6

R
range selections, 127–128
Rate Conversion tab (Configure New Recorder dia‐
log box), 91

Raven desktop, 1–2
Raven license agreement, 28
Raven User’s Manual, 28
Raven web site, 28
Raven window, 1
RavenPreferences.txt file

See preference file
read about updates, 28
Real‐time detection, 212
real‐time views (during signal acquisition), 18

waveforms, 18
real‐time views (during signal acqusition), 85
Reclaim button, 265
reclaiming unused memory, 265
Record button, 16, 72
record length, 285
Record To drop‐down list, 72
recorder presets, 83

default, 255
recorder windows, 18, 71, 84–85, 87, 94

See also recording a signal

editing in, 88
progress bar, 85–86
reconfiguring, 88
Record‐to‐Disk button, 84, 86
Record‐to‐Memory button, 84–85
Stop Recording button, 85
Stop‐Recording‐to‐Disk button, 86

recorders, 71
creating, 72
parameters, 72

recording a signal, 16, 18, 71
See  also Configure New Recorder dialog box;
recording modes

buffer size, 74
channels, choosing, 73
display configuration, 74–76
display latency, 75
file size, 78
input configuration, 72–74
latency, 75
processing latency, 75
recorder presets, 83
recording buffer, 75
recording level, 86
recording parameters, 72
retroactive, 93
sample format, 73
sample rate, 73
sample rate conversion during, 90–92
sample size, 73, 77
speed correction, 88–89
to a file sequence, 82
to file(s), 76, 86
to memory, 85
update rate, 75
window presets and recorder windows, 76

recording modes, 71–72
choosing, 72
record to file, 72
record to file sequence, 72
record to memory, 71

records (in short‐time Fourier transform), 284
records (in spectrographic views), 98
Record‐to‐Disk button, 84, 86, 93
Record‐to‐Memory button, 18, 84–85
rectangular window function, 101
Redo, 24
Redo (Edit menu), 132
redo a change, 24
rendering data

entries in Memory Manager, 264
resize the side panel, 35
retroactive recording (to files), 93
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Retroactive Recording Offset parameter (Configure
New Recorder dialog box), 93

RGB color chooser, 248
Run Full, 220

S
sample frame, 78
sample rate conversion

during recording, 90–92
sample size, 73, 275–276
samples

internal floating‐point representation, 276
sampling, 271
sampling rate, 272–273, 275
saturation (in HSB color chooser), 247
Save Active Selection As... (File menu), 141
Save All Selections, 142
Save Color Scheme Preset dialog box, 249
Save Sound Window Preset dialog box, 63
scale (of a view), 46, 48

default, 46
resetting, 49
setting, 46
zoom in, 48
zoom out, 48

scheduled recording, 92
scroll thumb, 9, 42
scrollbars, 42

paging, 160
visibility and window presets, 63

Scrolling Play, 8
Scrolling playback, 8
See also recording a signal
Select All, 24
Selectable look and feel, 38, 256
selection, 8, 135
selection bounds, 139, 143
selection control points, 128

active, 128
extender point, 128

selection files, 139
format, 139
retrieving, 138

selection ID, 128, 135
selection label, 128
selection labels

configuration, 63
visibility, 63

selection number, 135
Selection spectrum

play, 8
selection spectrum views, 97–98, 100, 125

creating with linked parameters, 56

selection table
Activate Next Selection button, 140
Activate Previous Selection button, 140
Down arrow button, 140
Up arrow button, 140

selection tables, 135, 138, 143
and paged sound windows, 141
collapsing, 135
configuring, 138, 151
copying rows, 142
expanding, 135
saving, 138
sort order, 138
visibility and window presets, 63
visibility of entries, 137

selections, 127–128, 131–132, 138, 143
activating, 129, 139
active, 129
active selection, 129
bounds, 143
clearing, 131
copying, 10, 132
creating, 127–128
cutting, 132
deactivating, 131
defining, 127–128
deleting (data), 132
ID, 135
inactive, 129
modifying, 128
modifying bounds, 140
modifying channels, 141
multi‐channel, 177
number, 135
pasting, 10, 132
point, 127, 130
range, 127–128
removing, 131
renumbering, 132
retrieving, 138–139
saving active selection, 141
saving all, 142
spanning page boundaries, 160

sequence tags (in file name templates), 80
short‐time Fourier transform (STFT), 284
show all button, 35
Show All Channels, 171
Show All Views, 36
showing/hiding channels, 171
Side panel, 1
side panel, 1–2

docking, side panel
hiding, 34

side panel, resizing, 35
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sidelobe rejection, 101, 295
sidelobes, 101, 292–294
signal acquisition, 71

See recording a signal
Smooth Spectrogram (View menu), 121–123
SMTP (Standard Mail Transfer Protocol) server, 269
sonagrams, 284
Sound files

opening, 3
opening recent, 6

sound files
AIFF format, 11
opening, 2
opening multiple, 165
WAVE format, 11

sound pressure, 279–280
sound window

activating, 67
closing, 41
minimizing, 41
moving, 41
printing, 15
resizing, 41

sound window presets
default, 255

sound window selection, 27
Sound Windows

Cascade, 68
Tile, 68

Sound windows
properties, applying to all, 70

sound windows
paged, 157

spectral smearing, 292–294
spectrogram caching

Memory Used, and, 264
spectrogram colormap, 60
Spectrogram Parameters... (View menu), 125
spectrogram presets, 115

default, 254
Spectrogram slice

play, 8
Spectrogram Slice view, 50
spectrogram slice view

significance of spectrum values, 124
time position, 123

spectrogram slice view, blank, 52
spectrogram slice views, 37, 58, 97–98, 123–124

creating with linked parameters, 56
“hidden” time axis, 57
linkage to spectrogram views, 57–58
time position of, 57

spectrogram smoothing, 286–287
Spectrogram view, 50

spectrogram view, 7
spectrogram views, 97–98, 115–116, 118, 120–123

brightness, 60, 116, 118
caching of data, 264
changing parameters, 125
colormap, 60
contrast, 60, 116, 118
creating, 60
creating with linked parameters, 56
linkage to spectrogram slice views, 57–58
parameters

and window presets, 63
significance of color (grayscale) values, 115
smoothing, 120–123
speed of calculation, 277
time alignment of data, 118–120

spectrograms, 119, 121–122, 284, 286–288, 290–295
spectrum averaging, 113–114
spectrum source data, 118
spectrum time, 118
Speed correction, 5
speed correction (during signal acquisition), 88
Speed tab (Configure New Recorder dialog box), 89
ss tag (in file name templates), 80
start time (for naming recorded files), 81
Step Back button, 160
Step Forward button, 160
step increment, 158, 160

reconfiguring, 161
STFT (short‐time Fourier transform), 284
Stop [playback] button, 8
Stop Recording button, 18, 85
Stop‐Recording‐to‐Disk button, 86
storage requirements, 277
support (for Raven), 267
Swatches color chooser, 246

T
tags (in file name templates), 80
technical support, 267
3 dB bandwidth

See filter bandwidth
TIFF (graphics) file format, 15
Tile Windows, 68
time analysis resolution, 285
Time axis marker, 8
Time axis position marker, 8
time domain, 280
time grid spacing, 107, 287, 290–291
time grid spacing (hop size), 106
time offset, 185
Time parameter, 107
time tags (in file name templates), 80
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time‐frequency uncertainty principle, 285–289
TN, 217
toolbar

lock/unlock, 29
tooltips, 1
TP, 216
triangular window function, 101
true negatives, 217
true positives, 216

U
Unbiased, 191
Unbiased Normalization, 191
uncertainty principle

See time‐frequency uncertainty principle
Undo, 24
Undo (Edit menu), 132
undo a change, 24
undocked, 34
Unlink View (View menu), 55
unlinking views, 54–55
unlock, toolbar, 29
unrecoverable errors, 268
Updates, 28
updates (software and documentation), 265

V
variable bitrate mp3 files, 6
View menu

Apply To All, 70
Choose Measurements, 143
Clear Active Selection, 131
Clear All Selections, 131
Color Scheme > Colormap‐name, 60
Color Scheme > Edit..., 61, 245
Color Scheme > Reverse Color Map, 61
Deactivate Selection, 131
Delete View, 58
Hide View, 58
Move View Down, 58
Move View Up, 58
New > Similar Selection Spectrum View, 56
New > Similar Spectrogram Slice View, 56
New > Similar Spectrogram View, 56
New > Spectrogram Slice View..., 51
Smooth Spectrogram, 121–123
Spectrogram Parameters..., 125
Unlink View, 55
Window Preset > Preset‐name, 63
Window Preset > Save “Preset‐name”, 64
Window Preset > Save As..., 63

view selection button, 41

visibility and window presets, 63
views

deleting, 58
display order of, 58
multiple lines, 64–65

W
wav filename extension, 11
WAVE file format, 11, 77
Waveform view, 50
waveform view, 7
What’s New, 28
window

See sound window
Window > Background Color..., 38, 256
Window > Look and Feel, 38, 256
window components

hiding, 58
See components, window
showing, 58

window functions, 101, 103–104, 294–295
Bartlett, 101
Blackman, 101
Hamming, 101
Hann, 101
Hanning, 101
rectangular, 101
triangular, 101

Window menu
Memory Manager, 262

window overlap, 107, 290–291
window overlap (in spectrograms), 107
Window preset, 4
window presets, 25, 63

and recorder windows, 76
precedence over other presets, 64

window size, 63
choosing, 289

Window Size parameter, 103–104
Window Size slider control, 104
Window Type parameter, 101
windows

bring to front, 27
Windows menu, 68
Workspace files

opening with missing/moved sound file(s), 13
Workspace Resolver Dialog, 14
Workspaces

opening (drag and drop), 13
workspaces, 13

default, 258
opening, 13
saving, 13
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wsp filename extension, 13

Y
yy tag (in file name templates), 80

Z
Zoom In button, 48
Zoom Out button, 48
Zoom‐to‐All button, 49
Zoom‐to‐Selection button, 49
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